summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* net-irc/weechat: respect PYTHON_SINGLE_TARGET settingTim Harder2016-03-312-2/+151
| | | | | | Previously it would only build against python2.7. Patch thanks to Oleg in bug #577638.
* net-irc/quassel: EAPI 6Johannes Huber2016-03-282-18/+18
| | | | Package-Manager: portage-2.2.28
* net-irc/quassel: Remove vulnerable versionJohannes Huber2016-03-271-211/+0
| | | | | | Gentoo-bug: 568150 Package-Manager: portage-2.2.28
* net-irc/quassel: ppc stable wrt bug #568150Agostino Sarubbo2016-03-271-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-irc/irssi: Version bump.Patrice Clement2016-03-262-0/+73
| | | | Package-Manager: portage-2.2.26
* net-irc/quassel: Remove oldJohannes Huber2016-03-261-218/+0
| | | | Package-Manager: portage-2.2.28
* net-irc/quassel: Restore armJohannes Huber2016-03-261-1/+1
| | | | Package-Manager: portage-2.2.28
* net-irc/quassel: Restore x86Johannes Huber2016-03-261-1/+1
| | | | Package-Manager: portage-2.2.28
* net-irc/quassel: Restore ppcJohannes Huber2016-03-261-1/+1
| | | | Package-Manager: portage-2.2.28
* net-irc/inspircd: bump to vn. 2.0.21Ian Delaney2016-03-264-0/+389
| | | | | | | | | | | patches to bump ebuild and fix build paths sunbmitted by the proxy maintainer via the gentoo bug. Keyword arm intially tested fine however requires keywording in required dep, held back for later. Gentoo bug: #575956 Package-Manager: portage-2.2.28
* net-irc/znc: Add missing slot op to ICU dependencyAndreas K. Hüttel2016-03-251-1/+1
| | | | Package-Manager: portage-2.2.28
* net-irc/unrealircd: Fix duplicate showlistmodes useflag description.Nathan Phillip Brink2016-03-231-2/+1
| | | | Package-Manager: portage-2.2.26
* net-irc/znc: update LICENSE for older ebuildsLouis Sautier2016-03-215-10/+10
| | | | | | | Gentoo-Bug: https://bugs.gentoo.org/571366 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1104
* net-irc/znc: update metadata, add myself as proxied maintainerLouis Sautier2016-03-211-7/+20
| | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1086
* net-irc/znc: remove oldLouis Sautier2016-03-211-186/+0
| | | | | Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1086
* net-irc/znc: bump to 1.6.3, EAPI=6Louis Sautier2016-03-213-0/+149
| | | | | | | | | | | | | | | | | | - use the proper LICENSE - remove the ZNC_DATADIR variable - the libressl patch is no longer required → drop patch - swig is not needed to build bindings from a release, removed from DEPEND - configure uses python3 by default → don't specify it any more - move informational postinst messages to a README.gentoo file - fix the systemd unit by setting a valid HOME for the znc user - delete the custom src_unpack function, provide the full path to gtest Gentoo-Bug: https://bugs.gentoo.org/567344 Gentoo-Bug: https://bugs.gentoo.org/571366 Gentoo-Bug: https://bugs.gentoo.org/521916 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1086
* net-irc/kvirc: Call cmake-utils_src_prepare().Arfrever Frehtes Taifersar Arahesis2016-03-161-0/+2
| | | | It will result in call to epatch_user().
* net-irc/kvirc: Stop using deprecated functions from cmake-utils.eclass.Arfrever Frehtes Taifersar Arahesis2016-03-161-25/+26
|
* net-irc/irssi: Add test restriction, bug #577404Sven Wegener2016-03-151-0/+2
| | | | Package-Manager: portage-2.2.26
* net-irc/quassel: x86 stable wrt bug #568150Agostino Sarubbo2016-03-151-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-irc/irssi: Remove ipv6 USE flag from live ebuildSven Wegener2016-03-131-3/+2
| | | | Package-Manager: portage-2.2.26
* net-irc/irssi: Update live ebuildSven Wegener2016-03-131-11/+16
| | | | Package-Manager: portage-2.2.26
* net-irc/irssi: Version bump, bug #577336Sven Wegener2016-03-132-0/+71
| | | | | | This also enables true color support for bug #552510. Package-Manager: portage-2.2.26
* net-irc/quassel: Add use flag snorenotifyJohannes Huber2016-03-125-5/+234
| | | | | | | Gentoo-bug: 574496 Reported-by: Michael Palimaka <kensington@gentoo.org> Package-Manager: portage-2.2.28
* net-irc/irker: Version bumpBertrand Jacquin2016-03-092-0/+56
| | | | | | | | | | | | irker now suports python3. See-Also: https://gitlab.com/esr/irker/commit/9311a6d7b6c1522f338f010d3e1a6b741c031325 This series of commits closes #896. Pull-Request: https://github.com/gentoo/gentoo/pull/896 Acked-by: Patrick Lauer <patrick@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: portage-2.2.26
* net-irc/irker: Default logging is now syslog instead of fileBertrand Jacquin2016-03-092-11/+4
| | | | | | | | This behaviour appeared in version 2.9. Handle IRKERD_LOGFILE checkpath only when IRKERD_LOGFILE is defined as IRKERD_LOGLEVEL is independant. Package-Manager: portage-2.2.26
* net-irc/irker: irk and irkerhook.py are not python3 friendlyBertrand Jacquin2016-03-095-5/+5
| | | | | | | | | | | | | | | | | | $ /usr/lib/python-exec/python3.4/irk foo bar Traceback (most recent call last): File "/usr/lib/python-exec/python3.4/irk", line 50, in <module> main() File "/usr/lib/python-exec/python3.4/irk", line 41, in main message = message.decode('string_escape') AttributeError: 'str' object has no attribute 'decode' $ /usr/lib/python-exec/python3.4/irkerhook.py File "/usr/lib/python-exec/python3.4/irkerhook.py", line 432 print message ^ SyntaxError: Missing parentheses in call to 'print' Package-Manager: portage-2.2.26
* net-irc/irker: Install systemd service on every system.Bertrand Jacquin2016-03-091-1/+7
| | | | | | | | | | Makefile uses `pkg-config --variable=systemdsystemunitdir systemd` to determine in which directory systemd service file should be installed. It can be empty if building host has no systemd installed but OpenRC. Rely on systemd eclass. Package-Manager: portage-2.2.26
* net-irc/irker: Add missing die on sedBertrand Jacquin2016-03-095-10/+15
| | | | Package-Manager: portage-2.2.26
* net-irc/irker: Prune old versionsBertrand Jacquin2016-03-095-87/+0
| | | | Package-Manager: portage-2.2.26
* net-irc/kvirc: amd64 stable wrt bug #576204Agostino Sarubbo2016-03-071-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-irc/polari: sort keywordsAlexandre Rostovtsev2016-03-061-1/+1
| | | | Package-Manager: portage-2.2.27
* Merge remote-tracking branch 'remotes/github/pr/979'Alexandre Rostovtsev2016-03-061-0/+33
|\ | | | | | | net-irc/polari dep fixes and keywording from anthonyryan1; acked by steev
| * net-irc/polari: Add missing RDEPEND on net-im/telepathy-loggerAnthony Ryan2016-03-061-0/+33
| | | | | | | | | | | | | | Also added ~arm keyword as a result of personal testing on a RK3288 (armv7a) device. Package-Manager: portage-2.2.26
* | net-irc/polari: x86 stable wrt bug #566378Mikle Kolyada2016-03-061-1/+1
| | | | | | | | Package-Manager: portage-2.2.26
* | net-irc/eggdrop: add myself as proxied maintainerLouis Sautier2016-03-041-1/+13
| | | | | | | | Package-Manager: portage-2.2.27
* | net-irc/eggdrop: fix a race condition in make, fixes #533490Louis Sautier2016-03-041-1/+1
| | | | | | | | Package-Manager: portage-2.2.27
* | net-irc/eggdrop: bump to EAPI=6, fix a QA warningLouis Sautier2016-03-042-5/+19
| | | | | | | | | | | | | | Add a patch to fix a compilation warning. Taken from eggheads/eggdrop@7570148085cd33f12ba30897e27e6064c202f12b Package-Manager: portage-2.2.27
* | net-irc/eggdrop: fix compilation with gcc-5 #571004Louis Sautier2016-03-042-1/+54
|/ | | | | | Backport patch from https://github.com/eggheads/eggdrop/issues/123 Package-Manager: portage-2.2.27
* Add libressl support to many packagesJason A. Donenfeld2016-03-022-4/+4
| | | | | Package maintainers will likely want to cleanup various things for this experimental USE flag.
* net-irc/quassel: remove proxy maintainer and g-p-m from metadata.xmlIan Delaney2016-02-291-0/+1
| | | | | | | | | maintainer provided consent to withdraw prox maintainer status via email: From: Manuel Nickschas <sputnick@quassel-irc.org> Subject: Re: quassel Date: Sat, 27 Feb 2016 15:08:46 +0100 Package-Manager: portage-2.2.26
* net-irc/quassel: remove proxy maintainer and g-p-m from metadata.xmlIan Delaney2016-02-291-8/+0
| | | | Package-Manager: portage-2.2.26
* metadata.xml: Add maintainer-needed comment to packages without maintainer.Ulrich Müller2016-02-2833-0/+33
| | | | Bug: 575810
* net-irc/polari: amd64 stable, bug 566378Pacho Ramos2016-02-221-1/+1
| | | | | Package-Manager: portage-2.2.27 RepoMan-Options: --include-arches="amd64"
* Remove masked for removal packagesPacho Ramos2016-02-205-88/+0
|
* net-irc/quassel: amd64 stable wrt bug #568150Agostino Sarubbo2016-02-111-1/+1
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* net-irc/quassel: BumpPatrick Lauer2016-02-102-0/+219
| | | | Package-Manager: portage-2.2.27
* net-irc/kvirc: Version bump.Arfrever Frehtes Taifersar Arahesis2016-02-012-0/+136
|
* net-irc/kvirc: Improve dependency on dev-lang/perl.Arfrever Frehtes Taifersar Arahesis2016-01-311-2/+2
|
* Change deps to new fork of dev-python/socksipyJustin Lecher2016-01-293-3/+3
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>