summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* x11-drivers/xf86-video-mga: Drop old versionsMatt Turner39 hours2-20/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-input-synaptics: Drop old versionsMatt Turner39 hours2-44/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 510.85.02 for amd64Ionen Wolkens43 hours1-1/+1
| | | | | | | Still keeping 0/510 over 0/515 in stable for now, although will probably look at replacing it soon'ish. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 470.141.03 for amd64Ionen Wolkens43 hours1-1/+1
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 390.154 for amd64, x86Ionen Wolkens43 hours1-1/+1
| | | | | | | Note I barely test 390.xx runtime anymore, doesn't help that my old 560ti that I normally don't use keeps falling off the bus. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: note 0/470 wayland is a bit on abandonIonen Wolkens43 hours1-1/+2
| | | | | | | | | e.g. pure wayland vulkan barely works, and seeing other oddities that I doubt will ever be resolved and EGLStream support may get dropped altogether. egl-wayland-1.1.7 is also unlikely to get updates and this doesn't work with 1.1.10. Best try to discourage for later. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 arm64, #861023Arthur Zamarin2 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 ppc, #861023Arthur Zamarin4 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 ppc, #861023Arthur Zamarin4 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 ppc64, #861023Arthur Zamarin4 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 ppc64, #861023Arthur Zamarin4 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-input-synaptics: Stabilize 1.9.2 arm, #861023Arthur Zamarin4 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* x11-drivers/xf86-video-mga: Stabilize 2.0.1 sparc, #861023matoro4 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* x11-drivers/nvidia-drivers: drop 515.57Ionen Wolkens12 days2-514/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.65.01Ionen Wolkens2022-08-022-0/+514
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 510.85.02Ionen Wolkens2022-08-022-0/+478
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 470.141.03Ionen Wolkens2022-08-022-0/+467
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 390.154Ionen Wolkens2022-08-022-0/+444
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-video-nv: Version bump to 2.1.22Matt Turner2022-07-272-0/+12
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-video-mga: x86 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-synaptics: x86 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-video-mga: amd64 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-synaptics: amd64 stable wrt bug #861023Agostino Sarubbo2022-07-261-1/+1
| | | | Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-wacom: Drop old versionsMatt Turner2022-07-212-78/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.10:0/vulkan, drop 515.49.06Ionen Wolkens2022-07-212-3/+5
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-wacom: Version bump to 1.1.0Matt Turner2022-07-172-0/+82
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-video-mga: Version bump to 2.0.1Matt Turner2022-07-102-0/+19
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/xf86-input-synaptics: Version bump to 1.9.2Matt Turner2022-07-102-0/+46
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: drop 515.48.07-r1Ionen Wolkens2022-07-032-508/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.06:0/vulkan, del 515.49.05-r1Ionen Wolkens2022-07-032-5/+4
| | | | | | | Also depend on >=egl-wayland-1.1.10 given libnvidia-vulkan-producer now has wlEglCreateSurfaceExport Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* */*: reassign polynomial-c's packagesJoonas Niilola2022-06-291-4/+1
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.57Ionen Wolkens2022-06-282-0/+514
| | | | | | | | | | | | Now needs >=egl-wayland-1.1.10 or else get a missing symbol if try to use vulkan on wayland. 515.57 still ships with 1.1.9 but it's a modified version of 1.1.9, likewise 1.1.10-r1 is a bit modified given it's currently in a poor state upstream (hopefully this works fine). Also install nvidia-dbus.conf again, file was sanitized upstream and believe it should be fine install. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: set kernel max 5.18 in 0/vulkanIonen Wolkens2022-06-281-1/+1
| | | | | | Overlooked updating that one. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: pin <515.57:0/515 to egl-wayland-1.1.9Ionen Wolkens2022-06-282-2/+2
| | | | | | | | Was waiting for a bump to do these revbumps given 1.1.10 was not keyworded anyway. 1.1.10 needs wlEglCreateSurfaceExport from libnvidia-vulkan-producer.so which currently only exist in >=515.57 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-libinput: Drop old versionsMatt Turner2022-06-242-22/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* x11-drivers/nvidia-drivers: drop 470.62.30Ionen Wolkens2022-06-212-463/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: add 515.49.05:0/vulkanIonen Wolkens2022-06-172-0/+507
| | | | | | | | | | | Note that even though it is newer (for now), it is not recommended to use the 0/vulkan branch unless you are involved in vulkan application development, upstream bugs may not get fixed (aka it adds vulkan features on top of old drivers and rebase occasionally). Please report if packaging issues, as don't check masked 0/vulkan much. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/xf86-input-libinput: arm64 stable wrt bug #852191Agostino Sarubbo2022-06-171-1/+1
| | | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="arm64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-libinput: Stabilize 1.2.1 x86, #852191Sam James2022-06-161-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* x11-drivers/xf86-input-libinput: Stabilize 1.2.1 amd64, #852191Sam James2022-06-161-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* x11-drivers/xf86-input-libinput: ppc64 stable wrt bug #852191Agostino Sarubbo2022-06-161-1/+1
| | | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="ppc64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-libinput: arm stable wrt bug #852191Agostino Sarubbo2022-06-161-1/+1
| | | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="arm" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-libinput: sparc stable wrt bug #852191Agostino Sarubbo2022-06-161-1/+1
| | | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="sparc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/xf86-input-libinput: ppc stable wrt bug #852191Agostino Sarubbo2022-06-161-1/+1
| | | | | | Package-Manager: Portage-3.0.30, Repoman-3.0.3 RepoMan-Options: --include-arches="ppc" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* x11-drivers/nvidia-drivers: cleanup old abi_x86_32 swap checkIonen Wolkens2022-06-125-41/+0
| | | | | | | | | Was to help reduce surprises when profile removed it as default, but been a while and should be little meaning to this now. README.Gentoo still warns about this for new installs. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: stabilize 510.73.05-r1 for amd64Ionen Wolkens2022-06-091-1/+1
| | | | | | | | | | | | | | | Branch been tested for a while and major known issues are sorted out in stable now. May at most still be a bit rocky for wayland users given the some applications will switch to using GBM, but gnome/kde have rolled out fixes to major issues a while ago. Owners of Kepler cards should mask >=x11-drivers/nvidia-drivers-471 as the ebuild will warn about (thanks for testing wrt #837317). Closes: https://bugs.gentoo.org/837317 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: pin to egl-wayland-1.1.9 for 0/510Ionen Wolkens2022-06-081-1/+1
| | | | | | | | | | | | Upcoming egl-wayland-1.1.10 is known incompatible, meant to bump it early to fix wayland vulkan issues with 0/515 but it requires yet unreleased nvidia-drivers that'd have the missing symbol in the vulkan-producer lib. And so .10 will likely never work with old 0/510, and there should be no reason to use 1.1.7 with it (barely tested combination). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: drop 515.43.04Ionen Wolkens2022-06-082-522/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: minor code cleanupIonen Wolkens2022-06-076-12/+12
| | | | | | | | That this works without eval feels a bit uncanny because the backslash for the following space is inside the variable, but it evaluates whole thing together. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* x11-drivers/nvidia-drivers: warn about X86_KERNEL_IBTIonen Wolkens2022-06-076-0/+18
| | | | | | | | | | | | | New feature in >=kernel-5.18, believe few have enabled it in Gentoo but it's been causing issues in binary distros that tried to enable it by default. Seems possible to workaround, but would rather wait for nvidia's fix. Add to non-5.18 ebuilds too for consistency and not losing track, is quiet if the option doesn't exist. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>