summaryrefslogtreecommitdiff
blob: 1a66309db92eddbf9ad01ba1dd470c7be09774bd (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

# Michał Górny <mgorny@gentoo.org> (28 Feb 2018)
# Requires masked USE flags.
gnome-base/gvfs mtp

# Michał Górny <mgorny@gentoo.org> (22 Feb 2018)
# USE=libcxxrt is use.forced.
sys-libs/libcxx libcxxabi

# Michał Górny <mgorny@gentoo.org> (22 Feb 2018)
# Even more unkeyworded dependencies.
dev-libs/libpeas lua
dev-util/cmocka doc

# Michał Górny <mgorny@gentoo.org> (21 Feb 2018)
# Requires net-misc/curl[kerberos] which is masked here.
dev-python/pycurl test

# Michał Górny <mgorny@gentoo.org> (21 Feb 2018)
# More unkeyworded dependencies.
media-libs/xine-lib fusionsound
media-video/ffmpeg frei0r sofalizer

# Michał Górny <mgorny@gentoo.org> (19 Feb 2018)
# Unkeyworded dependencies.
app-doc/doxygen clang
dev-libs/libpeas jit
dev-perl/GD fcgi
media-libs/libcanberra gnome
media-libs/mesa vaapi
media-sound/pulseaudio equalizer qt4 realtime
media-video/ffmpeg celt ebur128 kvazaar libilbc openh264
media-video/ffmpeg rubberband sdl ssh x265 zeromq zimg
net-libs/gnutls idn
net-print/cups-filters pdf
sys-devel/gcc objc-gc
x11-drivers/nvidia-drivers static-libs tools
x11-libs/pango test
x11-wm/fluxbox vim-syntax
virtual/ffmpeg sdl

# Michał Górny <mgorny@gentoo.org> (17 Feb 2018)
# Claims to require dev-libs/elfutils which doesn't support FreeBSD.
# We can umask if it works with virtual/libelf though.
media-libs/gstreamer unwind

# Michał Górny <mgorny@gentoo.org> (17 Feb 2018)
# Unkeyworded deps.
media-libs/elementary javascript
media-libs/phonon vlc
virtual/notification-daemon kde

# Michał Górny <mgorny@gentoo.org> (15 Feb 2018)
# Requires USE=seccomp that is masked in this profile.
net-libs/gnutls test-full

# Michał Górny <mgorny@gentoo.org> (20 Jan 2018)
# Needs sys-libs/libomp which is not keyworded. Leaving the decision
# whether sys-libs/libomp should eventually be keyworded to when new
# LLVM is going to be keyworded.
<sys-devel/clang-runtime-4 openmp

# Michał Górny <mgorny@gentoo.org> (20 Jan 2018)
# Needs dev-ml/ocaml-ctypes which is not keyworded. Newer versions
# no longer have the flag, so no point in keywording it for old.
sys-devel/llvm ocaml

# Ulrich Müller <ulm@gentoo.org> (23 Oct 2017)
# Needs net-mail/mailutils which is not keyworded, bug #635216.
app-editors/emacs-vcs mailutils

# Davide Pesavento <pesa@gentoo.org> (26 Oct 2015)
# Tests require non-keyworded qt5
dev-qt/qtchooser test

# Johannes Huber <johu@gentoo.org> (28 Jan 2015)
# Missing keyword on dev-libs/botan and dev-libs/pkcs11-helper
app-crypt/qca botan pkcs11

# Michael Palimaka <kensington@gentoo.org> (26 Dec 2014)
# Unkeyworded media-libs/opencv
media-plugins/frei0r-plugins facedetect
media-video/vlc opencv

# Patrick Lauer <patrick@gentoo.org> (17 Nov 2014)
# Lars Wendler <polynomial-c@gentoo.org> (23 Jan 2015)
# Missing keywords
dev-libs/openssl sctp
net-misc/openssh sctp

# Pacho Ramos <pacho@gentoo.org> (01 Jun 2014)
# Missing keywords
>=app-misc/geoclue-2.1 modemmanager
>=x11-libs/gtk+-3.12 cloudprint
>=app-crypt/libsecret-0.16 test
media-plugins/gst-plugins-meta modplug vaapi

# Lars Wendler <polynomial-c@gentoo.org> (09 May 2014)
# Masked kde USE flag until bug #509892 is fixed
dev-vcs/subversion kwallet

# Pacho Ramos <pacho@gentoo.org> (02 Dec 2013)
# Missing keywords, bug #493156
media-libs/libgphoto2 serial

# nvidia-driver uses acpid
x11-drivers/nvidia-drivers acpi

# Needs emul libs and the package isnt multilib at all for FreeBSD x86_64
x11-drivers/nvidia-drivers multilib

# requires nvidia-cg-toolkit which is not available on bsd
# see http://developer.nvidia.com/cg-toolkit-download
media-libs/libprojectm video_cards_nvidia

# x11-drivers/xf86-video-vmware works fine without KMS- and 3D support.
# Other packages will not work. keep video_cards_vmware in use.mask.
x11-base/xorg-drivers -video_cards_vmware