aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-05 15:31:41 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-05 15:31:41 +0200
commit94af431d327828d1e0d457f176a80ca48ad86858 (patch)
tree55630255df2dbb25fb70fbafad472bf361160eca
parentIn tree (diff)
downloaddotnet-94af431d327828d1e0d457f176a80ca48ad86858.tar.gz
dotnet-94af431d327828d1e0d457f176a80ca48ad86858.tar.bz2
dotnet-94af431d327828d1e0d457f176a80ca48ad86858.zip
.NET only.
-rw-r--r--dev-dotnet/msnp-sharp/Manifest3
-rw-r--r--dev-dotnet/msnp-sharp/files/msnp-sharp.pc.in9
-rw-r--r--dev-dotnet/msnp-sharp/msnp-sharp-2.5.3.ebuild54
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-dotnet/msnp-sharp/Manifest b/dev-dotnet/msnp-sharp/Manifest
deleted file mode 100644
index 5e5f9fc..0000000
--- a/dev-dotnet/msnp-sharp/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX msnp-sharp.pc.in 148 RMD160 a052e6bccfb4092ff80f09f1901e1791e91fb328 SHA1 cb55255821f04b811def609e5b0132fadd9b719e SHA256 77a461b18f87a5505b1a641d552226df4d03201a1cc948a35649bdc5c2f1d6bf
-DIST MSNPSharp_253_release_src.zip 557297 RMD160 3b769e0d1f9633f98d3ac70596ef9bd1c8a1166e SHA1 a2e7d418df57cbee8c1a2c84c5c6507c65f34120 SHA256 b3a4da927a04ebc830f5a03b8cd9897f0cbc764c3f22f92caf7b70d64da0fdc1
-EBUILD msnp-sharp-2.5.3.ebuild 1441 RMD160 545448ef3ce07e1cf86f305a78a7ad89ff6f553e SHA1 00a065c80bf684ce8dd347dda2377ed93d7f9ae5 SHA256 84a0f94008227faabafadf45bf7ecca6fb70b10d83641512dad79e4bac5c3907
diff --git a/dev-dotnet/msnp-sharp/files/msnp-sharp.pc.in b/dev-dotnet/msnp-sharp/files/msnp-sharp.pc.in
deleted file mode 100644
index 332939d..0000000
--- a/dev-dotnet/msnp-sharp/files/msnp-sharp.pc.in
+++ /dev/null
@@ -1,9 +0,0 @@
-prefix=@prefix@
-exec_prefix=@exec_prefix@
-libdir=@libdir@
-
-
-Name: MSNPSharp
-Description: .NET MSN messaging Library
-Version: @VERSION@
-Libs: @libs@
diff --git a/dev-dotnet/msnp-sharp/msnp-sharp-2.5.3.ebuild b/dev-dotnet/msnp-sharp/msnp-sharp-2.5.3.ebuild
deleted file mode 100644
index a87e526..0000000
--- a/dev-dotnet/msnp-sharp/msnp-sharp-2.5.3.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-2.12.7-r5.ebuild,v 1.1 2009/01/05 17:17:56 loki_val Exp $
-
-EAPI="2"
-
-inherit mono autotools
-
-MY_PN=MSNPSharp
-MY_PV=${PV//.}
-MY_P=${MY_PN}_${MY_PV}
-
-HOMEPAGE="http://code.google.com/p/msnp-sharp/"
-SRC_URI="http://msnp-sharp.googlecode.com/files/${MY_P}_release_src.zip"
-# http://msnp-sharp.googlecode.com/files/MSNPSharp_253_release_src.zip
-DESCRIPTION="MSNPSharp is a .Net library that implements the MSN protocol."
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-LICENSE="|| ( LGPL-2.1 LGPL-3 )"
-
-
-RDEPEND=">=dev-lang/mono-2.0"
-DEPEND="${RDEPEND}
- >=dev-util/monodevelop-1.9.1
- >=dev-util/pkgconfig-0.23"
-
-S="${WORKDIR}"
-
-src_prepare() {
- mdtool generate-makefiles -d:Debug MSNPSharp.sln
- AT_M4DIR="${S}" eautoreconf
-}
-
-src_compile() {
- cd MSNPSharp
- emake -j1 ASSEMBLY_COMPILER_COMMAND='/usr/bin/gmcs -keyfile:Resources/msnpsharp.snk'
-}
-
-src_install() {
- cd MSNPSharp
- egacinstall bin/Debug/MSNPSharp.dll
- dodir /usr/$(get_libdir)/pkgconfig
- sed \
- -e 's:@prefix@:${pcfiledir}/../..:' \
- -e 's:@exec_prefix@:${prefix}:' \
- -e 's:@libdir@:${prefix}/'"$(get_libdir):" \
- -e "s:@VERSION@:${PV}:" \
- -e 's;@libs@; -r:${libdir}/mono/msnp-sharp/MSNPSharp.dll;' \
- < "${FILESDIR}"/${PN}.pc.in \
- > "${D}"/usr/$(get_libdir)/pkgconfig/msnp-sharp.pc
-
-}