aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-21 14:48:25 +0200
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-21 14:48:25 +0200
commitcbb44d0ab4f12290ea97c40705998bbb5421b16c (patch)
tree7c053d124aab37248aa58cb14b406b363f5de71f
parentMono-2.0.1 is now stable. (diff)
downloaddotnet-cbb44d0ab4f12290ea97c40705998bbb5421b16c.tar.gz
dotnet-cbb44d0ab4f12290ea97c40705998bbb5421b16c.tar.bz2
dotnet-cbb44d0ab4f12290ea97c40705998bbb5421b16c.zip
Add google-data-sharp
-rw-r--r--dev-dotnet/google-data-sharp/Manifest2
-rw-r--r--dev-dotnet/google-data-sharp/google-data-sharp-1.4.0.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-dotnet/google-data-sharp/Manifest b/dev-dotnet/google-data-sharp/Manifest
new file mode 100644
index 0000000..e3f7813
--- /dev/null
+++ b/dev-dotnet/google-data-sharp/Manifest
@@ -0,0 +1,2 @@
+DIST libgoogle-data-mono-1.4.0.2.tar.gz 2090937 RMD160 a2b6f67728b5d3b18bab9b71a9186d5f3ca787b8 SHA1 8e24b7ad03899b31499716c668e38f6af3189480 SHA256 761124feb67ad972e61a10a09bbde68536a2fa8cc67f9f17fcda907bbdb2fbe4
+EBUILD google-data-sharp-1.4.0.2.ebuild 746 RMD160 9fd21231ea351b1add35f86fdce80198f99cef5f SHA1 533b5c4c905d2de350268a21f0f0c47e7c7bbb53 SHA256 55f1086d250c3615803d73c3d71cd5ac1a1d00104e21367a07cc06ecf8de8f42
diff --git a/dev-dotnet/google-data-sharp/google-data-sharp-1.4.0.2.ebuild b/dev-dotnet/google-data-sharp/google-data-sharp-1.4.0.2.ebuild
new file mode 100644
index 0000000..aed84e3
--- /dev/null
+++ b/dev-dotnet/google-data-sharp/google-data-sharp-1.4.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+MY_PN=libgoogle-data-mono
+MY_P=${MY_PN}-${PV}
+
+inherit mono
+
+DESCRIPTION="This is a sample skeleton ebuild file"
+
+HOMEPAGE="http://code.google.com/p/google-gdata/"
+
+SRC_URI="http://google-gdata.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+
+IUSE=""
+DEPEND=">=dev-lang/mono-2.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake PREFIX="/usr" CSC="/usr/bin/gmcs" || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install || die "emake install failed"
+ dohtml RELEASE_NOTES.HTML || die "dodoc failed"
+ mono_multilib_comply
+}