summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-12-12 08:10:15 +0000
committerThomas Kahle <tomka@gentoo.org>2010-12-12 08:10:15 +0000
commit67ddeb1c0cd866a185b6de21081eafc1bd8aca47 (patch)
treeac2ec7f686111a742b99bcb1b7e85ef579fb6996
parentChange my old nick in the ChangeLog (diff)
downloademacs-67ddeb1c0cd866a185b6de21081eafc1bd8aca47.tar.gz
emacs-67ddeb1c0cd866a185b6de21081eafc1bd8aca47.tar.bz2
emacs-67ddeb1c0cd866a185b6de21081eafc1bd8aca47.zip
New ebuild: completion-ui
svn path=/emacs-overlay/; revision=1549
-rw-r--r--app-emacs/completion-ui/Manifest3
-rw-r--r--app-emacs/completion-ui/completion-ui-0.11.10.ebuild30
-rw-r--r--app-emacs/completion-ui/files/50completion-ui-gentoo.el8
3 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/completion-ui/Manifest b/app-emacs/completion-ui/Manifest
new file mode 100644
index 0000000..b149216
--- /dev/null
+++ b/app-emacs/completion-ui/Manifest
@@ -0,0 +1,3 @@
+AUX 50completion-ui-gentoo.el 469 RMD160 6b8e0076ab2d352aaad5457abb6cd8fed1d9b8c8 SHA1 866987fbad28eaf3d564dbe6e6550a79e2b7ce16 SHA256 93cfb80ff8f88422495f1b99b1e938c540784620960d9c7d13649b5e0e772bb9
+DIST completion-ui-0.11.10.tar.gz 62335 RMD160 77df446864cd1cbe2333d826a9c9e39609f5045b SHA1 3146a033ba80b44be56e8cf0cca3fe1ed8e80447 SHA256 7bef005758cf5d994c3c61cb152051f09308b3cc6f648db31b55b1928cc0b130
+EBUILD completion-ui-0.11.10.ebuild 761 RMD160 e30b4348d6a24e5931c56de30ae63bd931f585c7 SHA1 7d0fc52f28a3707d7588a580735354c87c9431f3 SHA256 c4714ea813e17fea93c6bf2a41e3909aa4f78ea1effb6834867e422f10727b2a
diff --git a/app-emacs/completion-ui/completion-ui-0.11.10.ebuild b/app-emacs/completion-ui/completion-ui-0.11.10.ebuild
new file mode 100644
index 0000000..e3dcea9
--- /dev/null
+++ b/app-emacs/completion-ui/completion-ui-0.11.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit elisp
+
+DESCRIPTION="library that implements user-interfaces for in-buffer completion"
+HOMEPAGE="http://www.dr-qubit.org/emacs.php#completion"
+# Upstream ships this as 0.11.8, but it contains version 0.11.10
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ http://dev.gentoo.org/~tomka/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "This package ships completion for dabbrev, etags, elisp, "
+ elog "files, semantic, and nxml. You may want to bind the complete-? "
+ elog "functions to a key in your .emacs file."
+}
+
diff --git a/app-emacs/completion-ui/files/50completion-ui-gentoo.el b/app-emacs/completion-ui/files/50completion-ui-gentoo.el
new file mode 100644
index 0000000..aff8381
--- /dev/null
+++ b/app-emacs/completion-ui/files/50completion-ui-gentoo.el
@@ -0,0 +1,8 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'complete-dabbrev "completion-ui-sources" "Complete dabbrev" t)
+(autoload 'complete-etags "completion-ui-sources" "Complete etags" t)
+(autoload 'complete-elisp "completion-ui-sources" "Complete elisp" t)
+(autoload 'complete-files "completion-ui-sources" "Complete files" t)
+(autoload 'complete-semantic "completion-ui-sources" "Complete semantic" t)
+(autoload 'complete-nxml "completion-ui-sources" "Complete nxml" t)