summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-12-18 13:15:44 +0000
committerUlrich Müller <ulm@gentoo.org>2007-12-18 13:15:44 +0000
commitf6a145808e1a37984fc97feebfcd5cfa26890637 (patch)
tree60ba361b361f76a645ef93a7fd51b74a23549bc0
parentkill eeio (diff)
downloademacs-f6a145808e1a37984fc97feebfcd5cfa26890637.tar.gz
emacs-f6a145808e1a37984fc97feebfcd5cfa26890637.tar.bz2
emacs-f6a145808e1a37984fc97feebfcd5cfa26890637.zip
Moved to Portage tree.
svn path=/emacs-overlay/; revision=882
-rw-r--r--app-emacs/matlab/ChangeLog16
-rw-r--r--app-emacs/matlab/Manifest5
-rw-r--r--app-emacs/matlab/files/51matlab-gentoo.el15
-rw-r--r--app-emacs/matlab/matlab-3.1.0_pre20070306.ebuild26
-rw-r--r--app-emacs/matlab/metadata.xml5
5 files changed, 0 insertions, 67 deletions
diff --git a/app-emacs/matlab/ChangeLog b/app-emacs/matlab/ChangeLog
deleted file mode 100644
index de00508..0000000
--- a/app-emacs/matlab/ChangeLog
+++ /dev/null
@@ -1,16 +0,0 @@
-# ChangeLog for app-emacs/matlab
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: $
-
- 18 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
- files/51matlab-gentoo.el:
- kill eeio
-
- 18 Dec 2007; Christian Faulhammer <opfer@gentoo.org>
- files/51matlab-gentoo.el:
- add another autoload for eei-connect
-
- 17 Dec 2007; Ulrich Mueller <ulm@gentoo.org> +files/51matlab-gentoo.el,
- +metadata.xml, +matlab-3.1.0_pre20070306.ebuild:
- CVS snapshot, needs testing.
-
diff --git a/app-emacs/matlab/Manifest b/app-emacs/matlab/Manifest
deleted file mode 100644
index 28172e9..0000000
--- a/app-emacs/matlab/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX 51matlab-gentoo.el 492 RMD160 b881f899369d49545d770874fce250e47d8b6cdf SHA1 a7aa2f5242e1155903f0c267640066359408f5ca SHA256 d932b3f5196187ba93c2b77567dfc7e4ae5502dd1376c349aef35623c70cfb39
-DIST matlab-3.1.0_pre20070306.tar.bz2 69566 RMD160 74f3ea7931803a077667140892e2add08de858bc SHA1 e67dac5ebe4535effdcc886398f52196a066ed90 SHA256 5956b47b8b17d342e64d9660be6c262f3935f15157274837dca6e85be17a080b
-EBUILD matlab-3.1.0_pre20070306.ebuild 643 RMD160 e703dd4d8952315741ffd043990f76ea4379bf87 SHA1 e61a782aad9679ef439941b09e3c78fa6004f67d SHA256 0d4497844bd72d5f9c5755171fede17071858a04cfe8db03f2d580b6f2756372
-MISC ChangeLog 493 RMD160 7201cd053f61f6678a31a86e7976dbbefd10fc7e SHA1 651db690b514c4a7bb5d35309069b4328d6ee04e SHA256 8d76ba8803d0f2a1837c54087f8e04f74a344e5bc26150ce474ca432ef165813
-MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
diff --git a/app-emacs/matlab/files/51matlab-gentoo.el b/app-emacs/matlab/files/51matlab-gentoo.el
deleted file mode 100644
index 48adabd..0000000
--- a/app-emacs/matlab/files/51matlab-gentoo.el
+++ /dev/null
@@ -1,15 +0,0 @@
-
-;;; matlab site-lisp configuration
-
-(add-to-list 'load-path "@SITELISP@")
-
-(autoload 'matlab-mode "matlab" "Enter Matlab mode." t)
-(add-to-list 'auto-mode-alist '("\\.m\\'" . matlab-mode))
-(autoload 'matlab-shell "matlab" "Interactive Matlab mode." t)
-
-(autoload 'mlint-minor-mode "mlint" nil t)
-(add-hook 'matlab-mode-hook (lambda () (mlint-minor-mode 1)))
-
-(autoload 'tlc-mode "tlc" "tlc Editing Mode" t)
-(add-to-list 'auto-mode-alist '("\\.tlc$" . tlc-mode))
-(setq tlc-indent-function t)
diff --git a/app-emacs/matlab/matlab-3.1.0_pre20070306.ebuild b/app-emacs/matlab/matlab-3.1.0_pre20070306.ebuild
deleted file mode 100644
index 6eee395..0000000
--- a/app-emacs/matlab/matlab-3.1.0_pre20070306.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/matlab/matlab-2.2.3.ebuild,v 1.12 2007/10/27 10:44:23 opfer Exp $
-
-inherit elisp
-
-DESCRIPTION="Major modes for MATLAB dot-m and dot-tlc files"
-HOMEPAGE="http://matlab-emacs.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND="app-emacs/cedet"
-RDEPEND="${DEPEND}"
-
-SITEFILE=51${PN}-gentoo.el
-DOCS="README INSTALL ChangeLog*"
-
-S="${WORKDIR}/matlab-emacs"
-
-src_compile() {
- elisp-comp *.el || die "elisp-comp failed"
-}
diff --git a/app-emacs/matlab/metadata.xml b/app-emacs/matlab/metadata.xml
deleted file mode 100644
index bc306fe..0000000
--- a/app-emacs/matlab/metadata.xml
+++ /dev/null
@@ -1,5 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>emacs</herd>
-</pkgmetadata>