summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-11-14 14:03:13 +0000
committerUlrich Müller <ulm@gentoo.org>2008-11-14 14:03:13 +0000
commit1e0dfea06f36b5073187ea90de0f24e4a364cb1f (patch)
tree72fe96477af1241a65d8cd767f2d4cc417f962c0
parentVersion bump. (diff)
downloademacs-1e0dfea06f36b5073187ea90de0f24e4a364cb1f.tar.gz
emacs-1e0dfea06f36b5073187ea90de0f24e4a364cb1f.tar.bz2
emacs-1e0dfea06f36b5073187ea90de0f24e4a364cb1f.zip
Copy from Portage tree.
svn path=/emacs-overlay/; revision=1208
-rw-r--r--app-editors/emacs/ChangeLog10
-rw-r--r--app-editors/emacs/Manifest6
-rw-r--r--app-editors/emacs/emacs-18.59-r5.ebuild97
-rw-r--r--app-editors/emacs/metadata.xml31
4 files changed, 144 insertions, 0 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
new file mode 100644
index 0000000..d7c0115
--- /dev/null
+++ b/app-editors/emacs/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-editors/emacs
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*emacs-18.59-r5 (14 Nov 2008)
+
+ 14 Nov 2008; Ulrich Mueller <ulm@gentoo.org> +metadata.xml,
+ +emacs-18.59-r5.ebuild:
+ Copy from Portage tree.
+
diff --git a/app-editors/emacs/Manifest b/app-editors/emacs/Manifest
new file mode 100644
index 0000000..d59a48a
--- /dev/null
+++ b/app-editors/emacs/Manifest
@@ -0,0 +1,6 @@
+DIST emacs-18.59-linux22x-elf-glibc21.diff.gz 15671 RMD160 4fab87eead1a66d767d2334d31507695dcf7b4a8 SHA1 075f1c9cf86e9a10fb686ebd04a2f95d6e4c3972 SHA256 fb810d893938883d50a3a8d7c43fbeb1604d5454f760b8f1f700326c8ee659dd
+DIST emacs-18.59-patches-3.tar.bz2 17323 RMD160 c0a205792f80c34b599c82fe5cf957f10f80956a SHA1 d452c45756e69edf71a46518cfde809eb65955f9 SHA256 679fe1c0e4fbc2ccf44e6c7097aa093c4e575fde15b5416d944916893bd543ff
+DIST emacs-18.59.tar.gz 2962652 RMD160 4976d0f0f34b6d54db6774d24a528f74a3bb20dc SHA1 15b25bf130e3eeb91f3eea8c01a3dec9aabf23cc SHA256 1e27e33f91984a91e9b4c1f21433f931aba03670960ecc147bb6d7b0de0f051e
+EBUILD emacs-18.59-r5.ebuild 2628 RMD160 98230ad513331ac2e9657ef374425dde606929b8 SHA1 b9e08234616ded59e5ba122b79a06eef025fbd82 SHA256 66dcdebc1787801ab7a66dd699a8c244b239e5f4d2421dfe0f59155179984448
+MISC ChangeLog 264 RMD160 a7a84b4009ed80288238b14c92ad333f7f6459f1 SHA1 bc83be5f7ed00e82203bead17a445cbe0f5e1c19 SHA256 d55100e7827492a4beb89c36fa5c858e197b5bb74c104be457d266a1394f8856
+MISC metadata.xml 1652 RMD160 537bd66f869b6306694a2e30a05d15e48e324a54 SHA1 afe373a8a2d21971448fc2480f6f1b77e0bb1f23 SHA256 89dca1423f45221c7df249d7e96e162abd7c3188824b81c0f83c2d8f4fa7a1b5
diff --git a/app-editors/emacs/emacs-18.59-r5.ebuild b/app-editors/emacs/emacs-18.59-r5.ebuild
new file mode 100644
index 0000000..87f674a
--- /dev/null
+++ b/app-editors/emacs/emacs-18.59-r5.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-18.59-r5.ebuild,v 1.6 2008/11/14 09:11:43 ulm Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="The extensible self-documenting text editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gnu/old-gnu/emacs/${P}.tar.gz
+ ftp://ftp.splode.com/pub/users/friedman/emacs/${P}-linux22x-elf-glibc21.diff.gz
+ mirror://gentoo/${P}-patches-3.tar.bz2"
+
+LICENSE="GPL-1 GPL-2 BSD as-is"
+SLOT="18"
+KEYWORDS="~x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
+
+MY_BASEDIR="/usr/share/emacs/${PV}"
+MY_LOCKDIR="/var/lib/emacs/lock"
+
+pkg_setup() {
+ use X && built_with_use x11-libs/libX11 xcb \
+ && die "${P} requires x11-libs/libX11 built with USE=-xcb"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-linux22x-elf-glibc21.diff"
+ EPATCH_SUFFIX=patch epatch
+}
+
+src_compile() {
+ # Do not use the sandbox, or the dumped Emacs will be twice as large
+ SANDBOX_ON=0
+
+ # autoconf? What's autoconf? We are living in 1992. ;-)
+ local arch
+ case ${ARCH} in
+ x86) arch=intel386 ;;
+ *) die "Architecture ${ARCH} not supported" ;;
+ esac
+ local cmd="s/\"s-.*\.h\"/\"s-linux.h\"/;s/\"m-.*\.h\"/\"m-${arch}.h\"/"
+ use X && cmd="${cmd};s/.*\(#define HAVE_X_WINDOWS\).*/\1/"
+ sed -e "${cmd}" src/config.h-dist >src/config.h
+
+ cat <<-END >src/paths.h
+ #define PATH_LOADSEARCH "${MY_BASEDIR}/lisp"
+ #define PATH_EXEC "${MY_BASEDIR}/etc"
+ #define PATH_LOCK "${MY_LOCKDIR}/"
+ #define PATH_SUPERLOCK "${MY_LOCKDIR}/!!!SuperLock!!!"
+ END
+
+ # -O3 and -finline-functions cause segmentation faults at run time.
+ filter-flags -finline-functions
+ replace-flags -O[3-9] -O2
+ strip-flags
+
+ emake -j1 CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" || die
+}
+
+src_install() {
+ local i
+
+ dodir ${MY_BASEDIR}
+ dodir /usr/share/man/man1
+ make install LIBDIR="${D}${MY_BASEDIR}" BINDIR="${D}/usr/bin" \
+ MANDIR="${D}/usr/share/man/man1" || die
+ chmod -R go-w "${D}${MY_BASEDIR}"
+ rmdir "${D}${MY_BASEDIR}/lock"
+
+ dodir ${MY_LOCKDIR%/*}
+ diropts -m0777
+ keepdir ${MY_LOCKDIR}
+
+ for i in emacsclient etags ctags; do
+ mv "${D}"/usr/bin/${i}{,-emacs-${SLOT}} || die "mv ${i} failed"
+ done
+ mv "${D}"/usr/bin/emacs{,-${SLOT}} || die "mv emacs failed"
+ mv "${D}"/usr/share/man/man1/emacs{,-emacs-${SLOT}}.1 || die
+ dosym ../emacs/${PV}/info /usr/share/info/emacs-${SLOT}
+
+ dodoc README PROBLEMS
+}
+
+pkg_postinst() {
+ eselect emacs update ifunset
+}
+
+pkg_postrm() {
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
new file mode 100644
index 0000000..7ef4be9
--- /dev/null
+++ b/app-editors/emacs/metadata.xml
@@ -0,0 +1,31 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ GNU Emacs is an extensible, customizable text editor—and more. At its core
+ is an interpreter for Emacs Lisp, a dialect of the Lisp programming language
+ with extensions to support text editing. The features of GNU Emacs include:
+ * Content-sensitive editing modes, including syntax coloring, for a wide
+ variety of file types including plain text, source code, and HTML.
+ * Complete built-in documentation, including a tutorial for new users.
+ * Support for many languages and their scripts, including all the European
+ "Latin" scripts, Russian, Greek, Japanese, Chinese, Korean, Thai,
+ Vietnamese, Lao, Ethiopian, and some Indian scripts.
+ * Highly customizable, using Emacs Lisp code or a graphical customization
+ interface.
+ * A large number of extensions that add other functionality, including a
+ project planner, mail and news reader, debugger interface, calendar, and
+ more. Many of these extensions are distributed with GNU Emacs; others are
+ available separately.
+</longdescription>
+<use>
+ <flag name='gzip-el'>Compress bundled Emacs Lisp source</flag>
+ <flag name='hesiod'>Enable support for <pkg>net-dns/hesiod</pkg></flag>
+ <flag name='leim'>Add support for Emacs input methods</flag>
+ <flag name='sendmail'>Build Emacs with MTA support</flag>
+ <flag name='sound'>Enable sound</flag>
+ <flag name='toolkit-scroll-bars'>Use the selected toolkit's scrollbars in
+ preference to Emacs' own scrollbars</flag>
+</use>
+</pkgmetadata>