summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-11-05 21:14:29 +0000
committerUlrich Müller <ulm@gentoo.org>2008-11-05 21:14:29 +0000
commit740fd4e7f70a14354e5709359e6ecfce35d778e9 (patch)
treefaf6e787323d283aa30b8c4d5b67d82e2d969bd1
parentAdd live SVN version. (diff)
downloademacs-740fd4e7f70a14354e5709359e6ecfce35d778e9.tar.gz
emacs-740fd4e7f70a14354e5709359e6ecfce35d778e9.tar.bz2
emacs-740fd4e7f70a14354e5709359e6ecfce35d778e9.zip
Convert to EAPI 2.
svn path=/emacs-overlay/; revision=1198
-rw-r--r--app-editors/emacs-cvs/ChangeLog14
-rw-r--r--app-editors/emacs-cvs/Manifest4
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.9999.ebuild277
-rw-r--r--app-editors/emacs-cvs/files/emacs-cvs-freebsd-sparc-1.patch11
-rw-r--r--app-editors/emacs-cvs/metadata.xml30
5 files changed, 336 insertions, 0 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
new file mode 100644
index 0000000..9d6835c
--- /dev/null
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for app-editors/emacs-cvs
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 05 Nov 2008; Ulrich Mueller <ulm@gentoo.org> emacs-cvs-23.0.9999.ebuild:
+ Convert to EAPI 2.
+
+*emacs-cvs-23.0.9999 (29 Oct 2008)
+
+ 29 Oct 2008; Ulrich Mueller <ulm@gentoo.org>
+ +files/emacs-cvs-freebsd-sparc-1.patch, +emacs-cvs-23.0.9999.ebuild,
+ metadata.xml:
+ Copied from Portage tree.
+
diff --git a/app-editors/emacs-cvs/Manifest b/app-editors/emacs-cvs/Manifest
new file mode 100644
index 0000000..fd3b71a
--- /dev/null
+++ b/app-editors/emacs-cvs/Manifest
@@ -0,0 +1,4 @@
+AUX emacs-cvs-freebsd-sparc-1.patch 448 RMD160 4f131b630ec09e1d9170374fc60a1620f0f718e9 SHA1 5bc71be91bb8008cec2473479184e250e5284c68 SHA256 e2c2e53e2995d4a505c480d17e0a7e5abff61ea96c4d3451a1e019c985a59cd8
+EBUILD emacs-cvs-23.0.9999.ebuild 8382 RMD160 a162e321c18bdbc0f5a9a4df442c159a533e0611 SHA1 fc222cc5e8d46ee2006061be337c4ef52da4dba0 SHA256 3e1eb3cb6ff5b44755067f72051f8f1403691318700e4c19d00333aee00d5e69
+MISC ChangeLog 418 RMD160 2b648c36f51fffb3c9521d81f0f519dc3ae1c9bd SHA1 a1796b1adb3aec649c2feb1bc0c08f45ba485ebc SHA256 bd085d371b28c25e3684e419484a07e21c2aae498b930917eacc719d3cbc6592
+MISC metadata.xml 1606 RMD160 f898da13dfc3bdb1636e9ff7bc241997d235498b SHA1 2dea9901bc80a1d91f38628707395d9b4ef0df70 SHA256 f4df95b7db6f7b3375bdd658024520a03a763e75f4ca846ab494609f6094c9bd
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.9999.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.9999.ebuild
new file mode 100644
index 0000000..f677324
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.9999.ebuild
@@ -0,0 +1,277 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.9999.ebuild,v 1.10 2008/09/23 21:02:31 opfer Exp $
+
+EAPI=2
+
+ECVS_AUTH="pserver"
+ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
+ECVS_MODULE="emacs"
+ECVS_BRANCH="HEAD"
+ECVS_LOCALNAME="emacs"
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools cvs elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI=""
+
+LICENSE="GPL-3 FDL-1.2 BSD"
+SLOT="23"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+IUSE="alsa dbus gif gpm gtk gzip-el hesiod jpeg kerberos m17n-lib motif png spell sound source svg tiff toolkit-scroll-bars X Xaw3d xft +xpm"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ net-libs/liblockfile
+ hesiod? ( net-dns/hesiod )
+ kerberos? ( virtual/krb5 )
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ alsa? ( media-libs/alsa-lib )
+ gpm? ( sys-libs/gpm )
+ dbus? ( sys-apps/dbus )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xbitmaps
+ x11-misc/emacs-desktop
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ svg? ( >=gnome-base/librsvg-2.0 )
+ tiff? ( media-libs/tiff )
+ xpm? ( x11-libs/libXpm )
+ xft? (
+ media-libs/fontconfig
+ media-libs/freetype
+ virtual/xft
+ m17n-lib? (
+ >=dev-libs/libotf-0.9.4
+ >=dev-libs/m17n-lib-1.5.1
+ )
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( motif? ( x11-libs/openmotif ) )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ gzip-el? ( app-arch/gzip )"
+
+S="${WORKDIR}/${ECVS_LOCALNAME}"
+
+EMACS_SUFFIX="emacs-${SLOT}"
+
+src_prepare() {
+ # FULL_VERSION keeps the full version number, which is needed in
+ # order to determine some path information correctly for copy/move
+ # operations later on
+ FULL_VERSION=$(grep 'defconst[ ]*emacs-version' lisp/version.el \
+ | sed -e 's/^[^"]*"\([^"]*\)".*$/\1/')
+ [ "${FULL_VERSION}" ] || die "Cannot determine current Emacs version"
+ echo
+ einfo "Emacs CVS branch: ${ECVS_BRANCH}"
+ einfo "Emacs version number: ${FULL_VERSION}"
+ [ "${FULL_VERSION%.*}" = ${PV%.*} ] \
+ || die "Upstream version number changed to ${FULL_VERSION}"
+ echo
+
+ epatch "${FILESDIR}/${PN}-freebsd-sparc-1.patch"
+
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ ALLOWED_FLAGS=""
+ strip-flags
+ #unset LDFLAGS
+ replace-flags -O[3-9] -O2
+
+ local myconf
+
+ if use alsa && ! use sound; then
+ echo
+ einfo "Although sound USE flag is disabled you chose to have alsa,"
+ einfo "so sound is switched on anyway."
+ echo
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} $(use_with sound)"
+ fi
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with gif) $(use_with jpeg)"
+ myconf="${myconf} $(use_with png) $(use_with svg rsvg)"
+ myconf="${myconf} $(use_with tiff) $(use_with xpm)"
+ myconf="${myconf} $(use_with xft freetype) $(use_with xft)"
+
+ if use xft; then
+ myconf="${myconf} $(use_with m17n-lib libotf)"
+ myconf="${myconf} $(use_with m17n-lib m17n-flt)"
+ else
+ myconf="${myconf} --without-libotf --without-m17n-flt"
+ use m17n-lib && einfo \
+ "USE flag \"m17n-lib\" has no effect because xft is not set."
+ fi
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
+ if use gtk; then
+ einfo "Configuring to build with GIMP Toolkit (GTK+)"
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d (Athena) toolkit"
+ myconf="${myconf} --with-x-toolkit=athena"
+ elif use motif; then
+ einfo "Configuring to build with Motif toolkit"
+ myconf="${myconf} --with-x-toolkit=motif"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ fi
+
+ local f tk=
+ for f in gtk Xaw3d motif; do
+ use ${f} || continue
+ [ "${tk}" ] \
+ && ewarn "USE flag \"${f}\" ignored (superseded by \"${tk}\")"
+ tk="${tk}${tk:+ }${f}"
+ done
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ myconf="${myconf} $(use_with hesiod)"
+ myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
+ myconf="${myconf} $(use_with gpm) $(use_with dbus)"
+
+ econf \
+ --program-suffix=-${EMACS_SUFFIX} \
+ --infodir=/usr/share/info/${EMACS_SUFFIX} \
+ ${myconf} || die "econf emacs failed"
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ emake CC="$(tc-getCC)" bootstrap || die "make bootstrap failed"
+ # cleanup, otherwise emacs will be dumped again in src_install
+ (cd src; emake versionclean)
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install () {
+ local i m
+
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
+ || die "removing duplicate emacs executable failed"
+ mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
+ || die "moving Emacs executable failed"
+
+ # move info documentation to the correct place
+ for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
+ mv "${i}" "${i}.info" || die "mv info failed"
+ done
+
+ # move man pages to the correct place
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
+ done
+
+ # avoid collision between slots, see bug #169033 e.g.
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+ rm -rf "${D}"/usr/share/{applications,icons}
+ rm "${D}"/var/lib/games/emacs/{snake,tetris}-scores
+ keepdir /usr/share/emacs/site-lisp
+ keepdir /var/lib/games/emacs
+
+ if use source; then
+ insinto /usr/share/emacs/${FULL_VERSION}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ sed 's/^X//' >10${PN}-${SLOT}-gentoo.el <<-EOF
+
+ ;;; ${PN}-${SLOT} site-lisp configuration
+
+ (if (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+ X (setq find-function-C-source-directory
+ X "/usr/share/emacs/${FULL_VERSION}/src"))
+ EOF
+ elisp-site-file-install 10${PN}-${SLOT}-gentoo.el
+ fi
+
+ dodoc README BUGS || die "dodoc failed"
+}
+
+emacs-infodir-rebuild() {
+ # Depending on the Portage version, the Info dir file is compressed
+ # or removed. It is only rebuilt by Portage if our directory is in
+ # INFOPATH, which is not guaranteed. So we rebuild it ourselves.
+
+ local infodir=/usr/share/info/${EMACS_SUFFIX} f
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${ROOT}"${infodir}/dir{,.*}
+ for f in "${ROOT}"${infodir}/*.info*; do
+ [[ ${f##*/} == *[0-9].info* ]] \
+ || install-info --info-dir="${ROOT}"${infodir} "${f}" &>/dev/null
+ done
+ rmdir "${ROOT}"${infodir} 2>/dev/null # remove dir if it is empty
+ echo
+}
+
+pkg_postinst() {
+ [ -f "${ROOT}"/usr/share/emacs/site-lisp/subdirs.el ] \
+ || cp "${ROOT}"/usr/share/emacs{/${FULL_VERSION},}/site-lisp/subdirs.el
+
+ local f
+ for f in "${ROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
+ [ -e "${f}" ] || touch "${f}"
+ done
+
+ elisp-site-regen
+ emacs-infodir-rebuild
+ eselect emacs update ifunset
+
+ echo
+ elog "You can set the version to be started by /usr/bin/emacs through"
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "You can therefore test emacs-cvs along with the stable release."
+ elog "\"man emacs.eselect\" for details."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ emacs-infodir-rebuild
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs-cvs/files/emacs-cvs-freebsd-sparc-1.patch b/app-editors/emacs-cvs/files/emacs-cvs-freebsd-sparc-1.patch
new file mode 100644
index 0000000..85ff3a0
--- /dev/null
+++ b/app-editors/emacs-cvs/files/emacs-cvs-freebsd-sparc-1.patch
@@ -0,0 +1,11 @@
+--- emacs-orig/src/alloc.c 2008-07-09 19:33:18.000000000 +0200
++++ emacs/src/alloc.c 2008-07-09 19:39:48.000000000 +0200
+@@ -4487,7 +4487,7 @@
+ /* Fixme: Code in the Boehm GC suggests flushing (with `flushrs') is
+ needed on ia64 too. See mach_dep.c, where it also says inline
+ assembler doesn't work with relevant proprietary compilers. */
+-#ifdef __sparc__
++#if defined(__sparc__) && !defined(__FreeBSD__)
+ asm ("ta 3");
+ #endif
+
diff --git a/app-editors/emacs-cvs/metadata.xml b/app-editors/emacs-cvs/metadata.xml
new file mode 100644
index 0000000..981238a
--- /dev/null
+++ b/app-editors/emacs-cvs/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ GNU Emacs is an extensible, customizable text editor—and more. At its core
+ is an interpreter for Emacs Lisp, a dialect of the Lisp programming language
+ with extensions to support text editing. The features of GNU Emacs include:
+ * Content-sensitive editing modes, including syntax coloring, for a wide
+ variety of file types including plain text, source code, and HTML.
+ * Complete built-in documentation, including a tutorial for new users.
+ * Support for many languages and their scripts, including all the European
+ "Latin" scripts, Russian, Greek, Japanese, Chinese, Korean, Thai,
+ Vietnamese, Lao, Ethiopian, and some Indian scripts.
+ * Highly customizable, using Emacs Lisp code or a graphical customization
+ interface.
+ * A large number of extensions that add other functionality, including a
+ project planner, mail and news reader, debugger interface, calendar, and
+ more. Many of these extensions are distributed with GNU Emacs; others are
+ available separately.
+</longdescription>
+<use>
+ <flag name='gzip-el'>Compress bundled Emacs Lisp source</flag>
+ <flag name='hesiod'>Enable support for <pkg>net-dns/hesiod</pkg></flag>
+ <flag name='sound'>Enable sound</flag>
+ <flag name='toolkit-scroll-bars'>Use the selected toolkit's scrollbars in
+ preference to Emacs' own scrollbars</flag>
+ <flag name='xft'>Build Emacs with support for the XFT font renderer</flag>
+</use>
+</pkgmetadata>