summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-03-19 08:28:03 +0000
committerUlrich Müller <ulm@gentoo.org>2007-03-19 08:28:03 +0000
commit747be5d4fc4ac013bbcfaaefc0bd4c7ecbcf214e (patch)
tree34103e38ecd955133e0383b9bf69db98d998e0d3
parentversion bump: (diff)
downloademacs-747be5d4fc4ac013bbcfaaefc0bd4c7ecbcf214e.tar.gz
emacs-747be5d4fc4ac013bbcfaaefc0bd4c7ecbcf214e.tar.bz2
emacs-747be5d4fc4ac013bbcfaaefc0bd4c7ecbcf214e.zip
Added patch to get rid of compiler warnings for emacs-21.
svn path=/emacs-overlay/; revision=95
-rw-r--r--app-admin/eselect-emacs/ChangeLog2
-rw-r--r--app-editors/emacs/files/emacs-21.4-qa.patch70
2 files changed, 71 insertions, 1 deletions
diff --git a/app-admin/eselect-emacs/ChangeLog b/app-admin/eselect-emacs/ChangeLog
index f3d82ff..145335e 100644
--- a/app-admin/eselect-emacs/ChangeLog
+++ b/app-admin/eselect-emacs/ChangeLog
@@ -6,7 +6,7 @@
+eselect-emacs-0.2.ebuild:
version bump:
Remove man symlinks with all possible compress extensions;
- Honour in set_man_symlinks;
+ Honour ROOT in set_man_symlinks;
Don't test for -z since the empty string
is a legal value (meaning no compression);
We don't have providers but versions;
diff --git a/app-editors/emacs/files/emacs-21.4-qa.patch b/app-editors/emacs/files/emacs-21.4-qa.patch
new file mode 100644
index 0000000..594a0da
--- /dev/null
+++ b/app-editors/emacs/files/emacs-21.4-qa.patch
@@ -0,0 +1,70 @@
+diff -ur emacs-21.4-orig/lib-src/cvtmail.c emacs-21.4/lib-src/cvtmail.c
+--- emacs-21.4-orig/lib-src/cvtmail.c 2002-02-15 13:06:48.000000000 +0100
++++ emacs-21.4/lib-src/cvtmail.c 2007-03-19 09:02:08.000000000 +0100
+@@ -33,12 +33,15 @@
+ * Author: Larry Kolodney, 1985
+ */
+
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
+
+ #include <stdio.h>
+
+-char *malloc ();
+-char *realloc ();
++#ifndef HAVE_STDLIB_H
+ char *getenv ();
++#endif
+
+ char *xmalloc ();
+ char *xrealloc ();
+diff -ur emacs-21.4-orig/lib-src/yow.c emacs-21.4/lib-src/yow.c
+--- emacs-21.4-orig/lib-src/yow.c 1999-02-26 12:37:05.000000000 +0100
++++ emacs-21.4/lib-src/yow.c 2007-03-19 09:03:50.000000000 +0100
+@@ -10,6 +10,10 @@
+ * With dynamic memory allocation.
+ */
+
++#ifdef HAVE_CONFIG_H
++#include <config.h>
++#endif
++
+ #include <stdio.h>
+ #include <ctype.h>
+ #include <../src/epaths.h> /* For PATH_DATA. */
+@@ -33,8 +37,6 @@
+ &res;})
+ #endif
+
+-char *malloc(), *realloc();
+-
+ void yow();
+ void setup_yow();
+
+diff -ur emacs-21.4-orig/src/prefix-args.c emacs-21.4/src/prefix-args.c
+--- emacs-21.4-orig/src/prefix-args.c 2001-02-22 02:49:37.000000000 +0100
++++ emacs-21.4/src/prefix-args.c 2007-03-19 09:20:27.000000000 +0100
+@@ -43,6 +43,10 @@
+ If I can't write a completely portable program to do this in C,
+ I'm quitting and taking up gardening. */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #include <stdio.h>
+
+ int
+diff -ur emacs-21.4-orig/src/xterm.c emacs-21.4/src/xterm.c
+--- emacs-21.4-orig/src/xterm.c 2002-10-15 16:21:45.000000000 +0200
++++ emacs-21.4/src/xterm.c 2007-03-19 09:13:01.000000000 +0100
+@@ -10899,7 +10899,7 @@
+ if (!tool_bar_p)
+ if (!dpyinfo->x_focus_frame
+ || f == dpyinfo->x_focus_frame)
+- construct_mouse_click (&emacs_event, &event, f);
++ construct_mouse_click (&emacs_event, &event.xbutton, f);
+ }
+ else
+ {