summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-02-15 22:31:15 +0100
committerUlrich Müller <ulm@gentoo.org>2014-02-15 22:31:15 +0100
commitd31433815314d021ce38f275b2cb88ebc55fa43d (patch)
treeff0d31ccd241c08c86ec2b9cfeceb0b31a1beb38
parentRemove www-client category. (diff)
downloademacs-d31433815314d021ce38f275b2cb88ebc55fa43d.tar.gz
emacs-d31433815314d021ce38f275b2cb88ebc55fa43d.tar.bz2
emacs-d31433815314d021ce38f275b2cb88ebc55fa43d.zip
Initial import. Ebuild based on ersatz-emacs-20060515.ebuild, with modifications by me.
Package-Manager: portage-2.2.8-r1
-rw-r--r--app-editors/pemacs/ChangeLog12
-rw-r--r--app-editors/pemacs/Manifest1
-rw-r--r--app-editors/pemacs/metadata.xml16
-rw-r--r--app-editors/pemacs/pemacs-1.5_pre20130322.ebuild41
-rw-r--r--app-editors/pemacs/pemacs-9999.ebuild40
5 files changed, 110 insertions, 0 deletions
diff --git a/app-editors/pemacs/ChangeLog b/app-editors/pemacs/ChangeLog
new file mode 100644
index 0000000..16ca95a
--- /dev/null
+++ b/app-editors/pemacs/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-editors/pemacs
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*pemacs-9999 (15 Feb 2014)
+*pemacs-1.5_pre20130322 (15 Feb 2014)
+
+ 15 Feb 2014; Ulrich Müller <ulm@gentoo.org> +pemacs-1.5_pre20130322.ebuild,
+ +pemacs-9999.ebuild, +metadata.xml:
+ Initial import. Ebuild based on ersatz-emacs-20060515.ebuild, with
+ modifications by me.
+
diff --git a/app-editors/pemacs/Manifest b/app-editors/pemacs/Manifest
new file mode 100644
index 0000000..71a832b
--- /dev/null
+++ b/app-editors/pemacs/Manifest
@@ -0,0 +1 @@
+DIST pemacs-1.5_pre20130322.tar.xz 42380 SHA256 29a2a1af523bbe2ba7bbb782c47dae7d34bc5027f90df090b71948c44c796867 SHA512 4458c045f64e5c4c80067394ad3431d54c14505d259e1055162eb540c7bca4e0e0f1bbadf31b3dc6614faa85e66c9b249b00d50d555a09669513fc465a30871e WHIRLPOOL 03259468ea38243907787bb0e5efa1c9117da5764355746cf5cefb340a218c9ea265f233db6ff2fe60caee620945fedccc3ff82984c424b7a9f33ef39a538c64
diff --git a/app-editors/pemacs/metadata.xml b/app-editors/pemacs/metadata.xml
new file mode 100644
index 0000000..1244e82
--- /dev/null
+++ b/app-editors/pemacs/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Perfect Emacs is a small footprint Emacs derived from Chris Baird's
+ Ersatz Emacs which was based on MicroEMACS 3.6 as released to
+ mod.sources and the Public Domain by Daniel Lawrence in 1986, and
+ was itself based on the work of Steve Wilhite and George Jones to
+ MicroEMACS 2.0 (then also public domain) by Dave Conroy.
+
+ Perfect Emacs is an attempt to find the perfect balance between
+ minimalism (i.e. the smallest functional emacs and code) whilst
+ still retaining the feeling of GNU Emacs.
+</longdescription>
+</pkgmetadata>
diff --git a/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild b/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild
new file mode 100644
index 0000000..4bb68fd
--- /dev/null
+++ b/app-editors/pemacs/pemacs-1.5_pre20130322.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hughbarney/pEmacs.git"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
+ inherit git-r3
+else
+ # snapshot from git repo
+ SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+fi
+
+DESCRIPTION="Perfect Emacs, a small footprint Emacs derived from Ersatz Emacs"
+HOMEPAGE="https://github.com/hughbarney/pEmacs"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin pe
+ doman pe.1
+ dodoc README.md
+}
diff --git a/app-editors/pemacs/pemacs-9999.ebuild b/app-editors/pemacs/pemacs-9999.ebuild
new file mode 100644
index 0000000..03206ae
--- /dev/null
+++ b/app-editors/pemacs/pemacs-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hughbarney/pEmacs.git"
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
+ inherit git-r3
+else
+ # snapshot from git repo
+ SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+fi
+
+DESCRIPTION="Perfect Emacs, a small footprint Emacs derived from Ersatz Emacs"
+HOMEPAGE="https://github.com/hughbarney/pEmacs"
+
+LICENSE="public-domain"
+SLOT="0"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LFLAGS="${LDFLAGS} $("$(tc-getPKG_CONFIG)" --libs ncurses)"
+}
+
+src_install() {
+ dobin pe
+ doman pe.1
+ dodoc README.md
+}