summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-08-15 07:57:39 +0000
committerUlrich Müller <ulm@gentoo.org>2008-08-15 07:57:39 +0000
commit43df7f9df992d646ad852fbb04bf3bb97572a204 (patch)
tree94c0d2aaef2f8888ce8b23220c34020791783411 /app-admin/emacs-updater/emacs-updater-9999.ebuild
parentMask live ebuild for emacs-updater. (diff)
downloademacs-43df7f9df992d646ad852fbb04bf3bb97572a204.tar.gz
emacs-43df7f9df992d646ad852fbb04bf3bb97572a204.tar.bz2
emacs-43df7f9df992d646ad852fbb04bf3bb97572a204.zip
Split off stand-alone package for emacs-updater.
Christian, please revert this commit if you don't agree. ;-) svn path=/emacs-overlay/; revision=1131
Diffstat (limited to 'app-admin/emacs-updater/emacs-updater-9999.ebuild')
-rw-r--r--app-admin/emacs-updater/emacs-updater-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-admin/emacs-updater/emacs-updater-9999.ebuild b/app-admin/emacs-updater/emacs-updater-9999.ebuild
new file mode 100644
index 0000000..a92c3c4
--- /dev/null
+++ b/app-admin/emacs-updater/emacs-updater-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit subversion
+
+DESCRIPTION="Rebuild Emacs packages"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+#SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ESVN_REPO_URI="svn://anonsvn.gentoo.org/emacs/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!<=app-admin/eselect-emacs-1.5
+ !=app-admin/eselect-emacs-9999
+ app-portage/portage-utils
+ virtual/emacs"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ dosbin emacs-updater || die "dosbin failed"
+}