summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-08-25 09:15:14 +0000
committerUlrich Müller <ulm@gentoo.org>2012-08-25 09:15:14 +0000
commit3126abdaa1215a011a33d0db780245e36bca5dcc (patch)
tree0dd7d66871f21c4322102c744ddd0c4d5ab65fbe /app-editors/mg/mg-20110905.ebuild
parentDisplay some elog messages only on first installation. (diff)
downloademacs-3126abdaa1215a011a33d0db780245e36bca5dcc.tar.gz
emacs-3126abdaa1215a011a33d0db780245e36bca5dcc.tar.bz2
emacs-3126abdaa1215a011a33d0db780245e36bca5dcc.zip
Copied from Portage tree.
(Portage version: 2.1.11.11/svn/Linux x86_64, signed Manifest commit with key 7DC6EA25) svn path=/emacs-overlay/; revision=1825
Diffstat (limited to 'app-editors/mg/mg-20110905.ebuild')
-rw-r--r--app-editors/mg/mg-20110905.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-editors/mg/mg-20110905.ebuild b/app-editors/mg/mg-20110905.ebuild
new file mode 100644
index 0000000..cc72d0e
--- /dev/null
+++ b/app-editors/mg/mg-20110905.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Micro GNU/emacs, a port from the BSDs"
+HOMEPAGE="http://homepage.boetes.org/software/mg/"
+SRC_URI="http://homepage.boetes.org/software/mg/${P}.tar.gz"
+
+LICENSE="public-domain BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="livecd"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # econf won't work, as this script does not accept any parameters
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall
+ dodoc README tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}