summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-08-21 11:54:07 +0000
committerUlrich Müller <ulm@gentoo.org>2011-08-21 11:54:07 +0000
commit2c614aaec6f55bfa730750b34787d8165025f8a6 (patch)
tree82c3ddc5cf3676ab0923088b43ff3ade9fabec71 /app-editors/uemacs-pk/uemacs-pk-9999.ebuild
parentUpdate mask. (diff)
downloademacs-2c614aaec6f55bfa730750b34787d8165025f8a6.tar.gz
emacs-2c614aaec6f55bfa730750b34787d8165025f8a6.tar.bz2
emacs-2c614aaec6f55bfa730750b34787d8165025f8a6.zip
Package renamed to uemacs-pk. Snapshot moved to portage tree.
svn path=/emacs-overlay/; revision=1680
Diffstat (limited to 'app-editors/uemacs-pk/uemacs-pk-9999.ebuild')
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-9999.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/uemacs-pk/uemacs-pk-9999.ebuild b/app-editors/uemacs-pk/uemacs-pk-9999.ebuild
new file mode 100644
index 0000000..88a635d
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+EGIT_REPO_URI="git://git.kernel.org/pub/scm/editors/uemacs/uemacs.git"
+
+inherit git-2 toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="http://git.kernel.org/?p=editors/uemacs/uemacs.git;a=summary
+ ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+SRC_URI=""
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e "s:/usr/lib/:/usr/share/${PN}/:" epath.h || die
+ # Respect LDFLAGS when linking
+ sed -i -e 's/\(\$(CC) \$(DEFINES)\) \(-o \$@\)/\1 $(LDFLAGS) \2/' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin em
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc README readme.39e emacs.ps UTF-8-demo.txt
+}