summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-06-08 13:39:28 +0000
committerHans de Graaff <graaff@gentoo.org>2008-06-08 13:39:28 +0000
commitc2afe5474a9b48b649c1248c7844d9cd7d564ff6 (patch)
tree6ee1e960cdcf95bfc8fca852df157e60aa268fad /app-editors
parentUpdate postgres dependency to use the virtual (diff)
downloademacs-c2afe5474a9b48b649c1248c7844d9cd7d564ff6.tar.gz
emacs-c2afe5474a9b48b649c1248c7844d9cd7d564ff6.tar.bz2
emacs-c2afe5474a9b48b649c1248c7844d9cd7d564ff6.zip
Cleanup of the ebuild including some minor bug fixing
svn path=/xemacs-overlay/; revision=1089
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/xemacs/ChangeLog10
-rw-r--r--app-editors/xemacs/Manifest3
-rw-r--r--app-editors/xemacs/xemacs-21.5.28-r4.ebuild255
3 files changed, 267 insertions, 1 deletions
diff --git a/app-editors/xemacs/ChangeLog b/app-editors/xemacs/ChangeLog
index f63cc7a..5970a21 100644
--- a/app-editors/xemacs/ChangeLog
+++ b/app-editors/xemacs/ChangeLog
@@ -2,6 +2,16 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Jun 2008; Hans de Graaff <graaff@gentoo.org> ChangeLog:
+ Cleanup of ebuild partly based on jmglov's now-removed 21.5.28 ebuild:
+ - enable freewnn also on amd64
+ - use use_with for more compact use flag handling
+ - actually support the alsa use flag
+ - remove 21.4-specific workarounds
+ - use proper configure flag for optimizations
+ - remove obsolete comments and add proper die messages
+ - use emake
+
03 May 2008; Hans de Graaff <graaff@gentoo.org> ChangeLog:
Fix a problem caused by GCC 4.1.2 optimization.
diff --git a/app-editors/xemacs/Manifest b/app-editors/xemacs/Manifest
index 324036e..22898c6 100644
--- a/app-editors/xemacs/Manifest
+++ b/app-editors/xemacs/Manifest
@@ -8,4 +8,5 @@ DIST NeXT_XEmacs.tar.gz 39571 RMD160 3c2cedf75e4ece412031b20a15614a78367393f4 SH
DIST xemacs-21.5.28.tar.gz 15310202 RMD160 a225a2da39c22dccbc5d14399d40dadecead5e11 SHA1 6de5f4b4cecac0480dd9ff50170a72f23f36dbac SHA256 588a3970ee44426975cd86026a932ed0e2cf47f597ebcf76d376bbd18638eae2
EBUILD xemacs-21.5.28-r2.ebuild 7386 RMD160 411544516e4755156719f5a4b2697268d09ac257 SHA1 c46aabcc30bd69a2ba83064ca606d302a8f2ff5b SHA256 88e6d50290ddd103ca9605070a3a491ff57756ff33d933a1af724188e0b72566
EBUILD xemacs-21.5.28-r3.ebuild 7649 RMD160 0e1413da36c50ba20d1ee1d22b4f519753fd8264 SHA1 3d4dd3f925e539f005d4bef9845121accdfb3ecd SHA256 1651863b5b7e70c713b5edfe75109eaf47ee8c115c75ba2f2713eb4fe5f758b4
-MISC ChangeLog 728 RMD160 38b87b33ed9a38c2916cb422eca645ac0ac53968 SHA1 148b744f2be20f56c8c4a7c2b5483f961f04f458 SHA256 621ba3a4a6de1094ee81ad990831fc99597bb5e02875703d4599ddc0b69506ad
+EBUILD xemacs-21.5.28-r4.ebuild 7070 RMD160 62c065b5c903a89b21ec7f2cb0c8116a159c0dc8 SHA1 0b5a29f3470bb3e8afc103b24f92815b6309eba3 SHA256 28378ad056080db5924b7abd6fcb32191096976a93399ae19c735970cce4d704
+MISC ChangeLog 1143 RMD160 e604193ecb2c18bbd3ce98df86b006a5c18a7cae SHA1 24056ae41b0b3653c32c17a7edce387a13900550 SHA256 72fd08ae22d8ef5598802ed7deda19b818a7278d2d1673655f9c5f1f9ca37fb7
diff --git a/app-editors/xemacs/xemacs-21.5.28-r4.ebuild b/app-editors/xemacs/xemacs-21.5.28-r4.ebuild
new file mode 100644
index 0000000..b35653e
--- /dev/null
+++ b/app-editors/xemacs/xemacs-21.5.28-r4.ebuild
@@ -0,0 +1,255 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xemacs/xemacs-21.4.20-r3.ebuild,v 1.4 2007/04/30 23:04:57 ulm Exp $
+
+# Note: xemacs currently does not work with a hardened profile. If you
+# want to use xemacs on a hardened profile then compile with the
+# -nopie flag in CFLAGS or help fix bug #75028.
+
+export WANT_AUTOCONF="2.5"
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="highly customizable open source text editor and application development system"
+HOMEPAGE="http://www.xemacs.org/"
+SRC_URI="http://ftp.xemacs.org/xemacs-21.5/${P}.tar.gz
+ http://www.malfunction.de/afterstep/files/NeXT_XEmacs.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug eolconv esd gif gpm pop postgres ldap xface nas dnd X jpeg tiff png mule motif freewnn canna xft xim athena neXt Xaw3d gdbm berkdb"
+
+X_DEPEND="x11-libs/libXt x11-libs/libXmu x11-libs/libXext x11-misc/xbitmaps"
+
+DEPEND="virtual/libc
+ !virtual/xemacs
+ berkdb? ( sys-libs/db )
+ gdbm? ( >=sys-libs/gdbm-1.8.3 )
+ >=sys-libs/zlib-1.1.4
+ >=dev-libs/openssl-0.9.6
+ >=media-libs/audiofile-0.2.3
+ gpm? ( >=sys-libs/gpm-1.19.6 )
+ postgres? ( >=virtual/postgresql-base-7.2 )
+ ldap? ( net-nds/openldap )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ X? ( $X_DEPEND !Xaw3d? ( !neXt? ( x11-libs/libXaw ) ) )
+ dnd? ( x11-libs/dnd )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ athena? ( x11-libs/libXaw )
+ Xaw3d? ( x11-libs/Xaw3d )
+ xft? ( media-libs/freetype x11-libs/libXrender media-libs/fontconfig )
+ neXt? ( x11-libs/neXtaw )
+ xface? ( media-libs/compface )
+ tiff? ( media-libs/tiff )
+ png? ( =media-libs/libpng-1.2* )
+ jpeg? ( media-libs/jpeg )
+ canna? ( app-i18n/canna )
+ freewnn? ( app-i18n/freewnn )
+ >=sys-libs/ncurses-5.2
+ >=app-admin/eselect-emacs-0.7-r1"
+
+PDEPEND="app-xemacs/xemacs-base
+ mule? ( app-xemacs/mule-base )"
+
+PROVIDE="virtual/xemacs"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ use neXt && unpack NeXT_XEmacs.tar.gz
+
+ cd "${S}"
+
+ # see bug 58350, 102540 and 143580
+ epatch "${FILESDIR}"/gdbm-and-db.patch
+
+ # Fix font-lock-warning-face not being exported, needed for
+ # gentoo-syntax
+ epatch "${FILESDIR}"/font-lock-warning-face.patch
+
+ # Fix for crash and security issue in #200297, fix from upstream CVS
+ epatch "${FILESDIR}"/${P}-int-format.patch
+
+ # Fix security issue in vcdiff script
+ epatch "${FILESDIR}"/${P}-vcdiff.patch
+
+ # Fix problem caused by improper optimization with GCC 4.1.2 on x86
+ # (and possibly other arches, but only confirmed on x86). See
+ # http://tracker.xemacs.org/XEmacs/its/issue354 for the upstream
+ # bug.
+ epatch "${FILESDIR}"/${P}-optimization-bug.patch
+
+ eautoconf
+
+ use neXt && cp "${WORKDIR}"/NeXT.XEmacs/xemacs-icons/* "${S}"/etc/toolbar/
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+
+ myconf="${myconf} --with-widgets=athena"
+ myconf="${myconf} --with-dialogs=athena"
+ myconf="${myconf} --with-menubars=lucid"
+ myconf="${myconf} --with-scrollbars=lucid"
+ if use motif ; then
+ myconf="--with-widgets=motif"
+ myconf="${myconf} --with-dialogs=motif"
+ myconf="${myconf} --with-scrollbars=motif"
+ myconf="${myconf} --with-menubars=lucid"
+ fi
+ if use athena ; then
+ myconf="--with-scrollbars=athena"
+ fi
+
+ if use Xaw3d; then
+ myconf="${myconf} --with-athena=3d"
+ elif use neXt; then
+ myconf="${myconf} --with-athena=next"
+ else
+ myconf="${myconf} --with-athena=xaw"
+ fi
+
+ use dnd && myconf="${myconf} --with-dragndrop --with-offix"
+
+ myconf="${myconf} $(use_with tiff )"
+ myconf="${myconf} $(use_with png )"
+ myconf="${myconf} $(use_with jpeg )"
+ myconf="${myconf} $(use_with xface )"
+
+ use xft && myconf="${myconf} --with-xft=emacs,tabs,menubars,gauges" ||
+ myconf="${myconf} --with-xft=no"
+
+ else
+ myconf="${myconf}
+ --without-x
+ --without-xpm
+ --without-dragndrop
+ --with-xft=no
+ --with-gif=no"
+ fi
+
+ if use mule ; then
+ myconf="${myconf} --with-mule"
+
+ if use xim ; then
+ if use motif ; then
+ myconf="${myconf} --with-xim=motif"
+ else
+ myconf="${myconf} --with-xim=xlib"
+ fi
+ else
+ myconf="${myconf} --with-xim=no"
+ fi
+
+ myconf="${myconf} $(use_with canna )"
+ myconf="${myconf} $(use_with freewnn wnn )"
+ fi
+
+ # This determines the type of sounds we are playing
+ local soundconf="native"
+
+ # This determines how these sounds should be played
+ use nas && soundconf="${soundconf},nas"
+ use esd && soundconf="${soundconf},esd"
+ use alsa && soundconf="${soundconf},alsa"
+
+ myconf="${myconf} --with-sound=${soundconf}"
+
+ if use gdbm || use berkdb ; then
+ if use gdbm ; then
+ mydb="gdbm"
+ # We have GDBM in a non-standard location
+ append-flags "-I/usr/include/gdbm"
+ fi
+
+ use berkdb && mydb="${mydb},berkdb"
+
+ myconf="${myconf} --with-database=${mydb}"
+ else
+ myconf="${myconf} --without-database"
+ fi
+
+ use debug && myconf="${myconf} --with-optimization=no --with-debug" ||
+ myconf="${myconf} --with-optimization=yes"
+
+ econf ${myconf} \
+ $(use_with gif ) \
+ $(use_with gpm ) \
+ $(use_with postgres postgresql ) \
+ $(use_with ldap ) \
+ $(use_with eolconv file-coding ) \
+ $(use_with pop ) \
+ --prefix=/usr \
+ --with-ncurses \
+ --with-msw=no \
+ --with-mail-locking=flock \
+ --with-site-lisp=yes \
+ --with-site-modules=yes \
+ --with-newgc \
+ || die "configuration failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake prefix="${D}"/usr \
+ mandir="${D}"/usr/share/man/man1 \
+ infodir="${D}"/usr/share/info \
+ libdir="${D}"/usr/lib \
+ install gzip-el || die
+
+ # Rename some applications installed in bin so that it is clear
+ # which application installed them and so that conflicting
+ # packages (emacs) can't clobber the actual applications.
+ # Addresses bug #62991.
+ for i in b2m ctags etags rcs-checkin ; do
+ mv "${D}"/usr/bin/${i} "${D}"/usr/bin/${i}-xemacs || die "mv ${i} failed"
+ done
+
+ # rename man pages
+ for i in ctags etags; do
+ mv "${D}"/usr/share/man/man1/${i}{,-xemacs}.1 || die "mv ${i}.1 failed"
+ done
+
+ # install base packages directories
+ dodir /usr/lib/xemacs/xemacs-packages/
+ dodir /usr/lib/xemacs/site-packages/
+ dodir /usr/lib/xemacs/site-modules/
+ dodir /usr/lib/xemacs/site-lisp/
+
+ if use mule;
+ then
+ dodir /usr/lib/xemacs/mule-packages
+ fi
+
+ # remove extraneous info files
+ cd "${D}"/usr/share/info
+ rm -f dir info.info texinfo* termcap* standards*
+
+ cd "${S}"
+ dodoc CHANGES-* ChangeLog INSTALL Installation PROBLEMS README*
+ dodoc "${FILESDIR}"/README.Gentoo
+
+ insinto /usr/share/pixmaps
+ newins "${S}"/etc/${PN}-icon.xpm ${PN}.xpm
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+}
+
+pkg_postinst() {
+ eselect emacs update --if-unset
+
+ einfo "If you are upgrading from XEmacs 21.4 you should note the following"
+ einfo "incompatibilities:"
+ einfo "- Mule-UCS is no longer supported due to proper UTF-8 support in XEmacs 21.5"
+ einfo "- The X resource class has changed from Emacs to XEmacs,"
+ einfo " settings in your .Xdefaults file should be updated accordingly."
+}
+
+pkg_postrm() {
+ eselect emacs update --if-unset
+}