summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2021-04-13 07:59:16 +0200
committerUlrich Müller <ulm@gentoo.org>2021-04-13 07:59:16 +0200
commitc74aff5d5305b5c2d89b2d63691ca0c84b983a98 (patch)
tree6be52505f7e5b07e99068f5e020027d0aa2bea45 /app-emacs/anything/anything-9999.ebuild
parentelisp*.eclass: Drop support for EAPI 4 (diff)
downloademacs-c74aff5d5305b5c2d89b2d63691ca0c84b983a98.tar.gz
emacs-c74aff5d5305b5c2d89b2d63691ca0c84b983a98.tar.bz2
emacs-c74aff5d5305b5c2d89b2d63691ca0c84b983a98.zip
app-emacs/anything: Remove package
This has been replaced by app-emacs/helm which is in the Gentoo repo. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/anything/anything-9999.ebuild')
-rw-r--r--app-emacs/anything/anything-9999.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/app-emacs/anything/anything-9999.ebuild b/app-emacs/anything/anything-9999.ebuild
deleted file mode 100644
index 5647e5a..0000000
--- a/app-emacs/anything/anything-9999.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit elisp
-
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="git://repo.or.cz/anything-config.git"
- EGIT_CHECKOUT_DIR="${WORKDIR}/anything-config"
- inherit git-r3
-else
- # snapshot from upstream git repo
- SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.gz"
-fi
-
-DESCRIPTION="Open anything - QuickSilver-like candidate-selection framework"
-HOMEPAGE="http://www.emacswiki.org/emacs/Anything"
-
-LICENSE="GPL-3+"
-SLOT="0"
-IUSE="extensions"
-
-S="${WORKDIR}/anything-config"
-SITEFILE="50${PN}-gentoo.el"
-
-src_compile() {
- elisp-compile *.el || die
- elisp-make-autoload-file || die
-
- if use extensions; then
- BYTECOMPFLAGS="-L . -L extensions" elisp-compile extensions/*.el || die
- fi
-}
-
-src_install() {
- elisp-install ${PN} *.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
-
- if use extensions; then
- elisp-install ${PN} extensions/*.{el,elc} || die
- fi
-
- dodoc README doc/anything.pdf
-}