summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2019-12-25 13:13:39 +0100
committerUlrich Müller <ulm@gentoo.org>2019-12-25 13:13:39 +0100
commitfea8f0807821dbd5410619522db9a5e17d4f8b11 (patch)
treef05eb614de7b107eb8a5eb58d6575f8211c43ada /app-emacs/elib/elib-1.0-r1.ebuild
parentmode-compile removed 2019-11-04 bug 666836 (diff)
downloademacs-fea8f0807821dbd5410619522db9a5e17d4f8b11.tar.gz
emacs-fea8f0807821dbd5410619522db9a5e17d4f8b11.tar.bz2
emacs-fea8f0807821dbd5410619522db9a5e17d4f8b11.zip
elib removed 2019-12-25 bug 701160
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-emacs/elib/elib-1.0-r1.ebuild')
-rw-r--r--app-emacs/elib/elib-1.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-emacs/elib/elib-1.0-r1.ebuild b/app-emacs/elib/elib-1.0-r1.ebuild
new file mode 100644
index 0000000..331d040
--- /dev/null
+++ b/app-emacs/elib/elib-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="The Emacs Lisp Library"
+HOMEPAGE="http://jdee.sourceforge.net"
+SRC_URI="http://jdee.sunsite.dk/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-texinfo-5.patch"
+ sed -i 's:--infodir:--info-dir:g' Makefile || die
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ dodir "${SITELISP}/elib"
+ dodir /usr/share/info
+ emake prefix="${ED}/usr" infodir="${ED}/usr/share/info" install
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog NEWS README TODO
+}