summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-11-15 14:43:58 +0100
committerUlrich Müller <ulm@gentoo.org>2013-11-15 14:43:58 +0100
commite94e71c712dd52c9f1c6b9543eff519898f2e08f (patch)
treeb2f617a877012d9eab8042869b7363f5dafdbd3e /app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
parentRefuse installation if the site-start.el file is still in its old location; w... (diff)
downloademacs-e94e71c712dd52c9f1c6b9543eff519898f2e08f.tar.gz
emacs-e94e71c712dd52c9f1c6b9543eff519898f2e08f.tar.bz2
emacs-e94e71c712dd52c9f1c6b9543eff519898f2e08f.zip
Install initial site-gentoo.el file from tarball.
Package-Manager: portage-2.2.7
Diffstat (limited to 'app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild')
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
index 8994fe0..f60db4f 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999.ebuild
@@ -34,6 +34,7 @@ pkg_setup() {
src_install() {
insinto "${SITELISP}"
doins subdirs.el
+ newins site-gentoo.el site-gentoo.el.orig
keepdir /etc/emacs
insinto /etc/emacs
@@ -93,8 +94,13 @@ site-start-modified-p() {
pkg_preinst() {
# make sure that site-gentoo.el exists since site-start.el requires it
- elisp-site-regen
- cp "${EROOT}${SITELISP}/site-gentoo.el" "${ED}${SITELISP}/" || die
+ if [[ -d ${EROOT}${SITELISP} ]]; then
+ elisp-site-regen
+ cp "${EROOT}${SITELISP}/site-gentoo.el" "${ED}${SITELISP}/" || die
+ rm "${ED}${SITELISP}/site-gentoo.el.orig" || die
+ else
+ mv "${ED}${SITELISP}"/site-gentoo.el{.orig,} || die
+ fi
if use games; then
local f