summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2015-02-19 23:12:35 +0100
committerUlrich Müller <ulm@gentoo.org>2015-02-19 23:12:35 +0100
commit075711ddee821d79f2421fa2f7ef3422953cbcc5 (patch)
tree85358c02131ed96276bba18bbef723a759a2cbad /app-emacs/emacs-common-gentoo
parentapp-emacs/emacs-common-gentoo: Fix permissions of shared score dir in pkg_pos... (diff)
downloademacs-075711ddee821d79f2421fa2f7ef3422953cbcc5.tar.gz
emacs-075711ddee821d79f2421fa2f7ef3422953cbcc5.tar.bz2
emacs-075711ddee821d79f2421fa2f7ef3422953cbcc5.zip
app-emacs/emacs-common-gentoo: Use "gamestat" group for shared score files, following QA tree policy.
Package-Manager: portage-2.2.17
Diffstat (limited to 'app-emacs/emacs-common-gentoo')
-rw-r--r--app-emacs/emacs-common-gentoo/ChangeLog4
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild16
2 files changed, 13 insertions, 7 deletions
diff --git a/app-emacs/emacs-common-gentoo/ChangeLog b/app-emacs/emacs-common-gentoo/ChangeLog
index 40b3c91..dd947e4 100644
--- a/app-emacs/emacs-common-gentoo/ChangeLog
+++ b/app-emacs/emacs-common-gentoo/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 19 Feb 2015; Ulrich Müller <ulm@gentoo.org>
+ emacs-common-gentoo-9999-r1.ebuild:
+ Use "gamestat" group for shared score files, following QA tree policy.
+
10 Feb 2015; Ulrich Müller <ulm@gentoo.org>
emacs-common-gentoo-9999-r1.ebuild:
Fix permissions of shared score dir in pkg_postinst.
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
index 564b4bf..2d872dd 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
@@ -22,7 +22,7 @@ PDEPEND="virtual/emacs"
S="${WORKDIR}/${PN}"
pkg_setup() {
- use games && enewgroup scores 36
+ use games && enewgroup gamestat 36
}
src_install() {
@@ -36,7 +36,7 @@ src_install() {
if use games; then
keepdir /var/games/emacs
- fowners root:scores /var/games/emacs
+ fowners root:gamestat /var/games/emacs
fperms g+w /var/games/emacs
fi
@@ -107,7 +107,7 @@ pkg_preinst() {
cp "${EROOT}/var/lib${f#/var}" "${ED}${f}" || die
fi
touch "${ED}${f}" || die
- chown root:scores "${ED}${f}" || die
+ chown root:gamestat "${ED}${f}" || die
chmod g+w "${ED}${f}" || die
done
fi
@@ -129,10 +129,12 @@ pkg_preinst() {
}
pkg_postinst() {
- # update permissions of shared score dir
- chmod 755 "${EROOT}"/var/games
- chown root:scores "${EROOT}"/var/games/emacs
- chmod 775 "${EROOT}"/var/games/emacs
+ if use games; then
+ # update permissions of shared score dir
+ chmod 755 "${EROOT}"/var/games
+ chown root:gamestat "${EROOT}"/var/games/emacs
+ chmod 775 "${EROOT}"/var/games/emacs
+ fi
if use X; then
fdo-mime_desktop_database_update