summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-06-22 13:56:25 +0000
committerUlrich Müller <ulm@gentoo.org>2008-06-22 13:56:25 +0000
commit7ed191fc13369b46f66b65ccecd7a640ee657853 (patch)
tree05c0e7dc50f1239016613e82c07beb83d57dbd42 /app-emacs
parentMoved to Portage tree. (diff)
downloademacs-7ed191fc13369b46f66b65ccecd7a640ee657853.tar.gz
emacs-7ed191fc13369b46f66b65ccecd7a640ee657853.tar.bz2
emacs-7ed191fc13369b46f66b65ccecd7a640ee657853.zip
Initial import, bug 228723.
svn path=/emacs-overlay/; revision=1106
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/bongo/ChangeLog11
-rw-r--r--app-emacs/bongo/Manifest6
-rw-r--r--app-emacs/bongo/bongo-20070619.ebuild48
-rw-r--r--app-emacs/bongo/files/50bongo-gentoo.el6
-rw-r--r--app-emacs/bongo/files/bongo-20070619-fix-require.patch11
-rw-r--r--app-emacs/bongo/metadata.xml5
6 files changed, 87 insertions, 0 deletions
diff --git a/app-emacs/bongo/ChangeLog b/app-emacs/bongo/ChangeLog
new file mode 100644
index 0000000..59ef043
--- /dev/null
+++ b/app-emacs/bongo/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/bongo
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*bongo-20070619 (22 Jun 2008)
+
+ 22 Jun 2008; Ulrich Mueller <ulm@gentoo.org> +files/50bongo-gentoo.el,
+ +files/bongo-20070619-fix-require.patch, +metadata.xml,
+ +bongo-20070619.ebuild:
+ Initial import, bug 228723. Ebuild contributed by me.
+
diff --git a/app-emacs/bongo/Manifest b/app-emacs/bongo/Manifest
new file mode 100644
index 0000000..0de7e93
--- /dev/null
+++ b/app-emacs/bongo/Manifest
@@ -0,0 +1,6 @@
+AUX 50bongo-gentoo.el 193 RMD160 2f2df265a712a2955d95c6b6a9f9c8d0e75345bc SHA1 db2b13cb5a6dda0df9c5552ddcf742a17bd4ae8a SHA256 268d57ad3d84870af45d87c1a060df2a5e06b11127d24b140a41614e6be4866e
+AUX bongo-20070619-fix-require.patch 224 RMD160 e4a1ce68d5fc982251d9bbbaa1d2aed417c20ece SHA1 0badaea162b26bfd54cd5d72de73e4417b033c1a SHA256 3570a83fa4c77e99f761475937587e4d0485661896adc79159fdebd44a04a879
+DIST bongo-20070619.tar.bz2 97341 RMD160 84fbc62b64541b2d19ab0100a944ef6d2dab98d8 SHA1 59a84838ea6550f6b128b3e84dacd6c9ce3d57ef SHA256 a4758e6f60e32f90aa0416c5f5a522dc8edb131ce4aa76212b542b941e12a4d8
+EBUILD bongo-20070619.ebuild 1042 RMD160 d42cd457b00439475edd504e20a1e210c8b6d1fb SHA1 113ed7c6c80e83fea6c5e425ac455e7c358a7889 SHA256 348ba5d0704f1f9faa4768dd5a264a14d7fe9f1a4fa79b13d9fa2c70b4b825db
+MISC ChangeLog 361 RMD160 83217e9406cc4510b1f9d840e7f98c9982ffa1a2 SHA1 39030071aca3c69e79d68c339b7d7e2dd24b08a2 SHA256 e363458ca8504b23c952abc308c60bfc1fde34b53798fa61a2a0035644473295
+MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
diff --git a/app-emacs/bongo/bongo-20070619.ebuild b/app-emacs/bongo/bongo-20070619.ebuild
new file mode 100644
index 0000000..775ee6e
--- /dev/null
+++ b/app-emacs/bongo/bongo-20070619.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+NEED_EMACS=22
+
+inherit elisp eutils
+
+DESCRIPTION="Buffer-oriented media player for Emacs"
+HOMEPAGE="http://www.brockman.se/software/bongo/"
+# Darcs snapshot of http://www.brockman.se/software/bongo/
+SRC_URI="http://dev.gentoo.org/~ulm/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${PN}"
+SITEFILE=50${PN}-gentoo.el
+DOCS="NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need Emacs 22 for image-load-path anyway, so don't bother with 21.
+ rm -f bongo-emacs21.el
+
+ epatch "${FILESDIR}/${P}-fix-require.patch"
+}
+
+src_compile() {
+ elisp_src_compile
+ makeinfo bongo.texinfo || die "makeinfo failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins *.pbm *.png || die "doins failed"
+
+ # needs additional dependencies Ruby-taglib and Mahoro
+ #dobin tree-from-tags.rb || die "dobin failed"
+
+ doinfo bongo.info || die "doinfo failed"
+}
diff --git a/app-emacs/bongo/files/50bongo-gentoo.el b/app-emacs/bongo/files/50bongo-gentoo.el
new file mode 100644
index 0000000..34745b8
--- /dev/null
+++ b/app-emacs/bongo/files/50bongo-gentoo.el
@@ -0,0 +1,6 @@
+
+;;; bongo site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'image-load-path "@SITEETC@" t)
+(autoload 'bongo "bongo" "Start Bongo by switching to a Bongo buffer." t)
diff --git a/app-emacs/bongo/files/bongo-20070619-fix-require.patch b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
new file mode 100644
index 0000000..6b3e6ff
--- /dev/null
+++ b/app-emacs/bongo/files/bongo-20070619-fix-require.patch
@@ -0,0 +1,11 @@
+--- bongo-orig/bongo.el 2007-06-19 16:51:37.000000000 +0200
++++ bongo/bongo.el 2008-06-22 15:30:23.000000000 +0200
+@@ -67,7 +67,7 @@
+
+ ;;; Code:
+
+-(eval-when-compile
++(eval-and-compile
+ (require 'cl)
+ (require 'rx))
+
diff --git a/app-emacs/bongo/metadata.xml b/app-emacs/bongo/metadata.xml
new file mode 100644
index 0000000..bc306fe
--- /dev/null
+++ b/app-emacs/bongo/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>