summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/emacs-updater/emacs-updater-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-admin/emacs-updater/emacs-updater-9999.ebuild b/app-admin/emacs-updater/emacs-updater-9999.ebuild
index 4045d28..e25f250 100644
--- a/app-admin/emacs-updater/emacs-updater-9999.ebuild
+++ b/app-admin/emacs-updater/emacs-updater-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="git://anongit.gentoo.org/proj/emacs-tools.git"
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/emacs-tools.git"
EGIT_BRANCH="${PN}"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
inherit git-r3
DESCRIPTION="Rebuild Emacs packages"
-HOMEPAGE="http://wiki.gentoo.org/wiki/Project:Emacs"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
LICENSE="GPL-2+"
SLOT="0"
@@ -23,6 +23,8 @@ RDEPEND="${DEPEND}
S="${WORKDIR}/${PN}"
src_prepare() {
+ default
+
if ! has_version sys-apps/util-linux; then
# BSD ships a dumb getopt(1), so use getopt-long instead
sed -i -e '/^GETOPT=/s/getopt/&-long/' emacs-updater || die