summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/mode-compile/Manifest1
-rw-r--r--app-emacs/mode-compile/files/50mode-compile-gentoo.el5
-rw-r--r--app-emacs/mode-compile/metadata.xml12
-rw-r--r--app-emacs/mode-compile/mode-compile-2.29.1.ebuild17
4 files changed, 35 insertions, 0 deletions
diff --git a/app-emacs/mode-compile/Manifest b/app-emacs/mode-compile/Manifest
new file mode 100644
index 0000000..7b4b89a
--- /dev/null
+++ b/app-emacs/mode-compile/Manifest
@@ -0,0 +1 @@
+DIST mode-compile-2.29.1.tar.gz 22924 BLAKE2B 7ef71f958ffd5022ddcc64c07ef60822af5bc4a1f5deac5c4e57ce63cd9596d5f612d73eb9cdac627ecfef59e893d795afbeaa19b380b0cc4291bb4dc23fc05c SHA512 bc43d9cae411f5177ce70c736041db74c6db1dc5b766b22b92227e9e1324d304276bd104d8e3cac9ff5a877fc48b6da5b904e1acdb6cca7396fc7c26cc572815
diff --git a/app-emacs/mode-compile/files/50mode-compile-gentoo.el b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
new file mode 100644
index 0000000..d8dc273
--- /dev/null
+++ b/app-emacs/mode-compile/files/50mode-compile-gentoo.el
@@ -0,0 +1,5 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'mode-compile "mode-compile"
+ "Command to compile current buffer file based on the major mode" t)
+(autoload 'mode-compile-kill "mode-compile"
+ "Command to kill a compilation launched by `mode-compile'" t)
diff --git a/app-emacs/mode-compile/metadata.xml b/app-emacs/mode-compile/metadata.xml
new file mode 100644
index 0000000..1c9e6cc
--- /dev/null
+++ b/app-emacs/mode-compile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<stabilize-allarches/>
+<upstream>
+ <remote-id type="github">emacsmirror/mode-compile</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/mode-compile/mode-compile-2.29.1.ebuild b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
new file mode 100644
index 0000000..9f05df6
--- /dev/null
+++ b/app-emacs/mode-compile/mode-compile-2.29.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Smart command for compiling files according to major-mode"
+HOMEPAGE="https://github.com/emacsmirror/mode-compile
+ https://www.emacswiki.org/emacs/ModeCompile"
+SRC_URI="https://github.com/emacsmirror/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+SITEFILE="50${PN}-gentoo.el"