summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/emacs/emacs-23.4-r21.ebuild18
-rw-r--r--app-editors/emacs/emacs-24.3-r8.ebuild11
-rw-r--r--app-editors/emacs/emacs-24.5-r11.ebuild11
-rw-r--r--app-editors/emacs/metadata.xml2
-rw-r--r--app-emacs/emacs-common/emacs-common-9999.ebuild11
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild2
-rw-r--r--eclass/elisp-common.eclass55
-rw-r--r--eclass/elisp.eclass2
-rw-r--r--profiles/eapi1
9 files changed, 47 insertions, 66 deletions
diff --git a/app-editors/emacs/emacs-23.4-r21.ebuild b/app-editors/emacs/emacs-23.4-r21.ebuild
index 697eed5..dd70dda 100644
--- a/app-editors/emacs/emacs-23.4-r21.ebuild
+++ b/app-editors/emacs/emacs-23.4-r21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,8 +13,8 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="23"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alsa aqua athena dbus games gconf gif gpm gtk gui gzip-el jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars Xaw3d xft +xpm"
+KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alsa aqua athena dbus games gif gpm gtk gui gzip-el jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars Xaw3d xft +xpm"
RDEPEND="acct-group/mail
app-emacs/emacs-common[games?,gui(-)?]
@@ -30,7 +30,6 @@ RDEPEND="acct-group/mail
x11-libs/libSM
x11-libs/libX11
x11-misc/xbitmaps
- gconf? ( >=gnome-base/gconf-2.26.2 )
gif? ( media-libs/giflib:0= )
jpeg? ( media-libs/libjpeg-turbo:0= )
png? ( >=media-libs/libpng-1.4:0= )
@@ -119,14 +118,9 @@ src_prepare() {
src_configure() {
strip-flags
filter-flags -fstrict-aliasing -pie
- append-flags $(test-flags -fno-strict-aliasing)
+ append-flags -std=gnu17 -fno-strict-aliasing -Wno-implicit
append-ldflags $(test-flags -no-pie) #639568
-
- if use ia64; then
- replace-flags "-O[2-9]" -O1 #325373
- else
- replace-flags "-O[3-9]" -O2
- fi
+ replace-flags "-O[3-9]" -O2
# Don't trigger a floating point exception for NaNs on alpha
use alpha && append-flags -mieee
@@ -150,7 +144,7 @@ src_configure() {
myconf+=" --without-x"
else
myconf+=" --with-x --without-ns"
- myconf+=" $(use_with gconf)"
+ myconf+=" --without-gconf"
myconf+=" $(use_with toolkit-scroll-bars)"
myconf+=" $(use_with gif)"
myconf+=" $(use_with jpeg)"
diff --git a/app-editors/emacs/emacs-24.3-r8.ebuild b/app-editors/emacs/emacs-24.3-r8.ebuild
index 9c4d40e..ea4c2eb 100644
--- a/app-editors/emacs/emacs-24.3-r8.ebuild
+++ b/app-editors/emacs/emacs-24.3-r8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.xz
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="24.3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="alsa aqua athena dbus gif gpm gsettings gtk gtk2 gui gzip-el imagemagick jpeg kerberos libxml2 livecd m17n-lib motif png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm"
RDEPEND="app-emacs/emacs-common[gui(-)?]
@@ -142,12 +142,7 @@ src_configure() {
strip-flags
filter-flags -pie #526948
append-ldflags $(test-flags -no-pie) #639570
-
- if use ia64; then
- replace-flags "-O[2-9]" -O1 #325373
- else
- replace-flags "-O[3-9]" -O2
- fi
+ replace-flags "-O[3-9]" -O2
# Don't trigger a floating point exception for NaNs on alpha
use alpha && append-flags -mieee
diff --git a/app-editors/emacs/emacs-24.5-r11.ebuild b/app-editors/emacs/emacs-24.5-r11.ebuild
index 1ae3f49..e79dd9e 100644
--- a/app-editors/emacs/emacs-24.5-r11.ebuild
+++ b/app-editors/emacs/emacs-24.5-r11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.xz
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="24"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="acl alsa aqua athena dbus games gfile gif gpm gsettings gtk gui gzip-el imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif png selinux sound source ssl svg tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm zlib"
RDEPEND="acct-group/mail
@@ -113,12 +113,7 @@ src_configure() {
strip-flags
filter-flags -pie #526948
append-ldflags $(test-flags -no-pie) #639570
-
- if use ia64; then
- replace-flags "-O[2-9]" -O1 #325373
- else
- replace-flags "-O[3-9]" -O2
- fi
+ replace-flags "-O[3-9]" -O2
# Don't trigger a floating point exception for NaNs on alpha
use alpha && append-flags -mieee
diff --git a/app-editors/emacs/metadata.xml b/app-editors/emacs/metadata.xml
index 098739b..f9892c3 100644
--- a/app-editors/emacs/metadata.xml
+++ b/app-editors/emacs/metadata.xml
@@ -23,8 +23,6 @@
<flag name="athena">Enable the MIT Athena widget set
(<pkg>x11-libs/libXaw</pkg>)</flag>
<flag name="games">Support shared score files for games</flag>
- <flag name="gconf">Use <pkg>gnome-base/gconf</pkg> to read the system
- font name</flag>
<flag name="gfile">Use gfile (<pkg>dev-libs/glib</pkg>) for file
notification</flag>
<flag name="gsettings">Use gsettings (<pkg>dev-libs/glib</pkg>) to read the
diff --git a/app-emacs/emacs-common/emacs-common-9999.ebuild b/app-emacs/emacs-common/emacs-common-9999.ebuild
index 61306a4..2349bac 100644
--- a/app-emacs/emacs-common/emacs-common-9999.ebuild
+++ b/app-emacs/emacs-common/emacs-common-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,7 +7,7 @@ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/emacs-tools.git"
EGIT_BRANCH="${PN}"
EGIT_CHECKOUT_DIR="${WORKDIR}/${PN}"
-inherit elisp-common desktop gnome2-utils xdg-utils readme.gentoo-r1 git-r3
+inherit elisp-common desktop eapi9-pipestatus gnome2-utils xdg-utils readme.gentoo-r1 git-r3
DESCRIPTION="Common files needed by all GNU Emacs versions"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
@@ -18,15 +18,14 @@ SLOT="0"
IUSE="games gsettings gui"
DEPEND="games? ( acct-group/gamestat )"
-RDEPEND="!=app-editors/emacs-29.1_rc1-r0
- ${DEPEND}
- gui? ( gsettings? ( dev-libs/glib ) )"
+RDEPEND="${DEPEND}"
PDEPEND=">=app-editors/emacs-23.1:*"
+IDEPEND="gui? ( gsettings? ( dev-libs/glib ) )"
src_install() {
insinto "${SITELISP}"
sed -e "s:@libdir@:$(get_libdir):g" subdirs.el.in | newins - subdirs.el
- assert
+ pipestatus || die
newins site-gentoo.el{,.orig}
keepdir /etc/emacs
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
index ec1c5f5..793656a 100644
--- a/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
+++ b/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
@@ -23,7 +23,7 @@ RDEPEND=">=app-editors/xemacs-21.5.35
BDEPEND="${RDEPEND}"
EMACS="${EPREFIX}/usr/bin/xemacs"
-EMACSFLAGS="-batch -q --no-site-file"
+EMACSFLAGS="-batch -q -no-site-file"
src_compile() {
${EMACS} ${EMACSFLAGS} \
diff --git a/eclass/elisp-common.eclass b/eclass/elisp-common.eclass
index ad9d3c7..117544e 100644
--- a/eclass/elisp-common.eclass
+++ b/eclass/elisp-common.eclass
@@ -25,7 +25,7 @@
# When relying on the emacs USE flag, you need to add
#
# @CODE
-# emacs? ( >=app-editors/emacs-25.3:* )
+# emacs? ( >=app-editors/emacs-25.3:* )
# @CODE
#
# to your DEPEND/RDEPEND line and use the functions provided here to
@@ -39,7 +39,7 @@
# NEED_EMACS with the Emacs version, as in the following example:
#
# @CODE
-# NEED_EMACS=26.1
+# NEED_EMACS=26.1
# @CODE
#
# Please note that this should be done only for packages that are known
@@ -54,7 +54,7 @@
# are loadable.
#
# @CODE
-# elisp-compile *.el
+# elisp-compile *.el
# @CODE
#
# Function elisp-make-autoload-file() can be used to generate a file
@@ -75,7 +75,7 @@
# (see below) the change, as it defaults to ${PN}.
#
# @CODE
-# elisp-install ${PN} *.el *.elc
+# elisp-install ${PN} *.el *.elc
# @CODE
#
# To let the Emacs support be activated by Emacs on startup, you need
@@ -84,9 +84,9 @@
# Normally this would look like this:
#
# @CODE
-# (add-to-list 'load-path "@SITELISP@")
-# (add-to-list 'auto-mode-alist '("\\.csv\\'" . csv-mode))
-# (autoload 'csv-mode "csv-mode" "Major mode for csv files." t)
+# (add-to-list 'load-path "@SITELISP@")
+# (add-to-list 'auto-mode-alist '("\\.csv\\'" . csv-mode))
+# (autoload 'csv-mode "csv-mode" "Major mode for csv files." t)
# @CODE
#
# If your Emacs support files are installed in a subdirectory of
@@ -117,13 +117,13 @@
# your ebuild (e.g., right after S or RDEPEND):
#
# @CODE
-# SITEFILE="50${PN}-gentoo.el"
+# SITEFILE="50${PN}-gentoo.el"
# @CODE
#
# Which is then installed by
#
# @CODE
-# elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+# elisp-site-file-install "${FILESDIR}/${SITEFILE}"
# @CODE
#
# in src_install(). Any characters after the "-gentoo" part and before
@@ -137,7 +137,7 @@
# and install a site-init file that does just that:
#
# @CODE
-# elisp-make-site-file "${SITEFILE}"
+# elisp-make-site-file "${SITEFILE}"
# @CODE
#
# Again, this must be called in src_install(). See the function's
@@ -153,7 +153,7 @@
# version. In this case, you can add an explicit check in pkg_setup:
#
# @CODE
-# elisp-check-emacs-version
+# elisp-check-emacs-version
# @CODE
#
# When having optional Emacs support, you should prepend "use emacs &&"
@@ -165,13 +165,13 @@
# emerging and unmerging by using
#
# @CODE
-# pkg_postinst() {
-# elisp-site-regen
-# }
+# pkg_postinst() {
+# elisp-site-regen
+# }
#
-# pkg_postrm() {
-# elisp-site-regen
-# }
+# pkg_postrm() {
+# elisp-site-regen
+# }
# @CODE
#
# Again, with optional Emacs support, you should prepend "use emacs &&"
@@ -260,7 +260,6 @@ elisp-emacs-version() {
}
# @FUNCTION: elisp-check-emacs-version
-# @USAGE: [version]
# @DESCRIPTION:
# Test if the eselected Emacs version is at least the version of
# GNU Emacs specified in the NEED_EMACS variable, or die otherwise.
@@ -356,8 +355,8 @@ elisp-make-autoload-file() {
#
# Example:
# @CODE
-# elisp-org-export-to texinfo README.org
-# mv README.texi ${PN}.texi || die
+# elisp-org-export-to texinfo README.org
+# mv README.texi ${PN}.texi || die
# @CODE
elisp-org-export-to() {
@@ -512,16 +511,16 @@ elisp-test-ert() {
#
# Example:
# @CODE
-# inherit elisp-common
+# inherit elisp-common
#
-# ...
+# ...
#
-# elisp-enable-tests --optional ert-runner "${S}"/elisp -t "!org"
+# elisp-enable-tests --optional ert-runner "${S}"/elisp -t "!org"
#
-# src_test() {
-# emake -C tests test
-# elisp-test
-# }
+# src_test() {
+# emake -C tests test
+# elisp-test
+# }
# @CODE
elisp-enable-tests() {
@@ -662,7 +661,7 @@ elisp-site-file-install() {
# this will add the package's SITELISP subdirectory to Emacs' load-path:
#
# @CODE
-# (add-to-list 'load-path "@SITELISP@")
+# (add-to-list 'load-path "@SITELISP@")
# @CODE
#
# Additional arguments are appended as lines to the destination file.
diff --git a/eclass/elisp.eclass b/eclass/elisp.eclass
index 1fa8aab..e2f629e 100644
--- a/eclass/elisp.eclass
+++ b/eclass/elisp.eclass
@@ -139,7 +139,7 @@ elisp_src_configure() { :; }
elisp_src_compile() {
elisp-compile *.el
if [[ -n ${ELISP_TEXINFO} ]]; then
- makeinfo ${ELISP_TEXINFO} || die
+ makeinfo --no-split ${ELISP_TEXINFO} || die
fi
}
diff --git a/profiles/eapi b/profiles/eapi
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/profiles/eapi
@@ -0,0 +1 @@
+5