summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild15
-rw-r--r--app-xemacs/test-harness/Manifest1
-rw-r--r--app-xemacs/test-harness/metadata.xml12
-rw-r--r--app-xemacs/test-harness/test-harness-21.4.24.ebuild31
-rw-r--r--profiles/eapi1
5 files changed, 6 insertions, 54 deletions
diff --git a/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild b/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
index 8cd372d..793656a 100644
--- a/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
+++ b/app-xemacs/ebuild-mode/ebuild-mode-9999.ebuild
@@ -17,19 +17,13 @@ S="${WORKDIR}/${PN}"
LICENSE="GPL-2+"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-RDEPEND=">=app-editors/xemacs-21.4.24-r9
+RDEPEND=">=app-editors/xemacs-21.5.35
app-xemacs/sh-script"
-BDEPEND="${RDEPEND}
- test? ( || (
- >=app-editors/xemacs-21.5.35
- app-xemacs/test-harness
- ) )"
+BDEPEND="${RDEPEND}"
EMACS="${EPREFIX}/usr/bin/xemacs"
-EMACSFLAGS="-batch -q --no-site-file"
+EMACSFLAGS="-batch -q -no-site-file"
src_compile() {
${EMACS} ${EMACSFLAGS} \
@@ -50,7 +44,8 @@ src_test() {
src_install() {
insinto /usr/lib/xemacs/site-packages/lisp/${PN}
- doins ebuild-mode.{el,elc} gentoo-newsitem-mode.{el,elc}
+ doins ebuild-mode.{el,elc} ebuild-mode-keywords.el \
+ gentoo-newsitem-mode.{el,elc}
doins auto-autoloads.el
}
diff --git a/app-xemacs/test-harness/Manifest b/app-xemacs/test-harness/Manifest
deleted file mode 100644
index 57808d3..0000000
--- a/app-xemacs/test-harness/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST xemacs-21.4.24.tar.gz 8543879 BLAKE2B d7e60e4e053a10bfc4591a5d691c849ef5e5436f6951c801f5a169592b160669d0f6b9dc8f10b6b79889a3210de977ed78a5cea826c02e425495364745ef9e10 SHA512 b7a88d5a4a9f74f74c2067ed60f7ea87ac8ccad5d9c2c1033ecf07f540250191f8fa5f9e6d23d9fedd0f2ab1eb5ea6c29a7665a310ec512d85e2e4f337447213
diff --git a/app-xemacs/test-harness/metadata.xml b/app-xemacs/test-harness/metadata.xml
deleted file mode 100644
index 84e56b7..0000000
--- a/app-xemacs/test-harness/metadata.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>ulm@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>xemacs@gentoo.org</email>
- <name>Gentoo XEmacs project</name>
- </maintainer>
- <stabilize-allarches/>
-</pkgmetadata>
diff --git a/app-xemacs/test-harness/test-harness-21.4.24.ebuild b/app-xemacs/test-harness/test-harness-21.4.24.ebuild
deleted file mode 100644
index e16e9b4..0000000
--- a/app-xemacs/test-harness/test-harness-21.4.24.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="Test suite harness for testing XEmacs"
-HOMEPAGE="https://www.xemacs.org/"
-SRC_URI="http://ftp.xemacs.org/pub/xemacs/xemacs-$(ver_cut 1-2)/xemacs-${PV}.tar.gz"
-S="${WORKDIR}/xemacs-${PV}/tests/automated"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND=">=app-editors/xemacs-${PV}"
-BDEPEND="${RDEPEND}"
-
-src_compile() {
- local EMACS="${EPREFIX}/usr/bin/xemacs"
-
- "${EMACS}" -batch -q --no-site-file \
- -eval "(add-to-list 'load-path nil)" \
- -f batch-byte-compile test-harness.el || die
-}
-
-src_test() { :; }
-
-src_install() {
- insinto /usr/lib/xemacs/site-packages/lisp/${PN}
- doins test-harness.{el,elc}
-}
diff --git a/profiles/eapi b/profiles/eapi
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/profiles/eapi
@@ -0,0 +1 @@
+5