summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/emacs/emacs-18.59-r11.ebuild11
-rw-r--r--app-editors/emacs/emacs-23.4-r17.ebuild5
-rw-r--r--app-editors/emacs/emacs-24.5-r5.ebuild4
3 files changed, 14 insertions, 6 deletions
diff --git a/app-editors/emacs/emacs-18.59-r11.ebuild b/app-editors/emacs/emacs-18.59-r11.ebuild
index bd7a527..9b26006 100644
--- a/app-editors/emacs/emacs-18.59-r11.ebuild
+++ b/app-editors/emacs/emacs-18.59-r11.ebuild
@@ -28,6 +28,14 @@ DEPEND="${RDEPEND}
PATCHES="../${P}-linux22x-elf-glibc21.diff ../patch"
+src_prepare() {
+ default
+
+ # Do not use the sandbox, or the dumped Emacs will be twice as large
+ sed -i -e 's:\./temacs.*dump:env SANDBOX_ON=0 LD_PRELOAD= &:' \
+ src/ymakefile || die
+}
+
src_configure() {
# autoconf? What's autoconf? We are living in 1992. ;-)
local arch
@@ -70,8 +78,7 @@ src_configure() {
}
src_compile() {
- # Do not use the sandbox, or the dumped Emacs will be twice as large
- export SANDBOX_ON=0
+ addpredict /var/lib/emacs/lock
emake --jobs=1 \
CC="$(tc-getCC)" CFLAGS="${CFLAGS} -Demacs" \
LD="$(tc-getCC) -nostdlib" LDFLAGS="${LDFLAGS}"
diff --git a/app-editors/emacs/emacs-23.4-r17.ebuild b/app-editors/emacs/emacs-23.4-r17.ebuild
index 0a3267b..7879999 100644
--- a/app-editors/emacs/emacs-23.4-r17.ebuild
+++ b/app-editors/emacs/emacs-23.4-r17.ebuild
@@ -224,10 +224,11 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
emake CC="$(tc-getCC)" \
AR="$(tc-getAR) cq" \
- RANLIB="$(tc-getRANLIB)"
+ RANLIB="$(tc-getRANLIB)" \
+ RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {
diff --git a/app-editors/emacs/emacs-24.5-r5.ebuild b/app-editors/emacs/emacs-24.5-r5.ebuild
index 4244c1f..9fa543d 100644
--- a/app-editors/emacs/emacs-24.5-r5.ebuild
+++ b/app-editors/emacs/emacs-24.5-r5.ebuild
@@ -225,8 +225,8 @@ src_configure() {
}
src_compile() {
- export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
- emake
+ # Disable sandbox when dumping. For the unbelievers, see bug #131505
+ emake RUN_TEMACS="env SANDBOX_ON=0 LD_PRELOAD= ./temacs"
}
src_install () {