summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
index 48c2eb6..04fb9b7 100644
--- a/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
+++ b/app-emacs/emacs-common-gentoo/emacs-common-gentoo-9999-r1.ebuild
@@ -37,6 +37,7 @@ src_install() {
if use games; then
keepdir /var/games/emacs
fowners root:games /var/games/emacs
+ fperms g+w /var/games/emacs
fi
if use X; then
@@ -107,6 +108,7 @@ pkg_preinst() {
fi
touch "${ED}${f}" || die
chown root:games "${ED}${f}" || die
+ chmod g+w "${ED}${f}" || die
done
fi