summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/uemacs-pk/ChangeLog8
-rw-r--r--app-editors/uemacs-pk/Manifest5
-rw-r--r--app-editors/uemacs-pk/files/uemacs-pk-4.0.18-gentoo.patch129
-rw-r--r--app-editors/uemacs-pk/metadata.xml5
-rw-r--r--app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild37
5 files changed, 184 insertions, 0 deletions
diff --git a/app-editors/uemacs-pk/ChangeLog b/app-editors/uemacs-pk/ChangeLog
new file mode 100644
index 0000000..d328f79
--- /dev/null
+++ b/app-editors/uemacs-pk/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-editors/uemacs-pk
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+ 11 Jun 2007; Ulrich Mueller <ulm@gentoo.org> +uemacs-pk-4.0.18.ebuild,
+ +files/uemacs-pk-4.0.18-gentoo.patch, +metadata.xml:
+ Initial import.
+
diff --git a/app-editors/uemacs-pk/Manifest b/app-editors/uemacs-pk/Manifest
new file mode 100644
index 0000000..d378054
--- /dev/null
+++ b/app-editors/uemacs-pk/Manifest
@@ -0,0 +1,5 @@
+AUX uemacs-pk-4.0.18-gentoo.patch 3207 RMD160 f9485775ed878daaed98bb2244464d7b27b6d3db SHA1 db0e9d01ec5750b263fb308c698bb69f8c7f81ed SHA256 41396a16f7af27be6d3671462b930ffdac998c0bdc500650b8d8716a3c2324ab
+DIST em-4.0.18.tar.gz 209742 RMD160 cab55709910c06c31d64cd12ce4ffb0142e2a514 SHA1 510dc15568af30c5b5cb7545c7b4ff62fba2032f SHA256 b3c014a30c54e04cfa53c477136541e1edffbb8a28016904a79948b3b718bfc5
+EBUILD uemacs-pk-4.0.18.ebuild 797 RMD160 3281c8a5ce030aae129e0e71ca649948964cf447 SHA1 4a878592fef5eeaea366e6bc336301b424671ae8 SHA256 a8ca151b4441d74207297ac5cda8eeed9afc42913a1fe51f1d1e9d4fff88c1b9
+MISC ChangeLog 269 RMD160 900bbd001329cac02f64b983b5794a802fed27f5 SHA1 651a37ad2679370080cd0b0ee86302246005712c SHA256 a76a9797061837d2c6005cd4a67f505508f54b9d4b2f656b72fc46e6439eaeab
+MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
diff --git a/app-editors/uemacs-pk/files/uemacs-pk-4.0.18-gentoo.patch b/app-editors/uemacs-pk/files/uemacs-pk-4.0.18-gentoo.patch
new file mode 100644
index 0000000..d1c8813
--- /dev/null
+++ b/app-editors/uemacs-pk/files/uemacs-pk-4.0.18-gentoo.patch
@@ -0,0 +1,129 @@
+--- em-4.0.18-orig/buffer.c 1994-05-21 12:40:56.000000000 +0200
++++ em-4.0.18/buffer.c 2007-06-11 16:59:35.000000000 +0200
+@@ -448,7 +448,6 @@
+ register BUFFER *bp;
+ register BUFFER *sb; /* buffer to insert after */
+ register LINE *lp;
+- char *malloc();
+
+ bp = bheadp;
+ while (bp != NULL) {
+--- em-4.0.18-orig/display.c 2005-02-22 12:03:13.000000000 +0100
++++ em-4.0.18/display.c 2007-06-11 16:59:46.000000000 +0200
+@@ -56,7 +56,6 @@
+ {
+ register int i;
+ register VIDEO *vp;
+- char *malloc();
+
+ TTopen(); /* open the screen */
+ TTkopen(); /* open the keyboard */
+--- em-4.0.18-orig/edef.h 1994-05-21 12:40:57.000000000 +0200
++++ em-4.0.18/edef.h 2007-06-11 21:14:54.000000000 +0200
+@@ -8,6 +8,9 @@
+ * modified by Petri Kutvonen
+ */
+
++#include <stdlib.h>
++#include <string.h>
++
+ /* some global fuction declarations */
+
+ char *flook();
+@@ -19,12 +22,13 @@
+ char *gtusr();
+ char *itoa();
+ char *ltos();
+-char *malloc();
++/*char *malloc();*/
+ char *mklower();
+ char *mkupper();
+-char *strcat();
+-char *strcpy();
+-char *strncpy();
++/*char *strcat();*/
++/*char *strcpy();*/
++/*char *strncpy();*/
++char *uestrncpy();
+ char *token();
+ char *transbind();
+ unsigned int getckey();
+--- em-4.0.18-orig/epath.h 1994-05-21 12:41:01.000000000 +0200
++++ em-4.0.18/epath.h 2007-06-11 22:00:08.000000000 +0200
+@@ -32,7 +32,7 @@
+ "/usr/local/lib/",
+ #endif
+ "/usr/local/",
+- "/usr/lib/",
++ "/usr/share/uemacs-pk/",
+ ""
+ };
+ #endif
+--- em-4.0.18-orig/eval.c 2005-02-22 12:03:13.000000000 +0100
++++ em-4.0.18/eval.c 2007-06-11 21:04:58.000000000 +0200
+@@ -554,7 +554,7 @@
+
+ atoi(st)
+
+-char *st;
++const char *st;
+
+ {
+ int result; /* resulting number */
+--- em-4.0.18-orig/line.c 1996-05-02 14:22:12.000000000 +0200
++++ em-4.0.18/line.c 2007-06-11 17:03:53.000000000 +0200
+@@ -33,7 +33,6 @@
+ {
+ register LINE *lp;
+ register int size;
+- char *malloc();
+
+ size = (used+NBLOCK-1) & ~(NBLOCK-1);
+ if (size == 0) /* Assume that an empty */
+--- em-4.0.18-orig/main.c 2005-02-22 12:03:13.000000000 +0100
++++ em-4.0.18/main.c 2007-06-11 21:15:57.000000000 +0200
+@@ -82,6 +82,7 @@
+
+ #if UNIX
+ #include <signal.h>
++static void emergencyexit();
+ #endif
+
+ #if CALLED
+@@ -123,7 +124,6 @@
+ #endif
+
+ #if UNIX
+- static void emergencyexit();
+ #ifdef SIGWINCH
+ extern void sizesignal();
+ #endif
+@@ -443,7 +443,6 @@
+ {
+ register BUFFER *bp;
+ register WINDOW *wp;
+- char *malloc();
+
+ bp = bfind(bname, TRUE, 0); /* First buffer */
+ blistp = bfind("*List*", TRUE, BFINVS); /* Buffer list buffer */
+--- em-4.0.18-orig/search.c 2005-02-22 12:03:13.000000000 +0100
++++ em-4.0.18/search.c 2007-06-11 17:01:48.000000000 +0200
+@@ -1557,8 +1557,6 @@
+ */
+ static BITMAP clearbits()
+ {
+- char *malloc();
+-
+ BITMAP cclstart, cclmap;
+ register int j;
+
+--- em-4.0.18-orig/window.c 1994-05-21 12:41:05.000000000 +0200
++++ em-4.0.18/window.c 2007-06-11 17:02:20.000000000 +0200
+@@ -332,7 +332,6 @@
+ register int ntrd;
+ register WINDOW *wp1;
+ register WINDOW *wp2;
+- char *malloc();
+
+ if (curwp->w_ntrows < 3) {
+ mlwrite("Cannot split a %d line window", curwp->w_ntrows);
diff --git a/app-editors/uemacs-pk/metadata.xml b/app-editors/uemacs-pk/metadata.xml
new file mode 100644
index 0000000..bc306fe
--- /dev/null
+++ b/app-editors/uemacs-pk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild b/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild
new file mode 100644
index 0000000..4735c1d
--- /dev/null
+++ b/app-editors/uemacs-pk/uemacs-pk-4.0.18.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="uEmacs/PK is an enhanced version of MicroEMACS"
+HOMEPAGE="ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK"
+SRC_URI="ftp://ftp.cs.helsinki.fi/pub/Software/Local/uEmacs-PK/em-${PV}.tar.gz"
+
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/em-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ newbin emacs uemacs
+ insinto /usr/share/${PN}
+ doins emacs.hlp
+ newins emacs.rc .emacsrc
+ dodoc readme readme.39e emacs.ps
+}