summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/emacs-updater')
-rw-r--r--app-admin/emacs-updater/ChangeLog5
-rw-r--r--app-admin/emacs-updater/Manifest24
-rw-r--r--app-admin/emacs-updater/emacs-updater-9999.ebuild26
3 files changed, 45 insertions, 10 deletions
diff --git a/app-admin/emacs-updater/ChangeLog b/app-admin/emacs-updater/ChangeLog
index 3014018..2196837 100644
--- a/app-admin/emacs-updater/ChangeLog
+++ b/app-admin/emacs-updater/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for app-admin/emacs-updater
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Jun 2012; Ulrich Müller <ulm@gentoo.org> emacs-updater-9999.ebuild:
+ Change live ebuild to use Git. Merge changes from Portage tree.
+
12 Apr 2009; Ulrich Mueller <ulm@gentoo.org> emacs-updater-9999.ebuild:
Install man page. Update dependencies.
diff --git a/app-admin/emacs-updater/Manifest b/app-admin/emacs-updater/Manifest
index cad5002..43536a8 100644
--- a/app-admin/emacs-updater/Manifest
+++ b/app-admin/emacs-updater/Manifest
@@ -1,3 +1,23 @@
-EBUILD emacs-updater-9999.ebuild 690 RMD160 1715ae511e0b81dfdd8f1dad77f97facc2b0f3a8 SHA1 34f6c4b834a02d0aa8236984df26ef2fdc64ed47 SHA256 8119d5ba0a87d458a668da5a3d40a484f28088b9faeb9f75a5cfb9099e4dd425
-MISC ChangeLog 954 RMD160 60755bc9af3a93a0db3e1d4038bfd0e545178958 SHA1 6e2775e93448cf7d50d131e1f79bea7135fbad2c SHA256 67050e649d44b8f00cb7fd7795e35a3fd744f66cce8bd8af91e2a433db3c0351
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+EBUILD emacs-updater-9999.ebuild 911 RMD160 75cac2c6bb93d3bc65ffd37f31c7c5c7281a0f19 SHA1 1a93211fd4f2fcbbb7b6809c2ff57710e19aa7c2 SHA256 7bdb7e43a87e05d8e5e3df673cb31a26a712b87aeb6c438e06ea64a78172c147
+MISC ChangeLog 1095 RMD160 6679051ab5dfe3f771670b8da278a1928aab31d2 SHA1 33c8ee684dad1a27b68dff82f2830db1a25e93eb SHA256 73f379adc690b808a50b4e2ca260dbeb7630df264a9cfe8329b92531d02e785e
MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iQIcBAEBAgAGBQJP01I2AAoJEDxpGckxwJCBexEP/3LL0hM5b8kq17BnevDg/a1M
+dzP8IvjYQoAJHg+m5W8YsiggV+xBp3GcnrwN2AUVCCSDIMovX2RbRp4paDLXFVjr
+yOPuLHcRpSBj7/zpOGmiRKm3dAWfeiWnw6eDW/m2cPIpALTpssP/AM86HMekcsFr
+uW+xX4e4w/nWlRiYUMwwFFRJTY5AGf8oNE3rRprJ+0RtdjQqbVgzLj7klIdrzwe4
+N3aV09PcAOwetrWy4SDLzGuK6oQ3Ic2QCvooPK7NQxnZyDmMP2EOjq8mnzdlIIyo
+KCs7kFPUQfHE8bejLfXccfgsDQoVM/0ttap7CSDLUcfbDh+czbY6jlvekQ8pazwZ
+3x49FVyYXl7/307BHsbG4c9vekHfA4v8OGiWi4WDsd7BdIehFsvNXtpxLv7oeco5
+Gbh3ySLvyNRnegmaxihlWVRmni8o00sffaQdk9KArh6p4c5kR3TO8ACD7icZD8Fb
+OkCtQV0dKIOypR6xEGzb76pPBDDi88R56BKSp6eUYNm4npP+5rIJoi0/WXdhLkN9
+oqZc1nrPuhi3SKEDhKOZjK+jWuNLeJwfuzkVgWqMBAEmVEWMv0AzWWtiNGmDjRHK
+ZfpwL2CkSdH3BonBr+qnVSNiUHQ5W2uRWHofxfAKzjtGWmKeF3fu6+7YresdgOZB
+9gVcBiotERNTxWffdoOU
+=XCzt
+-----END PGP SIGNATURE-----
diff --git a/app-admin/emacs-updater/emacs-updater-9999.ebuild b/app-admin/emacs-updater/emacs-updater-9999.ebuild
index d7f8579..afb64dd 100644
--- a/app-admin/emacs-updater/emacs-updater-9999.ebuild
+++ b/app-admin/emacs-updater/emacs-updater-9999.ebuild
@@ -1,27 +1,39 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-inherit subversion
+EAPI=4
+
+EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/emacs-tools.git"
+EGIT_BRANCH="${PN}"
+
+inherit git-2
DESCRIPTION="Rebuild Emacs packages"
HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
#SRC_URI="mirror://gentoo/${P}.tar.bz2"
-ESVN_REPO_URI="svn://anonsvn.gentoo.org/emacs/${PN}"
+SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND=""
RDEPEND="!<=app-admin/eselect-emacs-1.5
>=app-portage/portage-utils-0.1.28
virtual/emacs"
S="${WORKDIR}/${PN}"
+src_prepare() {
+ if [ -n "${EPREFIX}" ]; then
+ sed -i -e "1s:/:${EPREFIX%/}/:" \
+ -e "s:^\(EMACS\|SITELISP\)=:&${EPREFIX%/}:" \
+ emacs-updater || die
+ fi
+}
+
src_install() {
- dosbin emacs-updater || die "dosbin failed"
- doman emacs-updater.8 || die "doman failed"
+ dosbin emacs-updater
+ doman emacs-updater.8
}