summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/elisp-manual/ChangeLog11
-rw-r--r--app-doc/elisp-manual/Manifest5
-rw-r--r--app-doc/elisp-manual/elisp-manual-22.3.ebuild31
-rw-r--r--app-doc/elisp-manual/files/elisp-manual-22.3-direntry.patch19
-rw-r--r--app-doc/elisp-manual/metadata.xml25
5 files changed, 91 insertions, 0 deletions
diff --git a/app-doc/elisp-manual/ChangeLog b/app-doc/elisp-manual/ChangeLog
new file mode 100644
index 0000000..5d835d0
--- /dev/null
+++ b/app-doc/elisp-manual/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-doc/elisp-manual
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*elisp-manual-22.3 (17 Feb 2009)
+
+ 17 Feb 2009; Ulrich Mueller <ulm@gentoo.org>
+ +files/elisp-manual-22.3-direntry.patch, +metadata.xml,
+ +elisp-manual-22.3.ebuild:
+ Stand-alone Elisp manual for Emacs 22.
+
diff --git a/app-doc/elisp-manual/Manifest b/app-doc/elisp-manual/Manifest
new file mode 100644
index 0000000..170ea73
--- /dev/null
+++ b/app-doc/elisp-manual/Manifest
@@ -0,0 +1,5 @@
+AUX elisp-manual-22.3-direntry.patch 526 RMD160 12d95b6e9a658e7404de0b4feb85a547737cd586 SHA1 a8a8712d5380006405de3eea390a24f45524cddf SHA256 fec479ad2fd602d67b13f3498e4270e6104f9c05e2c0991ac686189d813e8148
+DIST emacs-22.3.tar.gz 39587396 RMD160 a7eed5099d0cab25f34152f1b18b5c1b4e2e0746 SHA1 5e9b3e0205099a83be7198fd43ba1c9442a3feb0 SHA256 7bd9b719db8ee20c75ee0d256737f7fd2c0e2ea30a285a3afbfc32c856420d16
+EBUILD elisp-manual-22.3.ebuild 639 RMD160 ca32daf0c495b9f1e0a45a973ecf91b25423e97a SHA1 27c9e89678982bf7fb820fff2eb7e02a0758ee9e SHA256 104720119d187fc99d231589dfa37deff2ae72f39ad6a68ea885c7d1b01de1ee
+MISC ChangeLog 331 RMD160 ddfd254eb1e57896e925dc1719a32ee7682fe4fe SHA1 9a78e06513f079bb63d002e02fea16cc7cb31fb4 SHA256 1fc70b61dd6ef2aefe375afb8576573d52c7fb2e6b8ab79eafe8a728d9a2da75
+MISC metadata.xml 1348 RMD160 5ecbda1b0b2424fb2d8dbc6dcb291d2b5277323c SHA1 073d9ee41bf2414a89c3952605cbd03113258d98 SHA256 d3a76777e927836d3ab86e6f07a97eea4eb5eb178c761bfaa2375c1076f34ddf
diff --git a/app-doc/elisp-manual/elisp-manual-22.3.ebuild b/app-doc/elisp-manual/elisp-manual-22.3.ebuild
new file mode 100644
index 0000000..49f7e17
--- /dev/null
+++ b/app-doc/elisp-manual/elisp-manual-22.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="The GNU Emacs Lisp Reference Manual"
+HOMEPAGE="http://www.gnu.org/software/emacs/manual/"
+SRC_URI="mirror://gnu/emacs/emacs-${PV}.tar.gz"
+
+LICENSE="FDL-1.2"
+SLOT="22"
+KEYWORDS="~amd64 ~ppc ~s390 ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/emacs-${PV}/lispref"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-direntry.patch"
+}
+
+src_compile() {
+ makeinfo elisp.texi || die "makeinfo failed"
+}
+
+src_install() {
+ doinfo elisp22.info* || die "doinfo failed"
+ dodoc ChangeLog README
+}
diff --git a/app-doc/elisp-manual/files/elisp-manual-22.3-direntry.patch b/app-doc/elisp-manual/files/elisp-manual-22.3-direntry.patch
new file mode 100644
index 0000000..21fc343
--- /dev/null
+++ b/app-doc/elisp-manual/files/elisp-manual-22.3-direntry.patch
@@ -0,0 +1,19 @@
+--- emacs-22.3-orig/lispref/elisp.texi
++++ emacs-22.3/lispref/elisp.texi
+@@ -1,6 +1,6 @@
+ \input texinfo @c -*-texinfo-*-
+ @c %**start of header
+-@setfilename elisp
++@setfilename elisp22.info
+ @settitle GNU Emacs Lisp Reference Manual
+ @c %**end of header
+
+@@ -11,7 +11,7 @@
+
+ @dircategory Emacs
+ @direntry
+-* Elisp: (elisp). The Emacs Lisp Reference Manual.
++* Elisp 22: (elisp22). The Emacs Lisp Reference Manual for Emacs 22.
+ @end direntry
+
+ @c in general, keep the following line commented out, unless doing a
diff --git a/app-doc/elisp-manual/metadata.xml b/app-doc/elisp-manual/metadata.xml
new file mode 100644
index 0000000..b47e13b
--- /dev/null
+++ b/app-doc/elisp-manual/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+ Most of the GNU Emacs text editor is written in the programming language
+ called Emacs Lisp. You can write new code in Emacs Lisp and install it as an
+ extension to the editor. However, Emacs Lisp is more than a mere "extension
+ language"; it is a full computer programming language in its own right. You
+ can use it as you would any other programming language.
+
+ Because Emacs Lisp is designed for use in an editor, it has special features
+ for scanning and parsing text as well as features for handling files,
+ buffers, displays, subprocesses, and so on. Emacs Lisp is closely integrated
+ with the editing facilities; thus, editing commands are functions that can
+ also conveniently be called from Lisp programs, and parameters for
+ customization are ordinary Lisp variables.
+
+ This manual attempts to be a full description of Emacs Lisp. For a
+ beginner's introduction to Emacs Lisp, see An Introduction to Emacs Lisp
+ Programming, by Bob Chassell, also published by the Free Software
+ Foundation. This manual presumes considerable familiarity with the use of
+ Emacs for editing; see The GNU Emacs Manual for this basic information.
+</longdescription>
+</pkgmetadata>