summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-23.4-r21.ebuild')
-rw-r--r--app-editors/emacs/emacs-23.4-r21.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/app-editors/emacs/emacs-23.4-r21.ebuild b/app-editors/emacs/emacs-23.4-r21.ebuild
index 697eed5..dd70dda 100644
--- a/app-editors/emacs/emacs-23.4-r21.ebuild
+++ b/app-editors/emacs/emacs-23.4-r21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,8 +13,8 @@ SRC_URI="mirror://gnu/emacs/${P}.tar.bz2
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="23"
-KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="alsa aqua athena dbus games gconf gif gpm gtk gui gzip-el jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars Xaw3d xft +xpm"
+KEYWORDS="~alpha amd64 arm ~hppa ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="alsa aqua athena dbus games gif gpm gtk gui gzip-el jpeg kerberos livecd m17n-lib motif png sound source svg tiff toolkit-scroll-bars Xaw3d xft +xpm"
RDEPEND="acct-group/mail
app-emacs/emacs-common[games?,gui(-)?]
@@ -30,7 +30,6 @@ RDEPEND="acct-group/mail
x11-libs/libSM
x11-libs/libX11
x11-misc/xbitmaps
- gconf? ( >=gnome-base/gconf-2.26.2 )
gif? ( media-libs/giflib:0= )
jpeg? ( media-libs/libjpeg-turbo:0= )
png? ( >=media-libs/libpng-1.4:0= )
@@ -119,14 +118,9 @@ src_prepare() {
src_configure() {
strip-flags
filter-flags -fstrict-aliasing -pie
- append-flags $(test-flags -fno-strict-aliasing)
+ append-flags -std=gnu17 -fno-strict-aliasing -Wno-implicit
append-ldflags $(test-flags -no-pie) #639568
-
- if use ia64; then
- replace-flags "-O[2-9]" -O1 #325373
- else
- replace-flags "-O[3-9]" -O2
- fi
+ replace-flags "-O[3-9]" -O2
# Don't trigger a floating point exception for NaNs on alpha
use alpha && append-flags -mieee
@@ -150,7 +144,7 @@ src_configure() {
myconf+=" --without-x"
else
myconf+=" --with-x --without-ns"
- myconf+=" $(use_with gconf)"
+ myconf+=" --without-gconf"
myconf+=" $(use_with toolkit-scroll-bars)"
myconf+=" $(use_with gif)"
myconf+=" $(use_with jpeg)"