summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-vcs/ChangeLog4
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild38
-rw-r--r--app-editors/emacs-vcs/metadata.xml2
3 files changed, 32 insertions, 12 deletions
diff --git a/app-editors/emacs-vcs/ChangeLog b/app-editors/emacs-vcs/ChangeLog
index f99932b..94ead1d 100644
--- a/app-editors/emacs-vcs/ChangeLog
+++ b/app-editors/emacs-vcs/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 08 Jun 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild,
+ metadata.xml:
+ Merge changes from Portage tree.
+
31 Mar 2013; Ulrich Müller <ulm@gentoo.org> emacs-vcs-24.3.9999.ebuild:
Merge changes from Portage tree.
diff --git a/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
index d82e038..df437ba 100644
--- a/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild,v 1.10 2013/03/31 11:51:18 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-vcs/emacs-vcs-24.3.9999.ebuild,v 1.13 2013/06/08 21:00:29 ulm Exp $
EAPI=5
@@ -31,20 +31,21 @@ HOMEPAGE="http://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
SLOT="24"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="acl alsa aqua athena dbus games gconf gif gnutls gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm"
+IUSE="acl alsa aqua athena dbus games gconf gfile gif gnutls gpm gsettings gtk +gtk3 gzip-el hesiod imagemagick +inotify jpeg kerberos libxml2 livecd m17n-lib motif pax_kernel png selinux sound source svg tiff toolkit-scroll-bars wide-int X Xaw3d xft +xpm"
REQUIRED_USE="?? ( aqua X )"
RDEPEND="sys-libs/ncurses
>=app-admin/eselect-emacs-1.2
>=app-emacs/emacs-common-gentoo-1.3-r3[games?,X?]
net-libs/liblockfile
- hesiod? ( net-dns/hesiod )
- kerberos? ( virtual/krb5 )
+ acl? ( virtual/acl )
alsa? ( media-libs/alsa-lib )
- gpm? ( sys-libs/gpm )
dbus? ( sys-apps/dbus )
gnutls? ( net-libs/gnutls )
- acl? ( virtual/acl )
+ gpm? ( sys-libs/gpm )
+ hesiod? ( net-dns/hesiod )
+ !inotify? ( gfile? ( >=dev-libs/glib-2.28.6 ) )
+ kerberos? ( virtual/krb5 )
libxml2? ( >=dev-libs/libxml2-2.2.0 )
selinux? ( sys-libs/libselinux )
X? (
@@ -55,7 +56,7 @@ RDEPEND="sys-libs/ncurses
gsettings? ( >=dev-libs/glib-2.28.6 )
gif? ( media-libs/giflib )
jpeg? ( virtual/jpeg )
- png? ( >=media-libs/libpng-1.4:0 )
+ png? ( >=media-libs/libpng-1.4:0= )
svg? ( >=gnome-base/librsvg-2.0 )
tiff? ( media-libs/tiff )
xpm? ( x11-libs/libXpm )
@@ -86,11 +87,17 @@ DEPEND="${RDEPEND}
alsa? ( virtual/pkgconfig )
dbus? ( virtual/pkgconfig )
gnutls? ( virtual/pkgconfig )
+ !inotify? ( gfile? ( virtual/pkgconfig ) )
libxml2? ( virtual/pkgconfig )
X? ( virtual/pkgconfig )
gzip-el? ( app-arch/gzip )
pax_kernel? ( sys-apps/paxctl )"
+if [[ ${PV##*.} = 9999 ]]; then
+ DEPEND="${DEPEND}
+ sys-apps/texinfo"
+fi
+
EMACS_SUFFIX="${PN/emacs/emacs-${SLOT}}"
SITEFILE="20${PN}-${SLOT}-gentoo.el"
@@ -146,6 +153,14 @@ src_configure() {
myconf+=" $(use_with sound)"
fi
+ if use inotify; then
+ myconf+=" --with-file-notification=inotify"
+ use gfile && ewarn \
+ "USE flag \"gfile\" has no effect if \"inotify\" is set."
+ else
+ myconf+=" --with-file-notification=$(usex gfile gfile)"
+ fi
+
if use X; then
myconf+=" --with-x --without-ns"
myconf+=" $(use_with gconf)"
@@ -214,13 +229,12 @@ src_configure() {
--enable-locallisppath="${EPREFIX}/etc/emacs:${EPREFIX}${SITELISP}" \
--with-gameuser="${GAMES_USER_DED:-games}" \
--without-compress-info \
- $(use_with hesiod) \
- $(use_with kerberos) $(use_with kerberos kerberos5) \
- $(use_with gpm) \
+ $(use_enable acl) \
$(use_with dbus) \
$(use_with gnutls) \
- $(use_with inotify) \
- $(use_with acl) \
+ $(use_with gpm) \
+ $(use_with hesiod) \
+ $(use_with kerberos) $(use_with kerberos kerberos5) \
$(use_with libxml2 xml2) \
$(use_with selinux) \
$(use_with wide-int) \
diff --git a/app-editors/emacs-vcs/metadata.xml b/app-editors/emacs-vcs/metadata.xml
index b68a939..358a70c 100644
--- a/app-editors/emacs-vcs/metadata.xml
+++ b/app-editors/emacs-vcs/metadata.xml
@@ -22,6 +22,8 @@
<flag name='games'>Support shared score files for games</flag>
<flag name='gconf'>Use <pkg>gnome-base/gconf</pkg> to read the system
font name</flag>
+ <flag name='gfile'>Use gfile (<pkg>dev-libs/glib</pkg>) for file
+ notification</flag>
<flag name='gsettings'>Use gsettings (<pkg>dev-libs/glib</pkg>) to read the
system font name</flag>
<flag name='gtk3'>Link against version 3 of the GIMP Toolkit instead of