summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/femto/Manifest1
-rw-r--r--app-editors/femto/femto-2.10_pre20191107.ebuild34
-rw-r--r--app-editors/femto/metadata.xml11
3 files changed, 46 insertions, 0 deletions
diff --git a/app-editors/femto/Manifest b/app-editors/femto/Manifest
new file mode 100644
index 0000000..32c74a9
--- /dev/null
+++ b/app-editors/femto/Manifest
@@ -0,0 +1 @@
+DIST femto-2.10_pre20191107.tar.gz 578713 BLAKE2B 18951dc30c23ca3ae89e07af60a284f2d47d560b4ccd9076b86df834916f2148885b00d82da54a16f07444fd4121c428c9161a7cd445afbb9669f6cc93e0fb8b SHA512 6364ed29d8b98904dab42a0ebb7e12442ae095fafbb6ba2265f4909fd91d5f0e47950e04a2e2775020e45aab69c88cb5927b62883417e36bac0f94dea6441411
diff --git a/app-editors/femto/femto-2.10_pre20191107.ebuild b/app-editors/femto/femto-2.10_pre20191107.ebuild
new file mode 100644
index 0000000..b2086fa
--- /dev/null
+++ b/app-editors/femto/femto-2.10_pre20191107.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+COMMIT="282ca3c04dba54f180021388102c2e319300cd07"
+DESCRIPTION="Extended version of Atto Emacs with a Tiny Lisp extension language"
+HOMEPAGE="https://github.com/hughbarney/femto"
+SRC_URI="https://github.com/hughbarney/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ LD="$(tc-getCC)" \
+ LDFLAGS="${LDFLAGS} -o" \
+ LIBS="$("$(tc-getPKG_CONFIG)" --libs ncursesw)"
+}
+
+src_install() {
+ dobin femto
+ dodoc README*.md CHANGE.LOG.md docs/*.txt docs/hltest.c
+ dodoc -r examples
+}
diff --git a/app-editors/femto/metadata.xml b/app-editors/femto/metadata.xml
new file mode 100644
index 0000000..45aec74
--- /dev/null
+++ b/app-editors/femto/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<upstream>
+ <remote-id type="github">hughbarney/femto</remote-id>
+</upstream>
+</pkgmetadata>