summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/metadata.xml38
-rw-r--r--app-editors/qemacs/qemacs-9999.ebuild55
2 files changed, 0 insertions, 93 deletions
diff --git a/app-editors/qemacs/metadata.xml b/app-editors/qemacs/metadata.xml
deleted file mode 100644
index a725e27..0000000
--- a/app-editors/qemacs/metadata.xml
+++ /dev/null
@@ -1,38 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>emacs@gentoo.org</email>
- <name>Gentoo Emacs project</name>
-</maintainer>
-<longdescription>
- QEmacs (for Quick Emacs) is a very small but powerful text editor. It has
- the following features:
- * Full screen editor with an Emacs look and feel with all Emacs common
- features: multi-buffer, multi-window, command mode, universal argument,
- keyboard macros, config file with C like syntax, minibuffer with
- completion and history.
- * Can edit files of hundreds of megabytes quickly by using a highly
- optimized internal representation and by mmaping the file.
- * Full UTF8 support, including bidirectional editing respecting the Unicode
- bidi algorithm. Arabic and Indic scripts handling (in progress).
- * WYSIWYG HTML/XML/CSS2 mode graphical editing. Also supports lynx like
- rendering on VT100 terminals. WYSIWYG DocBook mode based on XML/CSS2
- renderer.
- * C mode: coloring with immediate update. Emacs like auto-indent.
- * Shell mode: colorized VT100 emulation so that your shell work exactly as
- you expect. You can run interactive terminal apps directly in the process
- buffer: mc, MenuConfig, or even qemacs itself! Compile mode with
- next/prev error.
- * Input methods for most languages, including Chinese (input methods come
- from the Yudit editor).
- * Hexadecimal editing mode with insertion and block commands. Unicode hexa
- editing of UTF8 files also supported.
- * Works on any VT100 terminals without termcap. UTF8 VT100 support included
- with double width glyphs.
- * X11 support. Support multiple proportionnal fonts at the same time (as
- XEmacs).
- * Small! Full version is about 150KB. Smaller custom versions can be built
- by removing modules.
-</longdescription>
-</pkgmetadata>
diff --git a/app-editors/qemacs/qemacs-9999.ebuild b/app-editors/qemacs/qemacs-9999.ebuild
deleted file mode 100644
index 709e550..0000000
--- a/app-editors/qemacs/qemacs-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs cvs
-
-DESCRIPTION="QEmacs is a very small but powerful UNIX editor"
-HOMEPAGE="https://savannah.nongnu.org/projects/qemacs/"
-
-ECVS_SERVER="cvs.savannah.nongnu.org:/sources/qemacs"
-ECVS_MODULE="qemacs"
-
-LICENSE="LGPL-2.1+ GPL-2+"
-SLOT="0"
-IUSE="X png unicode xv"
-RESTRICT="test"
-
-RDEPEND="
- X? ( x11-libs/libX11
- x11-libs/libXext
- xv? ( x11-libs/libXv ) )
- png? ( >=media-libs/libpng-1.2:0= )"
-
-DEPEND="${RDEPEND}
- >=app-text/texi2html-5"
-
-S="${WORKDIR}/${PN}"
-
-# upstream build system strips the binary
-QA_PRESTRIPPED="/usr/bin/qemacs"
-
-src_configure() {
- # Home-grown configure script, doesn't support most standard options
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --cc="$(tc-getCC)" \
- $(use_enable X x11) \
- $(use_enable png) \
- $(use_enable xv) || die
-}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc Changelog README TODO.org config.eg
- docinto html
- dodoc qe-doc.html
-
- # Install headers so users can build their own plugins
- insinto /usr/include/qe
- doins *.h
- insinto /usr/include/qe/libqhtml
- doins libqhtml/*.h
-}