summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-emacs/ebuild-mode: Autoload devbook-mode in site-init file.Ulrich Müller2020-02-081-0/+3
| | | | | Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* elisp-common.eclass: Add missing argument to eend.Ulrich Müller2019-12-221-1/+1
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* elisp-common.eclass: Report Emacs version with einfo, not elog.Ulrich Müller2019-12-211-1/+1
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/emacs: Drop old blocker against emacs-vcs.Ulrich Müller2019-12-211-3/+0
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/emacs: Drop invalid keywords.Ulrich Müller2019-12-211-2/+2
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/emacs-daemon: Sync from gentoo repo.Ulrich Müller2019-12-211-4/+1
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/emacs-common-gentoo: Sync from gentoo repo.Ulrich Müller2019-12-211-7/+5
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-admin/emacs-updater: Sync from gentoo repo.Ulrich Müller2019-12-211-4/+4
| | | | | Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* elisp*.eclass: Sync from gentoo repo.Ulrich Müller2019-12-212-32/+88
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* elisp.eclass: Sync from gentoo repo.Ulrich Müller2019-09-091-14/+11
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* profiles/categories: Drop app-xemacs.Ulrich Müller2019-08-261-1/+0
| | | | Signed-off-by: Ulrich Müller <ulm@kph.uni-mainz.de>
* Remove app-xemacsMats Lidell2019-08-18415-4212/+0
| | | | | | | | | Upstream does not produce experimental packages at the moment and is not likely to start soon again with that practice. So keeping these packages here does not provide any value. If the need ever will arise it can be created again. Signed-off-by: Mats Lidell <matsl@gentoo.org>
* app-emacs/diff-mode-: Remove old.Ulrich Müller2019-08-182-27/+0
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/diff-mode-: Bump to version 20180427.Ulrich Müller2019-08-182-0/+20
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/codepad: Bump EAPI to 7.Ulrich Müller2019-08-181-5/+3
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/*: Update Manifest hashes.Ulrich Müller2019-08-176-66/+6
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/completion-ui: Remove package.Ulrich Müller2019-08-174-63/+0
| | | | | | | Does not compile with recent Emacs versions. Neither does newest available upstream version 0.12 (from 2013). Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-doc/elisp-tutorial: Update SRC_URI, bump EAPI to 7.Ulrich Müller2019-08-172-6/+13
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* elisp.eclass: Sync from gentoo repo.Ulrich Müller2019-08-171-22/+13
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/pemacs: Add slot operator for ncurses dependency.Ulrich Müller2019-08-173-7/+7
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/whizzytex: Drop advi USE flag, app-text/active-dvi is gone.Ulrich Müller2019-08-173-36/+13
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/wtf: Bump EAPI to 7, update LICENSE.Ulrich Müller2019-08-172-26/+7
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/weblogger: Remove package.Ulrich Müller2019-08-174-45/+0
| | | | | | Fails to compile with recent Emacs versions. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/w3m-type-ahead: Bump EAPI to 7.Ulrich Müller2019-08-172-29/+10
| | | | | | | Update HOMEPAGE, SRC_URI, LICENSE. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/vm-bogofilter: Remove package.Ulrich Müller2019-08-174-60/+0
| | | | | | | | HOMEPAGE and SRC_URI are dead. vm-bogofilter.el is distributed in the contrib directory of vm itself (as of version 8.2.0b), and should be installed by the app-emacs/vm ebuild. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/twitter: Remove package.Ulrich Müller2019-08-174-49/+0
| | | | | | | | No longer working. Replacement is called "twitel" and (supposedly) available from http://www.busydoingnothing.co.uk/twitel/ but the git repository linked from there appears to be dead. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/snippet: Remove package.Ulrich Müller2019-08-174-51/+0
| | | | | | | | | | | | | | HOMEPAGE and SRC_URI are gone. Use app-emacs/yasnippet as replacement. Quoting https://github.com/pkazmier/snippet.el: "This code is no longer maintained. Fortunately, the Internet has no shortage of others willing to improve upon unmaintained code. This codebase was used as the foundation for another project created by pluskid called smart-snippet. It has since been entirely rewritten by others and is now called YASnippet. If you are looking for a supported snippet mode, I'd recommend checking there first." Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/smex: Remove old.Ulrich Müller2019-08-172-16/+0
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/smex: Bump to version 1.1.4.Ulrich Müller2019-08-172-21/+20
| | | | | | | | Neither of the newer releases (up to 3.0) compiles with recent Emacs versions. Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/js2-mode: Remove old.Ulrich Müller2019-08-173-58/+0
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/js2-mode: Bump to version 20190219.Ulrich Müller2019-08-172-22/+23
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/fold-dwim: Bump EAPI to 7, update LICENSE.Ulrich Müller2019-08-172-27/+8
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/find-recursive: Bump EAPI to 7, update LICENSE.Ulrich Müller2019-08-172-26/+7
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/emacs-common-gentoo: Sync from gentoo repo.Ulrich Müller2019-08-171-7/+5
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/elip: Remove package.Ulrich Müller2019-08-174-46/+0
| | | | | | | HOMEPAGE and SRC_URI are gone. Apparently, I have also lost my copy of the elip-0.804.tar.gz distfile. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/ebuild-mode: Sync from gentoo repo.Ulrich Müller2019-08-171-4/+6
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/cgi+: Remove package.Ulrich Müller2019-08-174-50/+0
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/cgi: Remove package.Ulrich Müller2019-08-174-45/+0
| | | | Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/babel: Remove old.Ulrich Müller2019-08-172-16/+0
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/babel: Bump EAPI to 7.Ulrich Müller2019-08-172-24/+6
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-emacs/auto-lang: Bump EAPI to 7, update LICENSE.Ulrich Müller2019-08-172-25/+6
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/qemacs: Remove live ebuild.Ulrich Müller2019-08-172-93/+0
| | | | | | | This doesn't compile without the patches applied in the gentoo repo, and patching the live version is pointless. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/uemacs-pk: Sync from gentoo repo.Ulrich Müller2019-08-171-9/+6
| | | | | Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* app-editors/emacs: Fix support for >=media-gfx/imagemagick-7.Ulrich Müller2018-09-022-1/+104
| | | | Package-Manager: Portage-2.3.48, Repoman-2.3.10
* app-editors/emacs: Sync from gentoo repo.Ulrich Müller2018-08-242-5/+7
| | | | Package-Manager: Portage-2.3.47, Repoman-2.3.10
* app-editors/emacs: Restore emacs-24.3 for compatibility testing.Ulrich Müller2018-07-286-0/+1245
| | | | | | | | | | | | | | | | | This version is for investigation of some problems with app-emacs/vm and PGP encryption/decryption, where 24.3 is the last known good version. I publish this ebuild only because it was surprisingly hard to make this version build again, given the fact that there are working ebuilds for both 23.4 and 24.5. Since it is meant as a temporary solution, there is no consolidated patchset. Only the patches necessary to make it build are applied. Also some less important features (like shared game score files) have been dropped. Package-Manager: Portage-2.3.43, Repoman-2.3.10
* app-editors/xemacs: Remove since outdated as compared to gentoo repoMats Lidell2018-06-149-441/+0
|
* elisp.eclass: Depend on virtual/emacs on the build system.Ulrich Müller2018-06-011-12/+12
| | | | | | | For byte-compilation, Emacs is required to run on the native build system. Therefore BDEPEND on virtual/emacs in EAPI 7. Reorganise EAPI conditionals to be more compact.
* elisp.eclass: Sync from gentoo repo.Ulrich Müller2018-06-011-4/+4
|
* app-emacs/emacs-common-gentoo: Sync from gentoo repo.Ulrich Müller2018-04-021-1/+1
| | | | Package-Manager: Portage-2.3.27, Repoman-2.3.9