aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-07-07 14:08:58 -0700
committerQuentin Retornaz <gentoo@retornaz.com>2022-07-11 00:50:13 +0200
commit267757bad990adc2c1923ccc5c344db89c3dda5d (patch)
tree359c22b484a384b037c7ff3be8caa0e7d09d2c69
parentwww-servers/h2o: Add 2.2.6-r1 (diff)
downloadlibressl-267757bad990adc2c1923ccc5c344db89c3dda5d.tar.gz
libressl-267757bad990adc2c1923ccc5c344db89c3dda5d.tar.bz2
libressl-267757bad990adc2c1923ccc5c344db89c3dda5d.zip
www-servers/h2o: Remove old version
Signed-off-by: orbea <orbea@riseup.net> Closes: https://github.com/gentoo/libressl/pull/441 Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
-rw-r--r--www-servers/h2o/files/h2o-2.2-libressl-2.7.patch23
-rw-r--r--www-servers/h2o/h2o-2.2.6.ebuild107
2 files changed, 0 insertions, 130 deletions
diff --git a/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch b/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch
deleted file mode 100644
index 02942b4..0000000
--- a/www-servers/h2o/files/h2o-2.2-libressl-2.7.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From db50d885a87985310e65159a705b45de8646dc26 Mon Sep 17 00:00:00 2001
-From: AIZAWA Hina <hina@bouhime.com>
-Date: Fri, 23 Mar 2018 22:50:51 +0900
-Subject: [PATCH] Add supporting LibreSSL 2.7
-
-Signed-off-by: AIZAWA Hina <hina@bouhime.com>
----
- deps/neverbleed/neverbleed.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/deps/neverbleed/neverbleed.c b/deps/neverbleed/neverbleed.c
-index 29b35a9..42356a6 100644
---- a/deps/neverbleed/neverbleed.c
-+++ b/deps/neverbleed/neverbleed.c
-@@ -547,7 +547,7 @@ static int sign_stub(struct expbuf_t *buf)
- return 0;
- }
-
--#if !OPENSSL_1_1_API
-+#if !OPENSSL_1_1_API && (!defined(LIBRESSL_VERSION_NUMBER) || LIBRESSL_VERSION_NUMBER < 0x2070000fL)
-
- static void RSA_get0_key(const RSA *rsa, const BIGNUM **n, const BIGNUM **e, const BIGNUM **d)
- {
diff --git a/www-servers/h2o/h2o-2.2.6.ebuild b/www-servers/h2o/h2o-2.2.6.ebuild
deleted file mode 100644
index ca1edb2..0000000
--- a/www-servers/h2o/h2o-2.2.6.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-CMAKE_MAKEFILE_GENERATOR="emake"
-SSL_DEPS_SKIP=1
-USE_RUBY="ruby24 ruby25 ruby26"
-
-inherit cmake-utils ruby-single ssl-cert systemd toolchain-funcs user
-
-DESCRIPTION="H2O - the optimized HTTP/1, HTTP/2 server"
-HOMEPAGE="https://h2o.examp1e.net/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="libh2o +mruby"
-
-RDEPEND="dev-lang/perl
- sys-libs/zlib
- libh2o? ( dev-libs/libuv )
- dev-libs/openssl:0="
-DEPEND="${RDEPEND}
- libh2o? ( virtual/pkgconfig )
- mruby? (
- ${RUBY_DEPS}
- || (
- dev-libs/onigmo
- dev-libs/oniguruma
- )
- sys-devel/bison
- virtual/pkgconfig
- )"
-RDEPEND+="
- !sci-libs/libh2o"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.2-libressl-2.7.patch
- "${FILESDIR}"/${PN}-2.2-mruby.patch
-)
-
-pkg_setup() {
- enewgroup ${PN}
- enewuser ${PN} -1 -1 -1 ${PN}
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- local ruby="ruby"
- if use mruby; then
- for ruby in ${RUBY_TARGETS_PREFERENCE}; do
- if has_version dev-lang/ruby:${ruby:4:1}.${ruby:5}; then
- break
- fi
- ruby=
- done
- [[ -z ${ruby} ]] && die "no suitable ruby version found"
- fi
-
- sed -i \
- -e "/INSTALL/s:\(/doc/${PN}\) :\1/html :" \
- -e "/INSTALL/s:\(/doc\)/${PN}:\1/${PF}:" \
- -e "s: ruby: ${ruby}:" \
- CMakeLists.txt
-
- sed -i "s:pkg-config:$(tc-getPKG_CONFIG):g" deps/mruby/lib/mruby/gem.rb
- tc-export CC
- export LD="$(tc-getCC)"
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc/${PN}
- -DWITH_MRUBY=$(usex mruby)
- -DWITHOUT_LIBS=$(usex !libh2o)
- -DBUILD_SHARED_LIBS=$(usex libh2o)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- keepdir /var/www/localhost/htdocs
-
- insinto /etc/${PN}
- doins "${FILESDIR}"/${PN}.conf
-
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- systemd_dounit "${FILESDIR}"/${PN}.service
-
- insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
-
- keepdir /var/log/${PN}
- fowners ${PN}:${PN} /var/log/${PN}
- fperms 0750 /var/log/${PN}
-}
-
-pkg_postinst() {
- if [[ ! -f "${EROOT}"etc/ssl/${PN}/server.key ]]; then
- install_cert /etc/ssl/${PN}/server
- chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/server.*
- fi
-}