aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Moone <gentoo@chaoslab.org>2018-12-09 16:52:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2018-12-09 14:27:36 -0500
commit59beb84fee0daa4e7239a49e87069617998ee7f0 (patch)
tree4c748493e6c73ee3e99fa4d99467eab254c57416
parentDrop =net-mail/courier-imap-4.16.2 (diff)
downloadlibressl-59beb84fee0daa4e7239a49e87069617998ee7f0.tar.gz
libressl-59beb84fee0daa4e7239a49e87069617998ee7f0.tar.bz2
libressl-59beb84fee0daa4e7239a49e87069617998ee7f0.zip
net-misc/aria2: Drop 1.33.1
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-misc/aria2/Manifest1
-rw-r--r--net-misc/aria2/aria2-1.33.1.ebuild155
2 files changed, 0 insertions, 156 deletions
diff --git a/net-misc/aria2/Manifest b/net-misc/aria2/Manifest
index f52cd56..f26538b 100644
--- a/net-misc/aria2/Manifest
+++ b/net-misc/aria2/Manifest
@@ -1,2 +1 @@
-DIST aria2-1.33.1.tar.xz 1505208 BLAKE2B fb74add042d0cda81ca1b9c9d9b27b559ba859829c681520d6ece6322411f139667a1eaddc6f8aef23931e301ba4aab599ab17595df8d6ef477000f5e8fa83f0 SHA512 5379768a0960e46ed616a2540508d0dda4172c8d1a05021e50243241adb64448f5fa01878868ea206ec6b462fea39fa82284bb0f78ceec299eb289f94815b94a
DIST aria2-1.34.0.tar.xz 1525908 BLAKE2B 479145af229f5fe864e54c511197bedb306199dbda608416aa295930a8392c7a118993b5a1634db20b380ab448cc8a397a351b6b64560ca263a0818d47a1ae64 SHA512 80bc43e242c06acc95030021cb347b4ec230729f3d7e512ca1932941b34ef95c312a34007a226869e5d720839a400e66cdb072ccab5d42228d8cf3d828723dcc
diff --git a/net-misc/aria2/aria2-1.33.1.ebuild b/net-misc/aria2/aria2-1.33.1.ebuild
deleted file mode 100644
index 1f11eda..0000000
--- a/net-misc/aria2/aria2-1.33.1.ebuild
+++ /dev/null
@@ -1,155 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit bash-completion-r1
-
-DESCRIPTION="A download utility with segmented downloading with BitTorrent support"
-HOMEPAGE="https://aria2.github.io/"
-SRC_URI="https://github.com/aria2/${PN}/releases/download/release-${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="adns bittorrent +gnutls jemalloc libressl libuv +libxml2 metalink +nettle nls sqlite scripts ssh ssl tcmalloc test xmlrpc"
-
-CDEPEND="sys-libs/zlib:0=
- ssl? (
- app-misc/ca-certificates
- gnutls? ( >=net-libs/gnutls-1.2.9:0= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= ) ) )
- adns? ( >=net-dns/c-ares-1.5.0:0= )
- bittorrent? (
- ssl? (
- gnutls? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-6:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- !ssl? (
- nettle? ( >=dev-libs/nettle-2.4:0=[gmp] >=dev-libs/gmp-6:0= )
- !nettle? ( >=dev-libs/libgcrypt-1.2.2:0= ) ) )
- jemalloc? ( dev-libs/jemalloc )
- libuv? ( >=dev-libs/libuv-1.13:0= )
- metalink? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )
- sqlite? ( dev-db/sqlite:3= )
- ssh? ( net-libs/libssh2:= )
- tcmalloc? ( dev-util/google-perftools )
- xmlrpc? (
- libxml2? ( >=dev-libs/libxml2-2.6.26:2= )
- !libxml2? ( dev-libs/expat:0= ) )"
-
-DEPEND="${CDEPEND}
- app-arch/xz-utils
- virtual/pkgconfig
- nls? ( sys-devel/gettext )
- test? ( >=dev-util/cppunit-1.12.0:0 )"
-RDEPEND="${CDEPEND}
- nls? ( virtual/libiconv virtual/libintl )
- scripts? ( dev-lang/ruby )"
-
-# xmlrpc has no explicit switch, it's turned out by any XML library
-# so metalink implicitly forces it on
-REQUIRED_USE="?? ( jemalloc tcmalloc )
- metalink? ( xmlrpc )"
-RESTRICT="!test? ( test )"
-
-pkg_setup() {
- if use scripts && ! use xmlrpc; then
- ewarn "Please note that you may need to enable USE=xmlrpc to run the aria2rpc"
- ewarn "and aria2mon scripts against the local aria2."
- fi
-}
-
-src_prepare() {
- eapply "${FILESDIR}"/aria2-libressl.patch
- default
- sed -i -e "s|/tmp|${T}|" test/*.cc test/*.txt || die "sed failed"
-}
-
-src_configure() {
- local myconf=(
- # threads, epoll: check for best portability
-
- # do not try to compile and run a test LIBXML program
- --disable-xmltest
- # enable the shared library
- --enable-libaria2
- # zlib should always be available anyway
- --with-libz
- --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
-
- # optional features
- $(use_enable bittorrent)
- $(use_enable metalink)
- $(use_enable nls)
- $(use_with adns libcares)
- $(use_with jemalloc)
- $(use_with libuv)
- $(use_with sqlite sqlite3)
- $(use_with ssh libssh2)
- $(use_with tcmalloc)
- )
-
- # SSL := gnutls / openssl
- # USE=ssl
- # + USE=gnutls -> gnutls
- # + USE=-gnutls -> openssl
-
- if use ssl; then
- myconf+=( $(use_with gnutls) $(use_with !gnutls openssl) )
- else
- myconf+=( --without-gnutls --without-openssl )
- fi
-
- # message-digest := nettle / gcrypt / openssl
- # bignum := nettle+gmp / gcrypt / openssl
- # bittorrent := message-digest + bignum
- # USE=bittorrent
- # + USE=(ssl -gnutls) -> openssl
- # + USE=nettle -> nettle+gmp
- # + USE=-nettle -> gcrypt
-
- if use !bittorrent || use ssl && use !gnutls; then
- myconf+=( --without-libgcrypt --without-libnettle --without-libgmp )
- else
- myconf+=( $(use_with !nettle libgcrypt)
- $(use_with nettle libnettle) $(use_with nettle libgmp) )
- fi
-
- # metalink+xmlrpc := libxml2 / expat
- # USE=(metalink || xmlrpc)
- # + USE=libxml2 -> libxml2
- # + USE=-libxml2 -> expat
-
- if use metalink || use xmlrpc; then
- myconf+=( $(use_with !libxml2 libexpat) $(use_with libxml2) )
- else
- myconf+=( --without-libexpat --without-libxml2 )
- fi
-
- # Note:
- # - always enable gzip/http compression since zlib should always be available anyway
- # - always enable epoll since we can assume kernel 2.6.x
- # - other options for threads: solaris, pth, win32
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- rm -rf "${D}"/usr/share/doc/aria2 \
- "${D}"/usr/share/doc/${PF}/README{,.html}
-
- dobashcomp doc/bash_completion/aria2c
- use scripts && dobin doc/xmlrpc/aria2{mon,rpc}
-}
-
-pkg_postinst() {
- if use xmlrpc; then
- elog "If you would like to use the additional aria2mon and aria2rpc tools,"
- elog "you need to have \033[1mdev-lang/ruby\033[0m installed."
- fi
-}