aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Moone <gentoo@chaoslab.org>2018-12-09 16:53:21 +0000
committerAnthony G. Basile <blueness@gentoo.org>2018-12-09 14:27:36 -0500
commit8385e927c96f71e60c7b73db2797ca15c1316438 (patch)
tree17d8a3acb1e2e7caa0184987b4e75872422fca3e
parentnet-misc/aria2: Drop 1.33.1 (diff)
downloadlibressl-8385e927c96f71e60c7b73db2797ca15c1316438.tar.gz
libressl-8385e927c96f71e60c7b73db2797ca15c1316438.tar.bz2
libressl-8385e927c96f71e60c7b73db2797ca15c1316438.zip
Drop net-misc/curl
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
-rw-r--r--net-misc/curl/Manifest1
-rw-r--r--net-misc/curl/curl-7.59.0.ebuild250
-rw-r--r--net-misc/curl/files/curl-7.30.0-prefix.patch21
-rw-r--r--net-misc/curl/files/curl-7.59.0-libressl-2.7.patch30
-rw-r--r--net-misc/curl/files/curl-fix-gnutls-nettle.patch27
-rw-r--r--net-misc/curl/files/curl-respect-cflags-3.patch14
-rw-r--r--net-misc/curl/metadata.xml22
7 files changed, 0 insertions, 365 deletions
diff --git a/net-misc/curl/Manifest b/net-misc/curl/Manifest
deleted file mode 100644
index 246ca46..0000000
--- a/net-misc/curl/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST curl-7.59.0.tar.bz2 2904158 BLAKE2B c44d9985a19cb7b1e273f868181b0017c7b00683c195fd2c6696b9976e3c6a80d8b80490379c2dce653a9b2d698d1be33fce71a0e61844f38c12c44594909c35 SHA512 9b5586f443a3c9fed947debce86861a8dea0fbf59bf8838cfd72a0884f13073630cf9d369b5535a059d122decd738c652705567752517f5cb11148cc16f693fb
diff --git a/net-misc/curl/curl-7.59.0.ebuild b/net-misc/curl/curl-7.59.0.ebuild
deleted file mode 100644
index 1539b98..0000000
--- a/net-misc/curl/curl-7.59.0.ebuild
+++ /dev/null
@@ -1,250 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit autotools eutils prefix multilib-minimal
-
-DESCRIPTION="A Client that groks URLs"
-HOMEPAGE="https://curl.haxx.se/"
-SRC_URI="https://curl.haxx.se/download/${P}.tar.bz2"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="adns brotli http2 idn ipv6 kerberos ldap metalink rtmp samba ssh ssl static-libs test threads"
-IUSE+=" curl_ssl_axtls curl_ssl_gnutls curl_ssl_libressl curl_ssl_mbedtls curl_ssl_nss +curl_ssl_openssl curl_ssl_winssl"
-IUSE+=" elibc_Winnt"
-
-#lead to lots of false negatives, bug #285669
-RESTRICT="test"
-
-RDEPEND="ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
- brotli? ( app-arch/brotli:= )
- ssl? (
- curl_ssl_axtls? (
- net-libs/axtls:0=[${MULTILIB_USEDEP}]
- app-misc/ca-certificates
- )
- curl_ssl_gnutls? (
- net-libs/gnutls:0=[static-libs?,${MULTILIB_USEDEP}]
- dev-libs/nettle:0=[${MULTILIB_USEDEP}]
- app-misc/ca-certificates
- )
- curl_ssl_libressl? (
- dev-libs/libressl:0=[static-libs?,${MULTILIB_USEDEP}]
- )
- curl_ssl_mbedtls? (
- net-libs/mbedtls:0=[${MULTILIB_USEDEP}]
- app-misc/ca-certificates
- )
- curl_ssl_openssl? (
- dev-libs/openssl:0=[static-libs?,${MULTILIB_USEDEP}]
- )
- curl_ssl_nss? (
- dev-libs/nss:0[${MULTILIB_USEDEP}]
- app-misc/ca-certificates
- )
- )
- http2? ( net-libs/nghttp2[${MULTILIB_USEDEP}] )
- idn? ( net-dns/libidn2:0[static-libs?,${MULTILIB_USEDEP}] )
- adns? ( net-dns/c-ares:0[${MULTILIB_USEDEP}] )
- kerberos? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- metalink? ( >=media-libs/libmetalink-0.1.1[${MULTILIB_USEDEP}] )
- rtmp? ( media-video/rtmpdump[${MULTILIB_USEDEP}] )
- ssh? ( net-libs/libssh2[static-libs?,${MULTILIB_USEDEP}] )
- sys-libs/zlib[${MULTILIB_USEDEP}]
- abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20140508-r13
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-# Do we need to enforce the same ssl backend for curl and rtmpdump? Bug #423303
-# rtmp? (
-# media-video/rtmpdump
-# curl_ssl_gnutls? ( media-video/rtmpdump[gnutls] )
-# curl_ssl_openssl? ( media-video/rtmpdump[-gnutls,ssl] )
-# )
-
-# ssl providers to be added:
-# fbopenssl $(use_with spnego)
-
-DEPEND="${RDEPEND}
- >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
- test? (
- sys-apps/diffutils
- dev-lang/perl
- )"
-
-# c-ares must be disabled for threads
-# only one ssl provider can be enabled
-REQUIRED_USE="
- curl_ssl_winssl? ( elibc_Winnt )
- threads? ( !adns )
- ssl? (
- ^^ (
- curl_ssl_axtls
- curl_ssl_gnutls
- curl_ssl_libressl
- curl_ssl_mbedtls
- curl_ssl_nss
- curl_ssl_openssl
- curl_ssl_winssl
- )
- )"
-
-DOCS=( CHANGES README docs/FEATURES docs/INTERNALS.md \
- docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE.md )
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/curl/curlbuild.h
-)
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/curl-config
-)
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-7.30.0-prefix.patch
- eapply "${FILESDIR}"/${PN}-respect-cflags-3.patch
- eapply "${FILESDIR}"/${PN}-fix-gnutls-nettle.patch
- eapply "${FILESDIR}"/${PN}-7.59.0-libressl-2.7.patch
-
- sed -i '/LD_LIBRARY_PATH=/d' configure.ac || die #382241
-
- eapply_user
- eprefixify curl-config.in
- eautoreconf
-
- if [[ ${CHOST} == *-darwin17 ]] ; then
- # https://bugs.gentoo.org/show_bug.cgi?id=637252
- sed -i -e '/-Werror=partial-availability/s/Werror/Wno-error/g' \
- configure || die
- fi
-}
-
-multilib_src_configure() {
- # We make use of the fact that later flags override earlier ones
- # So start with all ssl providers off until proven otherwise
- local myconf=()
- myconf+=( --without-axtls --without-gnutls --without-mbedtls --without-nss --without-polarssl --without-ssl --without-winssl )
- myconf+=( --without-ca-fallback --with-ca-bundle="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt )
- if use ssl ; then
- if use curl_ssl_axtls; then
- einfo "SSL provided by axtls"
- myconf+=( --with-axtls )
- elif use curl_ssl_gnutls; then
- einfo "SSL provided by gnutls"
- myconf+=( --with-gnutls --with-nettle )
- elif use curl_ssl_libressl; then
- einfo "SSL provided by LibreSSL"
- myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
- elif use curl_ssl_mbedtls; then
- einfo "SSL provided by mbedtls"
- myconf+=( --with-mbedtls )
- elif use curl_ssl_nss; then
- einfo "SSL provided by nss"
- myconf+=( --with-nss )
- elif use curl_ssl_openssl; then
- einfo "SSL provided by openssl"
- myconf+=( --with-ssl --with-ca-path="${EPREFIX}"/etc/ssl/certs )
- elif use curl_ssl_winssl; then
- einfo "SSL provided by Windows"
- myconf+=( --with-winssl )
- else
- eerror "We can't be here because of REQUIRED_USE."
- fi
- else
- einfo "SSL disabled"
- fi
-
- # These configuration options are organized alphabetically
- # within each category. This should make it easier if we
- # ever decide to make any of them contingent on USE flags:
- # 1) protocols first. To see them all do
- # 'grep SUPPORT_PROTOCOLS configure.ac'
- # 2) --enable/disable options second.
- # 'grep -- --enable configure | grep Check | awk '{ print $4 }' | sort
- # 3) --with/without options third.
- # grep -- --with configure | grep Check | awk '{ print $4 }' | sort
- ECONF_SOURCE="${S}" \
- econf \
- --enable-crypto-auth \
- --enable-dict \
- --enable-file \
- --enable-ftp \
- --enable-gopher \
- --enable-http \
- --enable-imap \
- $(use_enable ldap) \
- $(use_enable ldap ldaps) \
- --disable-ntlm-wb \
- --enable-pop3 \
- --enable-rt \
- --enable-rtsp \
- $(use_enable samba smb) \
- $(use_with ssh libssh2) \
- --enable-smtp \
- --enable-telnet \
- --enable-tftp \
- --enable-tls-srp \
- $(use_enable adns ares) \
- --enable-cookies \
- --enable-hidden-symbols \
- $(use_enable ipv6) \
- --enable-largefile \
- --without-libpsl \
- --enable-manual \
- --enable-proxy \
- --disable-sspi \
- $(use_enable static-libs static) \
- $(use_enable threads threaded-resolver) \
- $(use_enable threads pthreads) \
- --disable-versioned-symbols \
- --without-cyassl \
- --without-darwinssl \
- $(use_with idn libidn2) \
- $(use_with kerberos gssapi "${EPREFIX}"/usr) \
- $(use_with metalink libmetalink) \
- $(use_with http2 nghttp2) \
- $(use_with rtmp librtmp) \
- $(use_with brotli) \
- --without-spnego \
- --without-winidn \
- --with-zlib \
- "${myconf[@]}"
-
- if ! multilib_is_native_abi; then
- # avoid building the client
- sed -i -e '/SUBDIRS/s:src::' Makefile || die
- sed -i -e '/SUBDIRS/s:scripts::' Makefile || die
- fi
-
- # Fix up the pkg-config file to be more robust.
- # https://github.com/curl/curl/issues/864
- local priv=() libs=()
- # We always enable zlib.
- libs+=( "-lz" )
- priv+=( "zlib" )
- if use http2; then
- libs+=( "-lnghttp2" )
- priv+=( "libnghttp2" )
- fi
- if use curl_ssl_openssl; then
- libs+=( "-lssl" "-lcrypto" )
- priv+=( "openssl" )
- fi
- grep -q Requires.private libcurl.pc && die "need to update ebuild"
- libs=$(printf '|%s' "${libs[@]}")
- sed -i -r \
- -e "/^Libs.private/s:(${libs#|})( |$)::g" \
- libcurl.pc || die
- echo "Requires.private: ${priv[*]}" >> libcurl.pc
-}
-
-multilib_src_install_all() {
- einstalldocs
- prune_libtool_files --all
-
- rm -rf "${ED}"/etc/
-}
diff --git a/net-misc/curl/files/curl-7.30.0-prefix.patch b/net-misc/curl/files/curl-7.30.0-prefix.patch
deleted file mode 100644
index fd495c4..0000000
--- a/net-misc/curl/files/curl-7.30.0-prefix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur curl-7.30.0.orig/curl-config.in curl-7.30.0/curl-config.in
---- curl-7.30.0.orig/curl-config.in 2013-02-06 09:44:37.000000000 -0500
-+++ curl-7.30.0/curl-config.in 2013-04-17 18:43:56.000000000 -0400
-@@ -134,7 +134,7 @@
- else
- CPPFLAG_CURL_STATICLIB=""
- fi
-- if test "X@includedir@" = "X/usr/include"; then
-+ if test "X@includedir@" = "X@GENTOO_PORTAGE_EPREFIX@/usr/include"; then
- echo "$CPPFLAG_CURL_STATICLIB"
- else
- echo "${CPPFLAG_CURL_STATICLIB}-I@includedir@"
-@@ -142,7 +142,7 @@
- ;;
-
- --libs)
-- if test "X@libdir@" != "X/usr/lib" -a "X@libdir@" != "X/usr/lib64"; then
-+ if test "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib" -a "X@libdir@" != "X@GENTOO_PORTAGE_EPREFIX@/usr/lib64"; then
- CURLLIBDIR="-L@libdir@ "
- else
- CURLLIBDIR=""
diff --git a/net-misc/curl/files/curl-7.59.0-libressl-2.7.patch b/net-misc/curl/files/curl-7.59.0-libressl-2.7.patch
deleted file mode 100644
index a048096..0000000
--- a/net-misc/curl/files/curl-7.59.0-libressl-2.7.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-$OpenBSD: patch-lib_vtls_openssl_c,v 1.3 2018/02/15 22:13:20 sthen Exp $
-
---- a/lib/vtls/openssl.c
-+++ b/lib/vtls/openssl.c
-@@ -117,12 +117,7 @@
- #define X509_get0_notBefore(x) X509_get_notBefore(x)
- #define X509_get0_notAfter(x) X509_get_notAfter(x)
- #define CONST_EXTS /* nope */
--#ifdef LIBRESSL_VERSION_NUMBER
--static unsigned long OpenSSL_version_num(void)
--{
-- return LIBRESSL_VERSION_NUMBER;
--}
--#else
-+#ifndef LIBRESSL_VERSION_NUMBER
- #define OpenSSL_version_num() SSLeay()
- #endif
- #endif
-@@ -3527,7 +3522,11 @@ static size_t Curl_ossl_version(char *buffer, size_t s
- unsigned long ssleay_value;
- sub[2]='\0';
- sub[1]='\0';
-+#ifdef LIBRESSL_VERSION_NUMBER
-+ ssleay_value = LIBRESSL_VERSION_NUMBER;
-+#else
- ssleay_value = OpenSSL_version_num();
-+#endif
- if(ssleay_value < 0x906000) {
- ssleay_value = SSLEAY_VERSION_NUMBER;
- sub[0]='\0';
diff --git a/net-misc/curl/files/curl-fix-gnutls-nettle.patch b/net-misc/curl/files/curl-fix-gnutls-nettle.patch
deleted file mode 100644
index fbacb77..0000000
--- a/net-misc/curl/files/curl-fix-gnutls-nettle.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -Naur curl-7.25.0.orig//configure.ac curl-7.25.0/configure.ac
---- curl-7.25.0.orig//configure.ac 2012-04-04 17:24:48.000000000 -0400
-+++ curl-7.25.0/configure.ac 2012-04-04 17:23:07.000000000 -0400
-@@ -1823,20 +1823,9 @@
-
- if test "$GNUTLS_ENABLED" = "1"; then
- USE_GNUTLS_NETTLE=
-- # First check if we can detect either crypto library via transitive linking
-- AC_CHECK_LIB(gnutls, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
-- if test "$USE_GNUTLS_NETTLE" = ""; then
-- AC_CHECK_LIB(gnutls, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
-- fi
-- # If not, try linking directly to both of them to see if they are available
-- if test "$USE_GNUTLS_NETTLE" = ""; then
-- AC_CHECK_LIB(nettle, nettle_MD5Init, [ USE_GNUTLS_NETTLE=1 ])
-- fi
-- if test "$USE_GNUTLS_NETTLE" = ""; then
-- AC_CHECK_LIB(gcrypt, gcry_control, [ USE_GNUTLS_NETTLE=0 ])
-- fi
-- if test "$USE_GNUTLS_NETTLE" = ""; then
-- AC_MSG_ERROR([GnuTLS found, but neither gcrypt nor nettle found])
-+ AC_ARG_WITH(nettle)
-+ if test "x$withval" = "xyes"; then
-+ USE_GNUTLS_NETTLE=1
- fi
- if test "$USE_GNUTLS_NETTLE" = "1"; then
- AC_DEFINE(USE_GNUTLS_NETTLE, 1, [if GnuTLS uses nettle as crypto backend])
diff --git a/net-misc/curl/files/curl-respect-cflags-3.patch b/net-misc/curl/files/curl-respect-cflags-3.patch
deleted file mode 100644
index 4a4a614..0000000
--- a/net-misc/curl/files/curl-respect-cflags-3.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index e9b49c7..e374ab6 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -280,9 +280,6 @@ dnl **********************************************************************
-
- CURL_CHECK_COMPILER
- CURL_SET_COMPILER_BASIC_OPTS
--CURL_SET_COMPILER_DEBUG_OPTS
--CURL_SET_COMPILER_OPTIMIZE_OPTS
--CURL_SET_COMPILER_WARNING_OPTS
-
- if test "$compiler_id" = "INTEL_UNIX_C"; then
- #
diff --git a/net-misc/curl/metadata.xml b/net-misc/curl/metadata.xml
deleted file mode 100644
index b911bba..0000000
--- a/net-misc/curl/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
- </maintainer>
- <use>
- <flag name="brotli">Enable brotli compression support</flag>
- <flag name="http2">Enabled HTTP/2.0 support</flag>
- <flag name="ssh">Enabled SSH urls in curl using libssh2</flag>
- <flag name="metalink">Enable metalink support</flag>
- <flag name="ssl">Enable crypto engine support (via openssl if USE='-gnutls -nss')</flag>
- <flag name="rtmp">Enable RTMP Streaming Media support</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:curl:curl</remote-id>
- <remote-id type="cpe">cpe:/a:curl:libcurl</remote-id>
- <remote-id type="cpe">cpe:/a:haxx:curl</remote-id>
- <remote-id type="cpe">cpe:/a:haxx:libcurl</remote-id>
- </upstream>
-</pkgmetadata>