aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/libarchive/Manifest1
-rw-r--r--app-arch/libarchive/files/libarchive-3.3.2-libressl-2.7.patch14
-rw-r--r--app-arch/libarchive/libarchive-3.3.2.ebuild128
-rw-r--r--app-arch/libarchive/metadata.xml36
4 files changed, 0 insertions, 179 deletions
diff --git a/app-arch/libarchive/Manifest b/app-arch/libarchive/Manifest
deleted file mode 100644
index 1e3ae30..0000000
--- a/app-arch/libarchive/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST libarchive-3.3.2.tar.gz 6236562 BLAKE2B da26474b4fd8111561c1e5ac12a6333a8ba8a23cce9e9cdce7b50647ab8dbae08609ea1bffbab60da74c6555ebf0815c456fe69c72129eb6071fb845141d0beb SHA512 1e538cd7d492f54b11c16c56f12c1632ba14302a3737ec0db786272aec0c8020f1e27616a7654d57e26737e5ed9bfc9a62f1fdda61a95c39eb726aa7c2f673e4
diff --git a/app-arch/libarchive/files/libarchive-3.3.2-libressl-2.7.patch b/app-arch/libarchive/files/libarchive-3.3.2-libressl-2.7.patch
deleted file mode 100644
index 252d9e4..0000000
--- a/app-arch/libarchive/files/libarchive-3.3.2-libressl-2.7.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-$OpenBSD: patch-libarchive_archive_openssl_hmac_private_h,v 1.3 2018/02/18 14:57:47 sthen Exp $
-
---- a/libarchive/archive_openssl_hmac_private.h
-+++ b/libarchive/archive_openssl_hmac_private.h
-@@ -28,7 +28,8 @@
- #include <openssl/hmac.h>
- #include <openssl/opensslv.h>
-
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
-+ (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x2070000fL)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline HMAC_CTX *HMAC_CTX_new(void)
diff --git a/app-arch/libarchive/libarchive-3.3.2.ebuild b/app-arch/libarchive/libarchive-3.3.2.ebuild
deleted file mode 100644
index d6134b1..0000000
--- a/app-arch/libarchive/libarchive-3.3.2.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils libtool multilib-minimal toolchain-funcs
-
-DESCRIPTION="BSD tar command"
-HOMEPAGE="http://www.libarchive.org/"
-SRC_URI="http://www.libarchive.org/downloads/${P}.tar.gz"
-
-LICENSE="BSD BSD-2 BSD-4 public-domain"
-SLOT="0/13"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="acl +bzip2 +e2fsprogs expat +iconv kernel_linux libressl lz4 +lzma lzo nettle static-libs +threads xattr +zlib"
-
-RDEPEND="
- acl? ( virtual/acl[${MULTILIB_USEDEP}] )
- bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
- expat? ( dev-libs/expat[${MULTILIB_USEDEP}] )
- !expat? ( dev-libs/libxml2[${MULTILIB_USEDEP}] )
- iconv? ( virtual/libiconv[${MULTILIB_USEDEP}] )
- kernel_linux? (
- xattr? ( sys-apps/attr[${MULTILIB_USEDEP}] )
- )
- !libressl? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- lz4? ( >=app-arch/lz4-0_p131:0=[${MULTILIB_USEDEP}] )
- lzma? ( app-arch/xz-utils[threads=,${MULTILIB_USEDEP}] )
- lzo? ( >=dev-libs/lzo-2[${MULTILIB_USEDEP}] )
- nettle? ( dev-libs/nettle:0=[${MULTILIB_USEDEP}] )
- zlib? ( sys-libs/zlib[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- kernel_linux? (
- virtual/os-headers
- e2fsprogs? ( sys-fs/e2fsprogs )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.3.2-libressl-2.7.patch
-)
-
-# Various test problems, starting with the fact that sandbox
-# explodes on long paths. https://bugs.gentoo.org/598806
-RESTRICT="test"
-
-src_prepare() {
- default
- elibtoolize # is required for Solaris sol2_ld linker fix
-}
-
-multilib_src_configure() {
- export ac_cv_header_ext2fs_ext2_fs_h=$(usex e2fsprogs) #354923
-
- local myconf=()
- myconf=(
- $(use_enable acl)
- $(use_enable static-libs static)
- $(use_enable xattr)
- $(use_with bzip2 bz2lib)
- $(use_with expat)
- $(use_with !expat xml2)
- $(use_with iconv)
- $(use_with lz4)
- $(use_with lzma)
- $(use_with lzo lzo2)
- $(use_with nettle)
- $(use_with zlib)
- )
- if multilib_is_native_abi ; then
- myconf+=(
- --enable-bsdcat=$(tc-is-static-only && echo static || echo shared)
- --enable-bsdcpio=$(tc-is-static-only && echo static || echo shared)
- --enable-bsdtar=$(tc-is-static-only && echo static || echo shared)
- )
- else
- myconf+=(
- --disable-bsdcat
- --disable-bsdcpio
- --disable-bsdtar
- )
- fi
-
- ECONF_SOURCE="${S}" econf "${myconf[@]}"
-}
-
-multilib_src_compile() {
- if multilib_is_native_abi ; then
- emake
- else
- emake libarchive.la
- fi
-}
-
-multilib_src_test() {
- # Replace the default src_test so that it builds tests in parallel
- multilib_is_native_abi && emake check
-}
-
-multilib_src_install() {
- if multilib_is_native_abi ; then
- emake DESTDIR="${D}" install
-
- # Create symlinks for FreeBSD
- if ! use prefix && [[ ${CHOST} == *-freebsd* ]]; then
- # Exclude cat for the time being #589876
- for bin in cpio tar; do
- dosym bsd${bin} /usr/bin/${bin}
- echo '.so bsd${bin}.1' > "${T}"/${bin}.1
- doman "${T}"/${bin}.1
- done
- fi
- else
- local install_targets=(
- install-includeHEADERS
- install-libLTLIBRARIES
- install-pkgconfigDATA
- )
- emake DESTDIR="${D}" "${install_targets[@]}"
- fi
-
- # Libs.private: should be used from libarchive.pc instead
- prune_libtool_files
-}
-
-multilib_src_install_all() {
- cd "${S}" || die
- einstalldocs
-}
diff --git a/app-arch/libarchive/metadata.xml b/app-arch/libarchive/metadata.xml
deleted file mode 100644
index 126e3e2..0000000
--- a/app-arch/libarchive/metadata.xml
+++ /dev/null
@@ -1,36 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>bsd@gentoo.org</email>
- <name>BSD Project</name>
- </maintainer>
- <longdescription lang="en">
- The bsdtar program creates and manipulates streaming archive files.
- It has a number of advantages over previous tar implementations.
- </longdescription>
- <use>
- <flag name="bzip2">
- Allow accessing bzip2-compressed archives through libbz2 (which
- comes with <pkg>app-arch/bzip2</pkg>). This only affects
- libarchive's native support: bsdtar will keep using bunzip2 as a
- filter if that's not built-in.
- </flag>
- <flag name="e2fsprogs">
- Use file flags from <pkg>sys-fs/e2fsprogs</pkg> headers instead of <pkg>virtual/os-headers</pkg> headers
- </flag>
- <flag name="lz4">
- Enable support for LZ4 compression using <pkg>app-arch/lz4</pkg>
- </flag>
- <flag name="nettle">
- Use <pkg>dev-libs/nettle</pkg> as crypto backend
- </flag>
- <flag name="zlib">
- Allow accessing gzip-compressed archives through
- <pkg>sys-libs/zlib</pkg>. This only affects libarchive's native
- support: bsdtar will keep using gunzip as a filter if that's not
- built-in. It's also needed for supporting extraction of ZIP
- files.
- </flag>
- </use>
-</pkgmetadata>