aboutsummaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-qt/qtnetwork: Drop oldHEADmasterDennis Gaebler10 hours2-68/+0
| | | | | | Reported-by: Dennis Gaebler <dennis.gaebler@uni-ulm.de> Closes: https://github.com/gentoo/libressl/pull/292 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-qt/qtnetwork: Add 5.12.3Dennis Gaebler10 hours2-0/+68
| | | | | | Reported-by: Dennis Gaebler <dennis.gaebler@uni-ulm.de> Bug: https://bugs.gentoo.org/562050 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* Drop deprecated libressl-overlay.xmlStefan Strogin5 days1-17/+0
| | | | Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: bump version to 8.16.0Stefan Strogin5 days2-0/+212
| | | | | Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* README: update overlay installation instructionsStefan Strogin6 days1-4/+6
| | | | Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: drop oldStefan Strogin6 days4-634/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: version 8.15.1Stefan Strogin6 days2-0/+212
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: Add 11.14.0maurerpe6 days3-0/+234
| | | | | | | | Add net-libs/nodejs-11.14.0. Continue to use bundled openssl. Reported-by: maurerpe <junk4me46806@yahoo.com> Closes: https://github.com/gentoo/libressl/pull/290 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* app-crypt/qca: bump version to 2.2.0; update patchStefan Strogin11 days3-11/+45
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-util/cargo: sync ebuild with gentoo.gitStefan Strogin2019-04-081-2/+7
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* app-crypt/qca: add package from gentoo.git; patch for LibreSSLStefan Strogin2019-04-085-0/+211
| | | | | | Bug: https://bugs.gentoo.org/657720 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-voip/linphone: drop package removed from gentoo.gitStefan Strogin2019-03-254-155/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/libeXosip: drop package removed from gentoo.gitStefan Strogin2019-03-253-48/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-qt/qtnetwork: drop oldStefan Strogin2019-03-252-68/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: drop oldStefan Strogin2019-03-2510-3121/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/nodejs: add 10.15.2 and 10.15.3maurerpe2019-03-253-3/+213
| | | | | | | | | | Keep nodejs up to date with portage. These versions still use bundled openssl due to lack of openssl support. Remove version 10.15.0 since it is no longer in portage. Reported-by: maurerpe <junk4me46806@yahoo.com> Closes: https://github.com/gentoo/libressl/pull/288 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-perl/Net-SSLeay: add version 1.860.0_p9Stefan Strogin2019-03-254-0/+103
| | | | | | | This version supports LibreSSL 2.9.0 out of box. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-qt/qtnetwork: bump version to 5.12.2Stefan Strogin2019-03-172-0/+68
| | | | | | Bug: https://bugs.gentoo.org/562050 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-misc/openssh: drop; fixed in gentoo.gitStefan Strogin2019-03-1326-2787/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-libs/liboauth: drop; fix no longer relevantStefan Strogin2019-03-065-309/+0
| | | | | | | | | Current version from gentoo.git builds successfully with USE="-nss libressl". Bug: https://bugs.gentoo.org/671178 Bug: https://bugs.gentoo.org/676080 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* net-dns/bind-tools: fixed upstream, new version is in gentoo.gitStefan Strogin2019-03-065-267/+0
| | | | | | Bug: https://bugs.gentoo.org/651310 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* media-video/ffmpeg: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-0513-3003/+0
| | | | | | Bug: https://bugs.gentoo.org/569818 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* www-client/lynx: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-057-321/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* app-admin/sudo: drop; fixed in gentoo.gitStefan Strogin2019-03-035-732/+0
| | | | | | Bug: https://bugs.gentoo.org/678888 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-qt/qtnetwork: bump version to 5.12.1; add patchStefan Strogin2019-03-023-0/+161
| | | | | | Bug: https://bugs.gentoo.org/562050 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-qt/qtnetwork: drop oldStefan Strogin2019-03-023-141/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-libs/libgit2: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-014-138/+0
| | | | | | | | Upstream patch for LibreSSL >=2.7.0: https://github.com/libgit2/libgit2/commit/7490d449b518115a1ae86b01397e95c38e39cff1 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-libs/libevent: drop; fixed upstream and in gentoo.gitStefan Strogin2019-03-014-178/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-cpp/commoncpp2: drop; fixed in gentoo.gitStefan Strogin2019-03-0113-416/+0
| | | | | Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* mail-filter/imapfilter: drop; fixed upstream and in gentoo.gitStefan Strogin2019-02-284-110/+0
| | | | | | | | | Fixed in: https://github.com/lefcha/imapfilter/commit/c470c45d1fcb9bf1d51e9ffba6c7be9186dcc6d2 https://github.com/lefcha/imapfilter/commit/9b227c9c67851b279f593b763f5396d782f1d6b9 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* sys-apps/kmod: add package from gentoo.git; patch for LibreSSLStefan Strogin2019-02-245-0/+421
| | | | | | Bug: https://bugs.gentoo.org/677960 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* app-crypt/signify: drop; libressl support is in main treeStefan Strogin2019-02-212-45/+0
| | | | | | Closes: #284 Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-python/*: drop as patches are upstream in gentoo.gitAaron Bauman2019-02-204-314/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-perl/*: drop as changes are upstream in gentoo.gitAaron Bauman2019-02-207-185/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-libs/boost: drop; fixed in the upstream and main treeStefan Strogin2019-02-2013-955/+0
| | | | | Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-lang/rust: drop; libressl support is in main treeStefan Strogin2019-02-206-470/+0
| | | | | Package-Manager: Portage-2.3.61, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com>
* dev-lang/python: drop as gentoo.git carries patchesAaron Bauman2019-02-2020-3146/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-db/sqlcipher: drop as changes are carried in gentoo.gitAaron Bauman2019-02-204-106/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* app-text/mupdf: drop as changes are in gentoo.gitAaron Bauman2019-02-2016-1245/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* app-arch/*: drop as gentoo.git is carrying patches nowAaron Bauman2019-02-204-179/+0
| | | | Signed-off-by: Aaron Bauman <bman@gentoo.org>
* dev-util/electron: Add libressl compatible electron buildMaximilian Friedersdorff2019-02-194-0/+1002
| | | | | | | Package-Manager: Portage-2.3.61, Repoman-2.3.12 Manifest-Sign-Key: BA1CE947376048A4B3C4D4E50B3B880CF5E7FCB3 Signed-off-by: Maximilian Friedersdorff <max@friedersdorff.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* net-libs/nodejs: Version 8.15.0Stefan Strogin2019-01-152-0/+212
| | | | | | Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Stefan Strogin <stefan.strogin@gmail.com> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* net-libs/nodejs: version bump to 10.15.0callmetango2019-01-152-0/+210
| | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* Merge pull request #278 from prototype99/masterAnthony G. Basile2019-01-012-1/+4
|\ | | | | add more fixes for #258
| * Update ManifestSeirra2019-01-011-0/+3
| |
| * fix openssl versioningSeirra2019-01-011-1/+1
|/
* dev-perl/Net-SSLeay: new packageQuentin Retornaz2018-12-207-0/+185
| | | | | | Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* dev-util/cargo: openssl-sys crate bump to 0.9.40 for libressl 2.9.0Quentin Retornaz2018-12-202-2/+2
| | | | | | Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* dev-lang/rust: initial commitmaurerpe2018-12-146-0/+470
| | | | | | | Patch rust-1.31.0 to add support for all of libressl-2.8.x instead of just libressl-2.8.1. Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
* net-libs/liboauth: libressl support in openssl-1.1 patchSandino Araico Sanchez2018-12-111-1/+1
| | | | Signed-off-by: Anthony G. Basile <blueness@gentoo.org>