aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/libmnl/Manifest1
-rw-r--r--net-libs/libmnl/libmnl-1.0.3-r1.ebuild32
-rw-r--r--net-libs/libmnl/metadata.xml15
3 files changed, 48 insertions, 0 deletions
diff --git a/net-libs/libmnl/Manifest b/net-libs/libmnl/Manifest
new file mode 100644
index 0000000..5e56654
--- /dev/null
+++ b/net-libs/libmnl/Manifest
@@ -0,0 +1 @@
+DIST libmnl-1.0.3.tar.bz2 337375 SHA256 6f14336e9acdbc62c2dc71bbb59ce162e54e9af5c80153e92476c5443fe784de SHA512 c47b76a6125271ef9dce13bc8bebd415d2bbd79b6d50491d8ba23344e7e6fe0c1413fe055913ab9444203f0d73166b79f0d4b532b13b62feecde3e5a8cd442a7 WHIRLPOOL 80717c63015e8df36a11c2b7914d63747ff296fac72b4f3a66670038f94d28961ddc6dce2050c41d3ceaf195030b61535ee84a628fa1fa686d8fed013f4d6261
diff --git a/net-libs/libmnl/libmnl-1.0.3-r1.ebuild b/net-libs/libmnl/libmnl-1.0.3-r1.ebuild
new file mode 100644
index 0000000..4b0bbc2
--- /dev/null
+++ b/net-libs/libmnl/libmnl-1.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Minimalistic netlink library"
+HOMEPAGE="http://netfilter.org/projects/libmnl"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux"
+IUSE="examples static-libs"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a mnl
+ prune_libtool_files
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/net-libs/libmnl/metadata.xml b/net-libs/libmnl/metadata.xml
new file mode 100644
index 0000000..7d46164
--- /dev/null
+++ b/net-libs/libmnl/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>netmon@gentoo.org</email>
+ <name>Gentoo network monitoring and analysis project</name>
+</maintainer>
+<longdescription lang="en">
+ libmnl is a minimalistic user-space library oriented to Netlink developers.
+ There are a lot of common tasks in parsing, validating, constructing of both
+ the Netlink header and TLVs that are repetitive and easy to get wrong. This
+ library aims to provide simple helpers that allows you to re-use code and to
+ avoid re-inventing the wheel.
+</longdescription>
+</pkgmetadata>