summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-11-27 11:02:50 +0100
committerFabian Groffen <grobian@gentoo.org>2017-11-27 11:02:50 +0100
commit3ebaafa07c70197d1de7d8961c3af56bfa8ff590 (patch)
tree8e6b6b1e7d1f0829906ecbf6ec01c720236a1337
parentsys-libs/readline: sync (diff)
downloadprefix-3ebaafa07c70197d1de7d8961c3af56bfa8ff590.tar.gz
prefix-3ebaafa07c70197d1de7d8961c3af56bfa8ff590.tar.bz2
prefix-3ebaafa07c70197d1de7d8961c3af56bfa8ff590.zip
app-arch/bzip2: remove interrevision
Package-Manager: Portage-2.3.13-prefix, Repoman-2.3.4
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r07.1.ebuild157
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-progress.patch175
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.4-prefix.patch57
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.4-saneso.patch13
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.5-Makefile-libbz2_dylib60
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.5-checkenv.patch21
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.5-soldflags.patch31
7 files changed, 0 insertions, 514 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.6-r07.1.ebuild b/app-arch/bzip2/bzip2-1.0.6-r07.1.ebuild
deleted file mode 100644
index 4d5efcff0e..0000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r07.1.ebuild
+++ /dev/null
@@ -1,157 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.6-r7.ebuild,v 1.2 2014/04/28 17:18:31 mgorny Exp $
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI=4
-
-inherit eutils toolchain-funcs multilib multilib-minimal prefix
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="http://www.bzip.org/"
-SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
-IUSE="static static-libs"
-
-RDEPEND="abi_x86_32? (
- !<=app-emulation/emul-linux-x86-baselibs-20130224
- !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
- )"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- epatch "${FILESDIR}"/${PN}-1.0.6-progress.patch
- epatch "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- epatch "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- epatch "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
- epatch "${FILESDIR}"/${PN}-1.0.6-out-of-tree-build.patch
-
- epatch "${FILESDIR}"/${PN}-1.0.6-r7-checkenv.patch # for AIX, Darwin?
- epatch "${FILESDIR}"/${PN}-1.0.6-prefix.patch
- eprefixify bz{diff,grep,more}
- # this a makefile for Darwin, which already "includes" saneso
- cp "${FILESDIR}"/${P}-Makefile-libbz2_dylib Makefile-libbz2_dylib || die
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s -f :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-
- if [[ ${CHOST} == *-hpux* ]] ; then
- sed -i -e 's,-soname,+h,' Makefile-libbz2_so || die "cannot replace -soname with +h"
- if [[ ${CHOST} == hppa*-hpux* && ${CHOST} != hppa64*-hpux* ]] ; then
- sed -i -e '/^SOEXT/s,so,sl,' Makefile-libbz2_so || die "cannot replace so with sl"
- sed -i -e '/^SONAME/s,=,=${EPREFIX}/lib/,' Makefile-libbz2_so || die "cannt set soname"
- fi
- fi
- if [[ ${CHOST} == *-cygwin* ]] ; then
- sed -i -e "s/-o libbz2\.so\.${PV}/-Wl,--out-implib=libbz2$(get_libname ${PV})/" \
- -e "s/-Wl,-soname -Wl,libbz2\.so\.1/-o cygbz2-${PV%%.*}.dll/" \
- -e "s/libbz2\.so/libbz2$(get_libname)/g" \
- Makefile-libbz2_so
- fi
-}
-
-bemake() {
- emake \
- VPATH="${S}" \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@"
-}
-
-multilib_src_compile() {
- local checkopts=
- case "${CHOST}" in
- *-darwin*)
- bemake PREFIX="${EPREFIX}"/usr -f "${S}"/Makefile-libbz2_dylib all
- # FWIW, #504648 like for .so below
- ln -sf libbz2.${PV}.dylib libbz2.dylib
- ;;
- *-mint*)
- # do nothing, no shared libraries
- :
- ;;
- *)
- bemake -f "${S}"/Makefile-libbz2_so all
- # Make sure we link against the shared lib #504648
- [[ $(get_libname) != $(get_libname ${PV}) ]] &&
- ln -sf libbz2$(get_libname ${PV}) libbz2$(get_libname)
- ;;
- esac
- bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
-}
-
-multilib_src_install() {
- into /usr
-
- if ! tc-is-static-only; then
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2$(get_libname ${PV})
- [[ ${CHOST} == *-cygwin* ]] && dobin cygbz2-${PV%%.*}.dll
- local v
- [[ $(get_libname) != $(get_libname ${PV}) ]] &&
- for v in libbz2$(get_libname) libbz2$(get_libname ${PV%%.*}) libbz2$(get_libname ${PV%.*}) ; do
- dosym libbz2$(get_libname ${PV}) /usr/$(get_libdir)/${v}
- done
-
- fi
-
- use static-libs && dolib.a libbz2.a
-
- if multilib_is_native_abi ; then
- gen_usr_ldscript -a bz2
-
- dobin bzip2recover
- into /
- dobin bzip2
- fi
-}
-
-multilib_src_install_all() {
- # `make install` doesn't cope with out-of-tree builds, nor with
- # installing just non-binaries, so handle things ourselves.
- insinto /usr/include
- doins bzlib.h
- into /usr
- dobin bz{diff,grep,more}
- doman *.1
-
- dosym bzdiff /usr/bin/bzcmp
- dosym bzdiff.1 /usr/share/man/man1/bzcmp.1
-
- dosym bzmore /usr/bin/bzless
- dosym bzmore.1 /usr/share/man/man1/bzless.1
-
- local x
- for x in bunzip2 bzcat bzip2recover ; do
- dosym bzip2.1 /usr/share/man/man1/${x}.1
- done
- for x in bz{e,f}grep ; do
- dosym bzgrep /usr/bin/${x}
- dosym bzgrep.1 /usr/share/man/man1/${x}.1
- done
-
- dodoc README* CHANGES manual.pdf
- dohtml manual.html
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-progress.patch b/app-arch/bzip2/files/bzip2-1.0.2-progress.patch
deleted file mode 100644
index 2f389cfac9..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.2-progress.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-Ripped from Mandrake.
-
-http://bugs.gentoo.org/show_bug.cgi?id=82192
-
---- bzip2-1.0.2.org/bzip2.1
-+++ bzip2-1.0.2/bzip2.1
-@@ -235,6 +235,10 @@
- Suppress non-essential warning messages. Messages pertaining to
- I/O errors and other critical events will not be suppressed.
- .TP
-+.B \-p --show-progress
-+Show percentage of input-file done and while compressing show the percentage
-+of the original file the new file is.
-+.TP
- .B \-v --verbose
- Verbose mode -- show the compression ratio for each file processed.
- Further \-v's increase the verbosity level, spewing out lots of
---- bzip2-1.0.2.org/bzip2.c
-+++ bzip2-1.0.2/bzip2.c
-@@ -145,6 +145,7 @@
- #include <signal.h>
- #include <math.h>
- #include <errno.h>
-+#include <time.h>
- #include <ctype.h>
- #include "bzlib.h"
-
-@@ -301,6 +302,7 @@
- Char progNameReally[FILE_NAME_LEN];
- FILE *outputHandleJustInCase;
- Int32 workFactor;
-+Char showProgress;
-
- static void panic ( Char* ) NORETURN;
- static void ioError ( void ) NORETURN;
-@@ -425,6 +427,12 @@
- UInt32 nbytes_in_lo32, nbytes_in_hi32;
- UInt32 nbytes_out_lo32, nbytes_out_hi32;
- Int32 bzerr, bzerr_dummy, ret;
-+ double fileSize = 0; /* initialized to make the compiler stop crying */
-+ /* double because big files might otherwhise give
-+ * overflows. not long long since not all compilers
-+ * support that one
-+ */
-+ time_t startTime, currentTime;
-
- SET_BINARY_MODE(stream);
- SET_BINARY_MODE(zStream);
-@@ -432,12 +440,21 @@
- if (ferror(stream)) goto errhandler_io;
- if (ferror(zStream)) goto errhandler_io;
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ (void)fseek(stream, 0, SEEK_END);
-+ fileSize = (double)ftell(stream);
-+ rewind(stream);
-+ if (verbosity >= 1)
-+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
-+ }
-+
- bzf = BZ2_bzWriteOpen ( &bzerr, zStream,
- blockSize100k, verbosity, workFactor );
- if (bzerr != BZ_OK) goto errhandler;
-
- if (verbosity >= 2) fprintf ( stderr, "\n" );
-
-+ time(&startTime);
- while (True) {
-
- if (myfeof(stream)) break;
-@@ -446,13 +463,32 @@
- if (nIbuf > 0) BZ2_bzWrite ( &bzerr, bzf, (void*)ibuf, nIbuf );
- if (bzerr != BZ_OK) goto errhandler;
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True)
-+ {
-+ time(&currentTime);
-+
-+ if ((currentTime - startTime) > 1) { /* show progress every 2 seconds */
-+ double curInPos = (double)ftell(stream);
-+ double curOutPos = (double)ftell(zStream);
-+
-+ startTime = currentTime;
-+
-+ fprintf(stderr, "%.2f%% done", (curInPos * 100.0) / fileSize);
-+ if (srcMode == SM_F2F)
-+ {
-+ fprintf(stderr, ", new size: %.2f%%", (curOutPos * 100.0) / curInPos);
-+ }
-+
-+ fprintf(stderr, " \r");
-+ }
-+ }
- }
-
- BZ2_bzWriteClose64 ( &bzerr, bzf, 0,
- &nbytes_in_lo32, &nbytes_in_hi32,
- &nbytes_out_lo32, &nbytes_out_hi32 );
- if (bzerr != BZ_OK) goto errhandler;
--
-+
- if (ferror(zStream)) goto errhandler_io;
- ret = fflush ( zStream );
- if (ret == EOF) goto errhandler_io;
-@@ -526,6 +562,8 @@
- UChar unused[BZ_MAX_UNUSED];
- Int32 nUnused;
- UChar* unusedTmp;
-+ double fileSize = 0; /* initialized to make the compiler stop crying */
-+ time_t startTime, currentTime;
-
- nUnused = 0;
- streamNo = 0;
-@@ -533,9 +571,19 @@
- SET_BINARY_MODE(stream);
- SET_BINARY_MODE(zStream);
-
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ long dummy = ftell(zStream);
-+ (void)fseek(zStream, 0, SEEK_END);
-+ fileSize = (double)ftell(zStream);
-+ (void)fseek(zStream, dummy, SEEK_SET);
-+ if (verbosity >= 1)
-+ fprintf(stderr, "Input-file size: %ld\n", (long)fileSize);
-+ }
-+
- if (ferror(stream)) goto errhandler_io;
- if (ferror(zStream)) goto errhandler_io;
-
-+ time(&startTime);
- while (True) {
-
- bzf = BZ2_bzReadOpen (
-@@ -551,6 +599,17 @@
- if ((bzerr == BZ_OK || bzerr == BZ_STREAM_END) && nread > 0)
- fwrite ( obuf, sizeof(UChar), nread, stream );
- if (ferror(stream)) goto errhandler_io;
-+
-+ if ((srcMode == SM_F2F || srcMode == SM_F2O) && showProgress == True) {
-+ time(&currentTime);
-+ if ((currentTime - startTime) >= 2)
-+ {
-+ double curInPos = (double)ftell(zStream);
-+ startTime = currentTime;
-+
-+ fprintf(stderr, "%.2f%% done\r", (curInPos * 100.0) / fileSize);
-+ }
-+ }
- }
- if (bzerr != BZ_STREAM_END) goto errhandler;
-
-@@ -1872,6 +1931,7 @@
- deleteOutputOnInterrupt = False;
- exitValue = 0;
- i = j = 0; /* avoid bogus warning from egcs-1.1.X */
-+ showProgress = False;
-
- /*-- Set up signal handlers for mem access errors --*/
- signal (SIGSEGV, mySIGSEGVorSIGBUScatcher);
-@@ -1949,6 +2009,7 @@
- case 'k': keepInputFiles = True; break;
- case 's': smallMode = True; break;
- case 'q': noisy = False; break;
-+ case 'p': showProgress = True; break;
- case '1': blockSize100k = 1; break;
- case '2': blockSize100k = 2; break;
- case '3': blockSize100k = 3; break;
-@@ -1985,6 +2046,7 @@
- if (ISFLAG("--keep")) keepInputFiles = True; else
- if (ISFLAG("--small")) smallMode = True; else
- if (ISFLAG("--quiet")) noisy = False; else
-+ if (ISFLAG("--show-progress")) showProgress = True; else
- if (ISFLAG("--version")) license(); else
- if (ISFLAG("--license")) license(); else
- if (ISFLAG("--exponential")) workFactor = 1; else
diff --git a/app-arch/bzip2/files/bzip2-1.0.4-prefix.patch b/app-arch/bzip2/files/bzip2-1.0.4-prefix.patch
deleted file mode 100644
index 9215bcd702..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.4-prefix.patch
+++ /dev/null
@@ -1,57 +0,0 @@
---- bzdiff
-+++ bzdiff
-@@ -1,4 +1,4 @@
--#!/bin/sh
-+#!@GENTOO_PORTAGE_EPREFIX@/bin/bash
- # sh is buggy on RS/6000 AIX 3.2. Replace above line with #!/bin/ksh
-
- # Bzcmp/diff wrapped for bzip2,
-@@ -12,7 +12,7 @@
- # necessary) and fed to cmp or diff. The exit status from cmp
- # or diff is preserved.
-
--PATH="/usr/bin:/bin:$PATH"; export PATH
-+PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:@GENTOO_PORTAGE_EPREFIX@/bin:$PATH"; export PATH
- prog=`echo $0 | sed 's|.*/||'`
- case "$prog" in
- *cmp) comp=${CMP-cmp} ;;
-@@ -56,7 +56,7 @@
- bzip2 -cdfq "$2" > $tmp
- bzip2 -cdfq "$1" | $comp $OPTIONS - $tmp
- STAT="$?"
-- /bin/rm -f $tmp;;
-+ @GENTOO_PORTAGE_EPREFIX@/bin/rm -f $tmp;;
-
- *) bzip2 -cdfq "$1" | $comp $OPTIONS - "$2"
- STAT="$?";;
---- bzgrep
-+++ bzgrep
-@@ -1,4 +1,4 @@
--#!/bin/sh
-+#!@GENTOO_PORTAGE_EPREFIX@/bin/sh
-
- # Bzgrep wrapped for bzip2,
- # adapted from zgrep by Philippe Troin <phil@fifi.org> for Debian GNU/Linux.
-@@ -6,7 +6,7 @@
- ## zgrep -- a wrapper around a grep program that decompresses files as needed
- ## Adapted from a version sent by Charles Levert <charles@comm.polymtl.ca>
-
--PATH="/usr/bin:$PATH"; export PATH
-+PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:$PATH"; export PATH
-
- prog=`echo $0 | sed 's|.*/||'`
- case "$prog" in
---- bzmore
-+++ bzmore
-@@ -1,9 +1,9 @@
--#!/bin/sh
-+#!@GENTOO_PORTAGE_EPREFIX@/bin/sh
-
- # Bzmore wrapped for bzip2,
- # adapted from zmore by Philippe Troin <phil@fifi.org> for Debian GNU/Linux.
-
--PATH="/usr/bin:$PATH"; export PATH
-+PATH="@GENTOO_PORTAGE_EPREFIX@/usr/bin:$PATH"; export PATH
-
- prog=`echo $0 | sed 's|.*/||'`
- case "$prog" in
diff --git a/app-arch/bzip2/files/bzip2-1.0.4-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.4-saneso.patch
deleted file mode 100644
index 0469f46b8a..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.4-saneso.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- Makefile-libbz2_so
-+++ Makefile-libbz2_so
-@@ -35,8 +35,8 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.4 $(OBJS)
-- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
-+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.4 libbz2.so.1.0
-
diff --git a/app-arch/bzip2/files/bzip2-1.0.5-Makefile-libbz2_dylib b/app-arch/bzip2/files/bzip2-1.0.5-Makefile-libbz2_dylib
deleted file mode 100644
index cd0ee20a5e..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.5-Makefile-libbz2_dylib
+++ /dev/null
@@ -1,60 +0,0 @@
-
-# This Makefile builds a shared version of the library,
-# libbz2.1.0.5.dylib, with install_name libbz2.1.dylib on Darwin
-#
-# Makefile created and used by Gentoo
-
-# ------------------------------------------------------------------
-# This file is part of bzip2/libbzip2, a program and library for
-# lossless, block-sorting data compression.
-#
-# bzip2/libbzip2 version 1.0.5 of 10 December 2007
-# Copyright (C) 1996-2007 Julian Seward <jseward@bzip.org>
-#
-# Please read the WARNING, DISCLAIMER and PATENTS sections in the
-# README file.
-#
-# This program is released under the terms of the license contained
-# in the file LICENSE.
-# ------------------------------------------------------------------
-
-
-SHELL=/bin/sh
-CC=gcc
-BIGFILES=-D_FILE_OFFSET_BITS=64
-CFLAGS+=-fpic -fPIC -Wall -Winline $(BIGFILES)
-PREFIX=/usr
-LIBDIR=lib
-SOLDFLAGS=-dynamiclib -install_name $(PREFIX)/$(LIBDIR)/libbz2.1.dylib -compatibility_version 1.0.0 -current_version 1.0.5
-
-OBJS= blocksort.o \
- huffman.o \
- crctable.o \
- randtable.o \
- compress.o \
- decompress.o \
- bzlib.o
-
-all: $(OBJS)
- $(CC) $(LDFLAGS) $(SOLDFLAGS) -o libbz2.1.0.5.dylib $(OBJS)
- $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.1.0.5.dylib
- rm -f libbz2.1.0.dylib
- ln -s libbz2.1.0.5.dylib libbz2.1.0.dylib
-
-clean:
- rm -f $(OBJS) bzip2.o libbz2.1.0.5.dylib libbz2.1.0.dylib bzip2-shared
-
-blocksort.o: blocksort.c
- $(CC) $(CFLAGS) -c blocksort.c
-huffman.o: huffman.c
- $(CC) $(CFLAGS) -c huffman.c
-crctable.o: crctable.c
- $(CC) $(CFLAGS) -c crctable.c
-randtable.o: randtable.c
- $(CC) $(CFLAGS) -c randtable.c
-compress.o: compress.c
- $(CC) $(CFLAGS) -c compress.c
-decompress.o: decompress.c
- $(CC) $(CFLAGS) -c decompress.c
-bzlib.o: bzlib.c
- $(CC) $(CFLAGS) -c bzlib.c
diff --git a/app-arch/bzip2/files/bzip2-1.0.5-checkenv.patch b/app-arch/bzip2/files/bzip2-1.0.5-checkenv.patch
deleted file mode 100644
index 3300a424a3..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.5-checkenv.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile 2005-02-17 05:28:24.000000000 -0600
-+++ Makefile-new 2005-10-12 20:26:29.000000000 -0500
-@@ -42,12 +42,12 @@
- check: test
- test: bzip2
- @cat words1
-- ./bzip2 -1 < sample1.ref > sample1.rb2
-- ./bzip2 -2 < sample2.ref > sample2.rb2
-- ./bzip2 -3 < sample3.ref > sample3.rb2
-- ./bzip2 -d < sample1.bz2 > sample1.tst
-- ./bzip2 -d < sample2.bz2 > sample2.tst
-- ./bzip2 -ds < sample3.bz2 > sample3.tst
-+ $(TESTENV) ./bzip2 -1 < sample1.ref > sample1.rb2
-+ $(TESTENV) ./bzip2 -2 < sample2.ref > sample2.rb2
-+ $(TESTENV) ./bzip2 -3 < sample3.ref > sample3.rb2
-+ $(TESTENV) ./bzip2 -d < sample1.bz2 > sample1.tst
-+ $(TESTENV) ./bzip2 -d < sample2.bz2 > sample2.tst
-+ $(TESTENV) ./bzip2 -ds < sample3.bz2 > sample3.tst
- cmp sample1.bz2 sample1.rb2
- cmp sample2.bz2 sample2.rb2
- cmp sample3.bz2 sample3.rb2
diff --git a/app-arch/bzip2/files/bzip2-1.0.5-soldflags.patch b/app-arch/bzip2/files/bzip2-1.0.5-soldflags.patch
deleted file mode 100644
index 1a06195dec..0000000000
--- a/app-arch/bzip2/files/bzip2-1.0.5-soldflags.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile-libbz2_so.orig 2009-06-23 12:30:55.000000000 +0200
-+++ Makefile-libbz2_so 2009-06-23 12:31:38.000000000 +0200
-@@ -25,6 +25,9 @@
- CC=gcc
- BIGFILES=-D_FILE_OFFSET_BITS=64
- CFLAGS+=-fpic -fPIC -Wall -Winline $(BIGFILES)
-+SOEXT=so
-+SONAME=libbz2.${SOEXT}.1
-+SOLDFLAGS=-shared -Wl,-soname -Wl,$(SONAME)
-
- OBJS= blocksort.o \
- huffman.o \
-@@ -35,13 +38,13 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.4 $(OBJS)
-- $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.4
-- rm -f libbz2.so.1.0
-- ln -s libbz2.so.1.0.4 libbz2.so.1.0
-+ $(CC) $(LDFLAGS) $(SOLDFLAGS) -o libbz2.${SOEXT}.1.0.4 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.${SOEXT}.1.0.4
-+ rm -f libbz2.${SOEXT}.1.0
-+ ln -s libbz2.${SOEXT}.1.0.4 libbz2.${SOEXT}.1.0
-
- clean:
-- rm -f $(OBJS) bzip2.o libbz2.so.1.0.4 libbz2.so.1.0 bzip2-shared
-+ rm -f $(OBJS) bzip2.o libbz2.${SOEXT}.1.0.4 libbz2.${SOEXT}.1.0 bzip2-shared
-
- blocksort.o: blocksort.c
- $(CC) $(CFLAGS) -c blocksort.c