aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgentoo90 <gentoo90@gmail.com>2020-01-05 00:05:08 +0200
committerMikhail Pukhlikov <cynede@gentoo.org>2020-01-13 10:19:22 +0400
commit138876e503cb9b9160f8ae96b950228afb246330 (patch)
tree2065523403d2ec8366b619ee81171a116950ab7c
parentdev-rust/cranelift-tools: update to v0.52.0 (diff)
downloadrust-138876e503cb9b9160f8ae96b950228afb246330.tar.gz
rust-138876e503cb9b9160f8ae96b950228afb246330.tar.bz2
rust-138876e503cb9b9160f8ae96b950228afb246330.zip
dev-lang/rust-bin-9999: allow choosing specific nightly version
Add RUST_NIGHTLY_DATE variable, similar to EGIT_COMMIT from git-r3.eclass. Usage: RUST_NIGHTLY_DATE="YYYY-MM-DD" emerge rust-bin:nightly Closes: https://github.com/gentoo/gentoo-rust/pull/474 Signed-off-by: Mikhail Pukhlikov <cynede@gentoo.org>
-rw-r--r--dev-lang/rust-bin/rust-bin-9999.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/rust-bin-9999.ebuild b/dev-lang/rust-bin/rust-bin-9999.ebuild
index e66acb1..3eb3dbc 100644
--- a/dev-lang/rust-bin/rust-bin-9999.ebuild
+++ b/dev-lang/rust-bin/rust-bin-9999.ebuild
@@ -10,6 +10,11 @@ HOMEPAGE="https://www.rust-lang.org/"
MY_SRC_URI="https://static.rust-lang.org/dist/rust-nightly"
MY_STDLIB_SRC_URI="https://static.rust-lang.org/dist/rust-std-nightly"
+if [[ -v RUST_NIGHTLY_DATE ]]; then
+ MY_SRC_URI="https://static.rust-lang.org/dist/${RUST_NIGHTLY_DATE}/rust-nightly"
+ MY_STDLIB_SRC_URI="https://static.rust-lang.org/dist/${RUST_NIGHTLY_DATE}/rust-std-nightly"
+fi
+
ALL_RUSTLIB_TARGETS=(
"wasm32-unknown-unknown"
)
@@ -80,6 +85,9 @@ src_install() {
components="${components},rls-preview,${analysis}"
fi
use rustfmt && components="${components},rustfmt-preview"
+
+ elog "installing components: ${components}"
+
./install.sh \
--components="${components}" \
--disable-verify \