summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-24 12:29:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-24 12:29:51 +0200
commit5e8438f8c65044e20dd3d6eaff30fdfcc1a426ea (patch)
tree109f940d80da3ba088764fa3e87b08460a34cb37
parentnet-im/qutimbump: bump; patch release from full tarball (diff)
downloadgentoo-5e8438f8c65044e20dd3d6eaff30fdfcc1a426ea.tar.gz
gentoo-5e8438f8c65044e20dd3d6eaff30fdfcc1a426ea.tar.bz2
gentoo-5e8438f8c65044e20dd3d6eaff30fdfcc1a426ea.zip
net-libs/openpgm: Make compatible with py2
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=492974 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--net-libs/openpgm/openpgm-5.1.118-r1.ebuild31
-rw-r--r--net-libs/openpgm/openpgm-5.2.122.ebuild2
2 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/openpgm/openpgm-5.1.118-r1.ebuild b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
new file mode 100644
index 000000000000..f27d8772310c
--- /dev/null
+++ b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-any-r1
+
+DESCRIPTION="Open source implementation of the Pragmatic General Multicast specification"
+HOMEPAGE="http://code.google.com/p/openpgm"
+SRC_URI="http://openpgm.googlecode.com/files/libpgm-${PV}~dfsg.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/libpgm-${PV}~dfsg/${PN}/pgm"
+
+src_install() {
+ DOCS=( "${S}"/../doc/. "${S}"/README )
+
+ autotools-utils_src_install
+}
diff --git a/net-libs/openpgm/openpgm-5.2.122.ebuild b/net-libs/openpgm/openpgm-5.2.122.ebuild
index 023987ac0442..cc42dc99bc82 100644
--- a/net-libs/openpgm/openpgm-5.2.122.ebuild
+++ b/net-libs/openpgm/openpgm-5.2.122.ebuild
@@ -18,6 +18,8 @@ SLOT="0"
KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~x86-fbsd"
IUSE="static-libs"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
DEPEND="${PYTHON_DEPS}"
S="${WORKDIR}/libpgm-${PV}~dfsg/${PN}/pgm"