summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-07-01 18:16:25 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-07-01 18:16:25 +0000
commit8e901301a21f967dba39ff4187120f6f7622d163 (patch)
treef2b656fb2728c0ff822eb9bbcbfa582dcec2ebc5
parent2022-07-01 16:31:49 UTC (diff)
parentapp-admin/terraform: add 1.2.4 (diff)
downloadgentoo-8e901301a21f967dba39ff4187120f6f7622d163.tar.gz
gentoo-8e901301a21f967dba39ff4187120f6f7622d163.tar.bz2
gentoo-8e901301a21f967dba39ff4187120f6f7622d163.zip
Merge updates from master
-rw-r--r--app-admin/terraform/Manifest2
-rw-r--r--app-admin/terraform/terraform-1.2.4.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/app-admin/terraform/Manifest b/app-admin/terraform/Manifest
index 57f0a9cfb844..203a5599a89c 100644
--- a/app-admin/terraform/Manifest
+++ b/app-admin/terraform/Manifest
@@ -2,3 +2,5 @@ DIST terraform-1.2.2-deps.tar.xz 264293344 BLAKE2B 939e0385d04a535af85ccd45d8078
DIST terraform-1.2.2.tar.gz 5179827 BLAKE2B 28a5d4e9c7c4f2001a76acafa039d808996eb41b20af21f013f6ecb1368f11a9891b2b17abedc41fa9a881081e3e89a42958c6a6868df19070d9fd8ed3abc1f2 SHA512 0bd56c2c281848a1f3e983e76a6ee13b7a483b02c35dcdf09084a2bee0aa39e9cc9380be35cb1b13cf895430c42117884c6bd2e27d487953d1fc73caac070f9f
DIST terraform-1.2.3-deps.tar.xz 264283836 BLAKE2B 5b8305463b5978c903499d0a813acc3217d5cbd0298e6d0eb62d30a25b7a6dd29f6d7a3991f16ab23b5f5b99a073bb79fe8600b9af782efcbb1d274ce0f3d205 SHA512 2bb63e46e5e9a8f52620661cd186c82aefb74d92dffbc71c8b7e38e3861ca958a6d7ab1656d22e1f011ddacb32b4624bb4aee74e00fb051dae8fdf0e31dd9d6f
DIST terraform-1.2.3.tar.gz 5181975 BLAKE2B 120db2c139726b3c1a5c76dcf048de6508f0a99b1f7a8abc2bc7fdb596a72453b4543806090062d804d68157dcb42255119e9e13c462668077baeca83016d287 SHA512 f2aa7436ac82fad365fbae22428984c6a62cb9a7ffa339af035c06f5002fae1b3b440265fdb97e0f4a4aeaebf3838f5a05cd3c40bca1a50273f0560ad4482fda
+DIST terraform-1.2.4-deps.tar.xz 264291608 BLAKE2B 4c0dd8d76bbf2b062f80225ff65342bccdf1f9efb03f0a309a42cdb64f139dbf31fb9ab6cf1754c0dde36c57123ffb7d5bb078d195ab879d29f29b2338761402 SHA512 e4440e541096a4311f713f8338d0653dd35fb7169cf39b1f06d8b1a7ad59d9b55d8115ae56edee9ce3da744d85180e606a9428b4907d1d6badcf8c77f72df36d
+DIST terraform-1.2.4.tar.gz 5183520 BLAKE2B 51b9353dfe40e988c8c621f9e09ec9d3e8facfa7b682832671b3f0f12f52d0836dd6ff1851bebfe6ca590248cd029c508dc35b437b637a51ace4c36ad5807730 SHA512 43dfc4745dbcb3f29577fac610771258c5a9551bf33019d1f6bd3059a808cd365f432842c565522c530b03abf18aeada53fc390604eaeafce4464afd9edcb463
diff --git a/app-admin/terraform/terraform-1.2.4.ebuild b/app-admin/terraform/terraform-1.2.4.ebuild
new file mode 100644
index 000000000000..411e61a46d05
--- /dev/null
+++ b/app-admin/terraform/terraform-1.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="dev-go/gox"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ export CGO_ENABLED=0
+ gox \
+ -os=$(go env GOOS) \
+ -arch=$(go env GOARCH) \
+ -output bin/terraform \
+ -verbose \
+ . || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " terraform -install-autocomplete"
+}