summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-21 11:16:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-21 11:16:33 +0200
commit000222a4a757c3321995860b56265c66116881ee (patch)
treed304cc8de0840113474b9164ba8db5174d6f1869
parentnet-analyzer/testssl: version bump 3.0.1 (diff)
downloadgentoo-000222a4a757c3321995860b56265c66116881ee.tar.gz
gentoo-000222a4a757c3321995860b56265c66116881ee.tar.bz2
gentoo-000222a4a757c3321995860b56265c66116881ee.zip
dev-python/markdown2: Bump to 2.3.8
Bug: https://bugs.gentoo.org/718656 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/markdown2/Manifest1
-rw-r--r--dev-python/markdown2/markdown2-2.3.8.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
index ff1604841588..f49f48ecaeeb 100644
--- a/dev-python/markdown2/Manifest
+++ b/dev-python/markdown2/Manifest
@@ -1 +1,2 @@
DIST markdown2-2.3.0.zip 145194 BLAKE2B ef6e5744b6d9c9c8de20ac2d17ea0fc13453dd6401ab0c8d6d258f6a19aec4e94cfdfef28cbef7ef4b4bf6133a0acb55a1d8a76a41ac621498117c39b1fc1a6e SHA512 48bf8e26b34c48c0c12fc0f110b09d3232ea3394db3325d50639adf5cefb603344ee97b116e09b574f7c7414ab4a8293ddc37ca6706e41baaa14e399fa467d5f
+DIST markdown2-2.3.8.tar.gz 86850 BLAKE2B e227139d4ac368095872b09bcaac78ad49c7ae43b63036563c3b80b2ff6a78c3d302d8a2c56b68a5ba1d01967ab1861f842986316bb6d0a6625cb21b644e46eb SHA512 76abbbb2fa5f6a4cc43f358812079a2561f45ba5c2aed1a1860256440f7c48ca5e766c00c2464b973ef0cbbff9db58bca4398dc15ef8b5d203a6565b226bd7cd
diff --git a/dev-python/markdown2/markdown2-2.3.8.ebuild b/dev-python/markdown2/markdown2-2.3.8.ebuild
new file mode 100644
index 000000000000..ddae999be0a0
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.3.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.tar.gz"
+HOMEPAGE="https://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+ cd test || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest test_markdown2.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}