summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-08-10 15:33:09 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-08-10 15:40:44 -0400
commit0135ee430d94b23b7d76cd29358e9695990bbd97 (patch)
treebd56dcf149945a7ed76be89617fb5c2826324ee1
parentapp-text/discount: new version 2.2.0. (diff)
downloadgentoo-0135ee430d94b23b7d76cd29358e9695990bbd97.tar.gz
gentoo-0135ee430d94b23b7d76cd29358e9695990bbd97.tar.bz2
gentoo-0135ee430d94b23b7d76cd29358e9695990bbd97.zip
app-text/discount: remove v2.1.6-r1 and a patch it used.
Package-Manager: portage-2.2.28
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.1.6-r1.ebuild71
-rw-r--r--app-text/discount/files/discount-2.1.6-portage-multilib-CFLAGS.patch58
3 files changed, 0 insertions, 130 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index d731d4f17227..394f7de24e47 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,3 +1,2 @@
-DIST discount-2.1.6.tar.bz2 83823 SHA256 702bb29e17e387f82e40fae062d5e4939bc6fb22dcf53e6109982a5faa110796 SHA512 75e2fcc31f670bab77a3658a684054971998e91ad14743814480a4d24a59285dea1fe922d16c8d1c868250c417963a80282b8fe278021240ba424b840dd4df8e WHIRLPOOL 9f519c44df4bc5300729dd0f51fbcb20f957da68d03b670307bfd51c0d994b5d2b765eac6e17bba8119bb095277ce5dfbad185599bdeca834c4982eb813d7a79
DIST discount-2.1.8a.tar.bz2 85161 SHA256 c01502f4eedba8163dcd30c613ba5ee238a068f75291be127856261727e03526 SHA512 a1eba7076a27da56136b8057189c5474a36bf11f8233cbae270c8a0cf9b070332b4dcdbbbecfbfbe1d8c19961ccaf87cee27ebe855c6bc6558d8ccc423553c96 WHIRLPOOL 5d7148f6c4e9f84a5290fffafa417c4684517df6fce0deec773beb2f89b4416b7849aa50351c27338653b8950b68c3c49ba223d31e347ad7562b0cb040761114
DIST discount-2.2.0.tar.bz2 88387 SHA256 b25395c29c2c08836199eb2eae87b56e6b545e77f5fbf921678aa1dc0ddab9f3 SHA512 04b66496ca53a2ab73cba2a8f9d8e77efd13f318b188611aaaebc4fd036a02cd188aa712337df414ff3b7ac65d2ced17020085cae10338e8af47e5b9552d981a WHIRLPOOL 1b4f30e924c4f38bc0685eb78c609c461e282dd54c6f588098ffb86dc03330ab45c68340dea5dd965cd26b42771ffc379c9ef828bbfc3a79f593b75f483c3e1d
diff --git a/app-text/discount/discount-2.1.6-r1.ebuild b/app-text/discount/discount-2.1.6-r1.ebuild
deleted file mode 100644
index 6bcc944acab2..000000000000
--- a/app-text/discount/discount-2.1.6-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib
-
-DESCRIPTION="An implementation of John Gruber's Markdown text to html language written in C"
-HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
-SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
-IUSE="minimal"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-portage-multilib-CFLAGS.patch
-
- # for QA, we remove the Makefile’s usage of install -s.
- # Drop ldconfig invocation.
- # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
- # at that point).
- sed -i \
- -e '/INSTALL_PROGRAM/s,-s ,,' \
- -e 's/\(LDCONFIG=\).*/\1:/' \
- -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
- configure.inc || die "sed configure.inc failed"
-
- # Add LDFLAGS and CPPFLAGS hackily.
- sed -i \
- -e 's/^CC[ \t]*=.*/& $(CPPFLAGS)/' \
- -e 's/^LFLAGS[ \t]*=.*/& $(LDFLAGS)/' \
- Makefile.in || die "Cannot fix LDFLAGS and CPPFLAGS"
-}
-
-src_configure() {
- ./configure.sh \
- --libdir="${EPREFIX}"usr/"$(get_libdir)" \
- --prefix="${EPREFIX}"usr \
- --mandir="${EPREFIX}"usr/share/man \
- --shared \
- $(usex minimal '' --enable-all-features) \
- || die
-}
-
-src_install() {
- emake DESTDIR="${D}" $(usex minimal install install.everything)
-
- DISCOUNT_EBUILD_RENAMED_BINARIES=()
- local bin
- for bin in "${ED}"usr/bin/*; do
- [[ ${bin} = */markdown || ${bin} =~ ${PN}[^/]*$ ]] && continue
- DISCOUNT_EBUILD_RENAMED_BINARIES+=(${bin##*/})
- mv "${bin}" "${bin%/*}/${PN}-${bin##*/}" || die
- mv "${ED}"usr/share/man/man1/{,${PN}-}${bin##*/}.1 || die
- done
-}
-
-pkg_postinst() {
- if [[ ${DISCOUNT_EBUILD_RENAMED_BINARIES} ]]; then
- local bin
- elog "Some discount binaries with overly-generic names have been"
- elog "prefixed. Please see"
- elog "https://github.com/Orc/discount/issues/81 for discussion."
- for bin in "${DISCOUNT_EBUILD_RENAMED_BINARIES[@]}"; do
- elog " Renamed '${bin}' to '${PN}-${bin}'."
- done
- fi
-}
diff --git a/app-text/discount/files/discount-2.1.6-portage-multilib-CFLAGS.patch b/app-text/discount/files/discount-2.1.6-portage-multilib-CFLAGS.patch
deleted file mode 100644
index 0abf540cb968..000000000000
--- a/app-text/discount/files/discount-2.1.6-portage-multilib-CFLAGS.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 9b95e9a2dce195a8dfbdbf3206494095b177d405 Mon Sep 17 00:00:00 2001
-From: Nathan Phillip Brink <binki@gentoo.org>
-Date: Thu, 25 Jul 2013 01:14:14 -0400
-Subject: [PATCH] =?UTF-8?q?Fix=20support=20for=20=E2=80=9C$=20CFLAGS=3D-m32=20./configure.sh=E2=80=9D=20by=20using=20CFLAGS=20for=20all=20build=20invokations=20of=20CC.?=
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
----
- Makefile.in | 14 +++++++-------
- 1 files changed, 7 insertions(+), 7 deletions(-)
-
-diff --git a/Makefile.in b/Makefile.in
-index 9bb438a..3bda63d 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -64,7 +64,7 @@ $(DESTDIR)$(LIBDIR):
- @INSTALL_DIR@ $(DESTDIR)$(LIBDIR)
-
- version.o: version.c VERSION
-- $(CC) -DVERSION=\"`cat VERSION`\" -c version.c
-+ $(CC) $(CFLAGS) -DVERSION=\"`cat VERSION`\" -c version.c
-
- VERSION:
- @true
-@@ -76,23 +76,23 @@ blocktags: mktags
-
- # example programs
- @THEME@theme: theme.o $(MKDLIB) mkdio.h
--@THEME@ $(CC) $(LFLAGS) -o theme theme.o pgm_options.o -lmarkdown @LIBS@
-+@THEME@ $(CC) $(CFLAGS) $(LFLAGS) -o theme theme.o pgm_options.o -lmarkdown @LIBS@
-
-
- mkd2html: mkd2html.o $(MKDLIB) mkdio.h
-- $(CC) $(LFLAGS) -o mkd2html mkd2html.o -lmarkdown @LIBS@
-+ $(CC) $(CFLAGS) $(LFLAGS) -o mkd2html mkd2html.o -lmarkdown @LIBS@
-
- markdown: main.o pgm_options.o $(MKDLIB)
-- $(CC) $(LFLAGS) -o markdown main.o pgm_options.o -lmarkdown @LIBS@
-+ $(CC) $(CFLAGS) $(LFLAGS) -o markdown main.o pgm_options.o -lmarkdown @LIBS@
-
- makepage: makepage.c pgm_options.o $(MKDLIB) mkdio.h
-- $(CC) $(LFLAGS) -o makepage makepage.c pgm_options.o -lmarkdown @LIBS@
-+ $(CC) $(CFLAGS) $(LFLAGS) -o makepage makepage.c pgm_options.o -lmarkdown @LIBS@
-
- pgm_options.o: pgm_options.c mkdio.h config.h
-- $(CC) -I. -c pgm_options.c
-+ $(CC) $(CFLAGS) -I. -c pgm_options.c
-
- main.o: main.c mkdio.h config.h
-- $(CC) -I. -c main.c
-+ $(CC) $(CFLAGS) -I. -c main.c
-
- $(MKDLIB): $(OBJS)
- ./librarian.sh make $(MKDLIB) VERSION $(OBJS)
---
-1.7.3.4
-