summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-12-18 18:41:22 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2017-12-18 18:41:22 -0500
commit07233aa58cf3e0b26f72f624d2ea4bbecb7917f3 (patch)
tree2eba4687baaf97ab609df626311f31a8580f1d22
parentgames-util/pyfa: Version bump (diff)
downloadgentoo-07233aa58cf3e0b26f72f624d2ea4bbecb7917f3.tar.gz
gentoo-07233aa58cf3e0b26f72f624d2ea4bbecb7917f3.tar.bz2
gentoo-07233aa58cf3e0b26f72f624d2ea4bbecb7917f3.zip
games-util/pyfa: Drop old
Drop 1.33.2. Package-Manager: Portage-2.3.13, Repoman-2.3.3
-rw-r--r--games-util/pyfa/Manifest1
-rw-r--r--games-util/pyfa/pyfa-1.33.2.ebuild101
2 files changed, 0 insertions, 102 deletions
diff --git a/games-util/pyfa/Manifest b/games-util/pyfa/Manifest
index 89dbf388bec7..f9d9fc4b3cc1 100644
--- a/games-util/pyfa/Manifest
+++ b/games-util/pyfa/Manifest
@@ -1,2 +1 @@
-DIST pyfa-1.33.2.tar.gz 8596509 BLAKE2B a00729be066a417cc4702f056506c2e248bc9a9076cab50706fc46669c9b9611f35b96b3096979edf620bc5b9f8341765b2768c032a9046a2629e0b121a2dca3 SHA512 333951ef53d8088c7264297402e072124a960feb1832eda2ea2dec5df2ddc438fd72ceb3f90c5fdad0fe3f9f2e32bb712db1d30bb3f8ded921d2b621b40270f2
DIST pyfa-1.34.0.tar.gz 8629709 BLAKE2B 5b16296b675383a446bb21133c9e83726a92beb221babbf8fbe4b19f0f7e95bb19fd6050a5c2e3d5e602df4bbb83debfeefd6ec7efdbff35a47934ef9b29979f SHA512 4642efd4de5be4add3c3f994d7be9dbeeb231fe86229f7944d52f265527c7a79698d3da5ccac3018e02c6000b0da888ad0e64382e12f74b7dd7b3398e7bb2d48
diff --git a/games-util/pyfa/pyfa-1.33.2.ebuild b/games-util/pyfa/pyfa-1.33.2.ebuild
deleted file mode 100644
index dbd5180ef370..000000000000
--- a/games-util/pyfa/pyfa-1.33.2.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="sqlite,threads"
-
-inherit eutils gnome2-utils python-r1
-
-DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
-HOMEPAGE="https://github.com/pyfa-org/Pyfa"
-
-LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
-SLOT="0"
-if [[ ${PV} = 9999 ]]; then
- EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-IUSE="+graph"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.0.5[${PYTHON_USEDEP}]
- dev-python/wxpython:3.0[${PYTHON_USEDEP}]
- >=dev-python/logbook-1.0.0[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- graph? (
- dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}] )
- ${PYTHON_DEPS}"
-DEPEND="app-arch/zip"
-
-[[ ${PV} = 9999 ]] || S=${WORKDIR}/Pyfa-${PV}
-
-src_prepare() {
- # get rid of CRLF line endings introduced in 1.1.10 so patches work
- edos2unix config.py pyfa.py gui/bitmapLoader.py service/settings.py
-
- # load gameDB and images from separate staticdata directory
- eapply "${FILESDIR}/${PN}-1.33.1-staticdata.patch"
-
- # fix import path in the main script for systemwide installation
- eapply "${FILESDIR}/${PN}-1.33.1-import-pyfa.patch"
-
- eapply_user
-
- touch __init__.py
-
- pyfa_make_configforced() {
- mkdir -p "${BUILD_DIR}" || die
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- -e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced-1.15.1.py" > "${BUILD_DIR}/configforced.py"
- sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
- pyfa.py > "${BUILD_DIR}/pyfa"
- }
- python_foreach_impl pyfa_make_configforced
-}
-
-src_install() {
- pyfa_py_install() {
- local packagedir=$(python_get_sitedir)/${PN}
- insinto "${packagedir}"
- doins -r eos gui service utils config*.py __init__.py
- [[ -e info.py ]] && doins info.py # only in zip releases
- doins "${BUILD_DIR}/configforced.py"
- python_doscript "${BUILD_DIR}/pyfa"
- python_optimize
- }
- python_foreach_impl pyfa_py_install
-
- insinto /usr/share/${PN}
- doins eve.db
-
- einfo "Compressing images ..."
- pushd imgs > /dev/null || die
- zip -r imgs.zip * || die "zip failed"
- doins imgs.zip
- popd > /dev/null || die
-
- dodoc README.md
- doicon -s 32 imgs/gui/pyfa.png
- newicon -s 64 imgs/gui/pyfa64.png pyfa.png
- domenu "${FILESDIR}/${PN}.desktop"
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}