summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-18 23:48:44 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-18 23:49:07 +0000
commit07249f05acded59ac1f74d53e4961ddb346d2632 (patch)
tree1d4f62332506cc074e4f4f539eb9a64be4b8a4a2
parentdev-embedded/sdcc: update to EAPI=7, use dostrip (diff)
downloadgentoo-07249f05acded59ac1f74d53e4961ddb346d2632.tar.gz
gentoo-07249f05acded59ac1f74d53e4961ddb346d2632.tar.bz2
gentoo-07249f05acded59ac1f74d53e4961ddb346d2632.zip
dev-embedded/sdcc: drop prepstrip, bug #587310
Reported-by: Michał Górny Closes: https://bugs.gentoo.org/587310 Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-embedded/sdcc/sdcc-3.5.0.ebuild7
-rw-r--r--dev-embedded/sdcc/sdcc-3.8.0.ebuild7
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild7
3 files changed, 7 insertions, 14 deletions
diff --git a/dev-embedded/sdcc/sdcc-3.5.0.ebuild b/dev-embedded/sdcc/sdcc-3.5.0.ebuild
index 3379d7019c12..5a4e83b451dd 100644
--- a/dev-embedded/sdcc/sdcc-3.5.0.ebuild
+++ b/dev-embedded/sdcc/sdcc-3.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -112,9 +112,4 @@ src_install() {
docs_compile || cd "${WORKDIR}"/doc
dohtml -r *
fi
-
- # a bunch of archives (*.a) are built & installed by gputils
- # for PIC processors, but they do not work with standard `ar`
- # & `scanelf` utils and they're not for the host.
- env RESTRICT="" prepstrip "${D%/}"/usr/bin
}
diff --git a/dev-embedded/sdcc/sdcc-3.8.0.ebuild b/dev-embedded/sdcc/sdcc-3.8.0.ebuild
index b2e7a0f0e7b3..570c8091c708 100644
--- a/dev-embedded/sdcc/sdcc-3.8.0.ebuild
+++ b/dev-embedded/sdcc/sdcc-3.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -125,9 +125,4 @@ src_install() {
cd "${WORKDIR}"/doc
dodoc -r *
fi
-
- # a bunch of archives (*.a) are built & installed by gputils
- # for PIC processors, but they do not work with standard `ar`
- # & `scanelf` utils and they're not for the host.
- env RESTRICT="" prepstrip "${D%/}"/usr/bin
}
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index b2e7a0f0e7b3..4a113587a4d5 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -129,5 +129,8 @@ src_install() {
# a bunch of archives (*.a) are built & installed by gputils
# for PIC processors, but they do not work with standard `ar`
# & `scanelf` utils and they're not for the host.
- env RESTRICT="" prepstrip "${D%/}"/usr/bin
+
+ # TODO: use dostrip from EAPI=7 when subversion gets EAPI=7
+ # in bug #678344:
+ #dostrip "${D%/}"/usr/bin
}