summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-02-28 03:51:12 +0100
committerIan Delaney <idella4@gentoo.org>2016-02-29 00:27:24 +0800
commit0a7324282908dd7f4de6ceca0b78f424973acade (patch)
tree712f0faa41c06682ebadf90ec34045d8ee1eb7ca
parentapp-doc/doxygen: introduce slot-dependency on media-libs/libpng:0= (diff)
downloadgentoo-0a7324282908dd7f4de6ceca0b78f424973acade.tar.gz
gentoo-0a7324282908dd7f4de6ceca0b78f424973acade.tar.bz2
gentoo-0a7324282908dd7f4de6ceca0b78f424973acade.zip
net-p2p/airdcpp-webclient: new package, DC++ client, vn. 0.16.5
Package-Manager: portage-2.2.27 RepoMan-Options: --force
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild48
-rw-r--r--net-p2p/airdcpp-webclient/metadata.xml23
3 files changed, 72 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
new file mode 100644
index 000000000000..cbd055e98044
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -0,0 +1 @@
+DIST airdcpp-webclient-0.16.5.tar.gz 702187 SHA256 d153621ce390ee5d434a63d8af5d46b4b54638984de35ee8340ca63f27f61e16 SHA512 decc359aa569de8d3ae117a7f9ce38d9234564401072a776271ce7dff1e24022ad8d01fbf9cf4cc5238778c3c0cb7031b33e2e8d6a1014034ef507a8c29a6f7b WHIRLPOOL 3c71a391dd3e7a5defa5ec8a3abf580b5850abade28b763ad2548f0cc6df5345002c3a07e7e9db33abdedbd60740b62fc27fb0f8af5022353ac35cb826437e18
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild
new file mode 100644
index 000000000000..e7ca695037a4
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-0.16.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://github.com/airdcpp-web/airdcpp-webclient"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+webui"
+
+RDEPEND="
+ dev-libs/geoip
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-libs/openssl:0
+ dev-cpp/tbb
+ virtual/libiconv
+ net-libs/miniupnpc
+ dev-libs/leveldb
+ dev-cpp/websocketpp
+ dev-libs/boost
+"
+DEPEND="
+ net-libs/nodejs
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/airdcpp-webclient/metadata.xml b/net-p2p/airdcpp-webclient/metadata.xml
new file mode 100644
index 000000000000..36c434f643b7
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">airdcpp-web/airdcpp-webclient</remote-id>
+ <bugs-to>https://github.com/airdcpp-web/airdcpp-webclient/issues</bugs-to>
+ </upstream>
+ <longdescription lang="en">
+ AirDC++ Web Client is a cross-platform peer-to-peer file sharing client which allows sharing files with groups of people.
+ </longdescription>
+ <use>
+ <flag name="webui">Enable the Web UI</flag>
+ </use>
+</pkgmetadata>