summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-11-07 12:40:01 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-11-07 12:40:44 +0100
commit0cec7803fb50f0a81a0de86808fb4c691daecf0a (patch)
tree7c4d06b83f4a5b6aa5f0555e309907e76825b30a
parentdev-cpp/lucene++: fix building with Boost 1.58 (diff)
downloadgentoo-0cec7803fb50f0a81a0de86808fb4c691daecf0a.tar.gz
gentoo-0cec7803fb50f0a81a0de86808fb4c691daecf0a.tar.bz2
gentoo-0cec7803fb50f0a81a0de86808fb4c691daecf0a.zip
sys-boot/os-prober: Version bump
Package-Manager: portage-2.2.24
-rw-r--r--sys-boot/os-prober/Manifest1
-rw-r--r--sys-boot/os-prober/os-prober-1.70.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/sys-boot/os-prober/Manifest b/sys-boot/os-prober/Manifest
index b09ed0e674bb..234f557127f3 100644
--- a/sys-boot/os-prober/Manifest
+++ b/sys-boot/os-prober/Manifest
@@ -2,3 +2,4 @@ DIST os-prober_1.65.tar.xz 24712 SHA256 c4a7661a52edae722f7e6bacb3f107cf7086cbe7
DIST os-prober_1.66.tar.xz 24904 SHA256 ab66eab63223d651cb6f9221ddffc958521b13edee4996c4fd87f08cb1955057 SHA512 6aaa2787be9ea522ae71b8c65fc04bb05af233c81e2a8cd0c27b79d6f8c697c5585b5f5fce91c67eab3bbc782e29087fb22db2626609702ab272a398e59ce333 WHIRLPOOL 12d058e78ddd168938b0160b8a2348b497d24c17b99a30a34edcd3e663e8c57eded8d85d02d97c85ad936aadce123387c85dd9c3f0510bf200a9fbf632fd95bf
DIST os-prober_1.67.tar.xz 25092 SHA256 69d5b5f5ab9182025fda9cfd9f09be20f28ed6fe7ea07c26664d5e571ed355aa SHA512 bc05256d9e1ef808ccaf5a95e23a811f3086ad5b54b444b30b9b21e0c56c71f5c4a7dc69b5d2604ec90209f9a0ef1e00286da016f953f430a5c269a6dc75a718 WHIRLPOOL 5b88ed969d64555ee663a19572bfeaff8ecd3ca750765133791fe597f953394630b3a631c49733142775291ad61fedccec0090f26ab3017f0df2607fc49ad6ca
DIST os-prober_1.68.tar.xz 25336 SHA256 ad0b98c3e59239bff94e8f03bb618c21043c5314a7d00726d53f84add8478804 SHA512 b545cb42eb6e46da051aa7b63ec2cb29549aa197d0e0c361fa5d4a92ae3774c665003b4c1cd4294c9d26a63a71cd50cce75fed3be9d770adffeb0bd0b8cfc79e WHIRLPOOL a337446d1e6691d50b749fe3843452389845dbb5de5e06227baebd90b2535aa3111f7373f7c26335feef5637dc84ae5c1f0faa8bcaf97dfa4393129129e8cbf2
+DIST os-prober_1.70.tar.xz 25468 SHA256 f95a8998e106578edf105c42c84809c71e413a01370be9bd0b6d238d5b63bf1d SHA512 d060a7fd4e128693b1bb79cff014b4583f56fd0ed4fdd1afd9670623538c03c4e458697c85c753ef4746b1acc5f91e31ef1f0d83fcb696e35ae8355f16edd9a4 WHIRLPOOL 9414e27187223aa6cddf910bcf77f2b677bf1bef0b358b287a59dbbd2acb9a35060163d18c26808a97da061b8d3e77713e283de2d32e23188400fde975c607a7
diff --git a/sys-boot/os-prober/os-prober-1.70.ebuild b/sys-boot/os-prober/os-prober-1.70.ebuild
new file mode 100644
index 000000000000..35c50c608c4a
--- /dev/null
+++ b/sys-boot/os-prober/os-prober-1.70.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#inherit eutils multilib toolchain-funcs
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to detect other OSs on a set of drives"
+HOMEPAGE="http://packages.debian.org/source/sid/os-prober"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # use default GNU rules
+ rm Makefile || die 'rm Makefile failed'
+ # Fix references to grub-mount
+ sed -i -e 's:grub-mount:grub2-mount:g' \
+ common.sh \
+ linux-boot-probes/common/50mounted-tests \
+ os-probes/common/50mounted-tests || die
+}
+
+src_compile() {
+ tc-export CC
+ emake newns
+}
+
+src_install() {
+ dobin os-prober linux-boot-prober
+
+ # Note: as no shared libraries are installed, /usr/lib is correct
+ exeinto /usr/lib/os-prober
+ doexe newns
+
+ insinto /usr/share/os-prober
+ doins common.sh
+
+ keepdir /var/lib/os-prober
+
+ local debarch=${ARCH%-*} dir
+
+ case ${debarch} in
+ amd64) debarch=x86 ;;
+ ppc|ppc64) debarch=powerpc ;;
+ esac
+
+ for dir in os-probes{,/mounted,/init} linux-boot-probes{,/mounted}; do
+ exeinto /usr/lib/$dir
+ doexe $dir/common/*
+ if [[ -d $dir/$debarch ]]; then
+ doexe $dir/$debarch/*
+ fi
+ if [[ -d $dir/$debarch/efi ]]; then
+ exeinto /usr/lib/$dir/efi
+ doexe $dir/$debarch/efi/*
+ fi
+ done
+
+ if use amd64 || use x86; then
+ exeinto /usr/lib/os-probes/mounted
+ doexe os-probes/mounted/powerpc/20macosx
+ fi
+
+ dodoc README TODO debian/changelog
+}
+
+pkg_postinst() {
+ elog "If you intend for os-prober to detect versions of Windows installed on"
+ elog "NTFS-formatted partitions, your system must be capable of reading the"
+ elog "NTFS filesystem. One way to do this is by installing sys-fs/ntfs3g"
+}